success with WD20EURX-57T0FY0 man date 21 Jun 2015 in TCD652160

Discussion in 'TiVo Upgrade Center' started by sixpackd, Jan 13, 2016.

  1. sixpackd

    sixpackd New Member

    12
    0
    Sep 11, 2011

    Advertisements

    Hello

    With some recent posts regarding issues with EURX drives manufactured recently, I wanted to post my experience.

    I have 2 TCD652160, one upgraded, one stock. The upgraded hard drive died, so I purchased 2 new WD20EURX on Amazon on Jan 7.

    The model I received is WD20EURX-57T0FY0, with a 21 Jun 2015 Manufacture date from Thailand.

    I used winmfs, and neither worked in either TiVo.

    After some troubleshooting, I used HDAT2 from the UBCD, and found that the power-up in standby (PUIS or PM2) was enabled, even though documentation states that pins 3 and 4 need to be jumpered for this to be enabled.
    (Note, IntelliPark was not enabled on either drive)

    I proceeded to use HDAT2 to disable this feature, and now both drives happily work in both TiVos, with no visible issues. Both TiVos have 318hrs of HD space.

    Hope this helps others upgrading.
     
  2. unitron

    unitron Well-Known Member

    16,595
    62
    Apr 28, 2006
    semi-coastal NC
    You first posted about the PUIS problem probably the moment I'd gotten home from dropping off an EURX at UPS to go back to newegg :( :D

    Which means I may have missed my chance to use your solution.


    But at least you seemed to have figured out the problem, suspecting something of which I never would have thought.
     
  3. sixpackd

    sixpackd New Member

    12
    0
    Sep 11, 2011
    Just for all that are following this.

    Turns out the 57T0FY0 indicates that this is an OEM drive for a specific manufacturer that requires specific settings like enabling Power-up in Standby (PUIS or PM2) by default.
     
  4. HerronScott

    HerronScott Well-Known Member

    7,615
    1,131
    Jan 1, 2002
    Staunton, VA
    So was this drive really from Amazon or another vendor selling through Amazon?

    Scott
     
  5. jmbach

    jmbach der Neuerer

    3,192
    480
    Jan 1, 2009

    Advertisements


    That does make sense. Had a similar situation with a set of Seagate drives with almost exactly the same behavior. However, I wasn't astute enough to check the puis setting and all that Seagate would tell me that the drive was made for a specific DVR manufacturer.


    Sent from my iPad using Tapatalk
     
  6. sixpackd

    sixpackd New Member

    12
    0
    Sep 11, 2011
  7. unitron

    unitron Well-Known Member

    16,595
    62
    Apr 28, 2006
    semi-coastal NC
    So it was something that should never have been in the retail chain of supply.

    Thanks for nothing, WD.
     
  8. Unitary

    Unitary New Member

    4
    0
    Jan 26, 2016
    Thanks for posting!

    This saved me a bunch of trouble and can confirm that this fixed my constant booting problem on my Tivo Premier (all flashing lights) with my new drive. Similar to you I bought the WD20EURX directly from Amazon Jan19 and was the same model WD20EURX-57T0FY0 Thailand, June 23, 2015. Cloned, expanded, ect. but would not spin-up in the Tivo.

    Used HDAT2 off the UBCD to disable PUIS, and it now spins up immediately and boots just fine.

    Cheers!
     
    Last edited: Jan 27, 2016
  9. sbl

    sbl New Member

    15
    1
    Sep 13, 2005
    This was a big help, thanks. For the record, the drives I bought retail from buy.com (via Jet.com) came with PUIS enabled so it seems the mid-2015 production runs are being distributed this way through more than one online retailer.

    For the novices like me, HDAT2 can be found on the Ultimate Boot CD under: HDD> Diagnosis > HDAT2

    Once HDAT2 is running, select the drive you want to check the PUIS setting on, then select command menu > command feature sets. You should see 'Power-Up in Standby (PUIS) feature set' listed at the bottom with a status of enabled or disabled. If enabled, arrow down until the feature set is highlighted then hit return. It will ask for confirmation that you want to change the status. Enter Y to proceed with disabling PUIS.
     
  10. tivoROCKSme

    tivoROCKSme New Member

    103
    0
    Jun 23, 2003
    This is also a big help for me. I bought my WD20EURX from Amazon (not another seller) and I'm having the PUIS issue. I noticed the drive didn't feel like it was spinning. Anyway, I have made it to HDAT2, but it's not recognizing my drive. It's only showing FDD which is odd because there is no FDD in this pc. I'll keep trying different configurations but appreciate any assistance. I feel like I'm so close.
     
  11. tivoROCKSme

    tivoROCKSme New Member

    103
    0
    Jun 23, 2003
    Update !!
    I moved the UBCD and WD20EURX to a new pc and booted up. This machine gave me a new clue as I was still having trouble getting this drive to show up in HDAT2 on the previous machine. In the new pc HDAT2 told me to type 'hdat2.exe /W' to wake/spin drive and disable PUIS.
    It worked! After typing that command at the HDAT2 command prompt, the drive now has PUIS disabled.
     
    Last edited: Mar 4, 2016
  12. mtn_man

    mtn_man New Member

    2
    0
    Feb 24, 2016
    so glad this post was here - it got me past the dreaded flashing lights issue on a premiere 746 using a WD20EURX!
     
  13. NWFan

    NWFan New Member

    4
    0
    May 2, 2007
    FIXED - just like tivoROCKSme switching to another computer (at work) allowed me to disable power-up in standby on the drive.
    --------------------------------------------------
    Please help. I am unable to get to the menu in HDAT2 to disable power-up in standby. I have my WD20EURX-57T0FY0 connected to a desktop via SATA. I start HDAT2 with a the /w switch. The drive appears in the “Device list”. I then hit enter and select the Command menu and I am presented with View/Search device. I press enter and “Working...” appears at the bottom of the screen. After about a minute the following appears “ERROR at LBA 0: Drive not ready (command failed or time out)”

    Any thoughts? Thank you.
     
    Last edited: Mar 8, 2016
  14. JimWall

    JimWall Member

    104
    4
    Oct 19, 2002
    I just replaced a failing 2 TB Seagate on my old Series 3 HD with a 2 TB WD Blue from local Best Buy. Tivo would sit at powering up for a long time. Then I remembered the old WD idle issue. I put drive back in PC and booted old WD wdidle3.exe utility under free DOS. It was set to "park" after 8 seconds of inactivity. I did wdidle3.exe /D which set it to 60 minutes. Put drive back in Tivo and it worked with no issues. I don't have the HDAT2 utility but I will take a look at it.
     
  15. unitron

    unitron Well-Known Member

    16,595
    62
    Apr 28, 2006
    semi-coastal NC
    First time I've heard of a Blue running Intellipark.

    Apparently WD is going to mix the Blue and Green lines together so thoroughly that no one can be sure exactly what they're buying.
     
  16. viggin

    viggin New Member

    6
    3
    Oct 9, 2011
    I just successfully put a WD20EURX into my Premiere Elite. I did have to disable PUIS. I forgot to note the manufacture date but I think it was very close to the drive in the top of this thread -- ~June 2015.

    Here is somewhat more of a guide to how to do this -- I had to pull together some information from a few other places on the internet so I thought I'd post this to elaborate a little on sixpackd's post which opened this thread.

    I also used HDAT2 from UBCD to disable.

    I created a bootable UBCD USB thumb drive using unetbootin

    1- Download UBCD ISO image
    2- Use unetbootin to transfer ISO onto thumb drive


    I was originally using a laptop and I could not get HDAT2 to recognize the drive in my particular SATA to eSATA / USB3 dock. I have another SATA<>USB adaptor somewhere, but instead I just temporarily ripped apart my PC-based home server. HDAT2 now recognized that the drive had PUIS enabled and gave me directions on how to disable it.

    1- Put WD20EURX into PC server.
    2- Boot from UBCD and navigate HDD>Diagnostics>HDAT2
    3- HDAT2 recognize that the HD20EURX has PUIS enabled and spits out directions on how to disable. I believe I had to type "hdat2.exe /W" which woke the drive, and then HDAT2 disabled PUIS automagically without needing to issue any other commands.

    Finally, I used ddrescue, also on UBCD, to copy the drive.

    Connect the destination drive (WD20EURX for me) to your system if you haven't already.

    From UBCD, run "parted magic" (On the UBCD main menu) using "Default Settings" (A prompt pops up after you pick parted magic).

    After parted magic loads you need to determine where the drives are mounted. I just clicked the "Drive Health" icon on the Parted Magic desktop which can provide this information.

    Then open the Linux terminal within Parted Magic (It's the computer screen with $_ icon on the bottom of the screen) and run ddrescue.

    I'll let you figure out the ddrescue syntax yourself. I was following a tutorial that wanted me to image the (presumably) failing drive and then copy that image back to the new drive. I didn't have time or space for that, so I went ahead and just did a direct clone -- checking about 9 times before I hit "enter" that I had my "source" and "destination" drives set right, lest I clone the new/empty western digital drive onto my failing TiVo drive.

    In my case everything went without a hitch. ddrescue didn't even seem to hit any speed bumps, so either the drive isn't failing at all and I have a different problem -or- (More likely I think) the drive was still healthy enough that a single, sustained, sequential read didn't cause any indigestion.

    Anyway pop the new drive in the TiVo and so far so good. I'll pop back in here if I have any issues.
     
    schwinn likes this.

Share This Page

spam firewall

Advertisements