1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. HerronScott

    HerronScott Well-Known Member

    6,153
    679
    Jan 1, 2002
    Staunton, VA
    What folder do you have Streambaby located in and what account are you running the service with?

    Scott
     
  2. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    I hadn't tried service mode for a long time, but it still works for me on Windows 10. A couple of important things:
    1. Run as administrator the service installer
    2. Once service is installed you need to find the service and change to use your account for login instead of the default service account.
     
  3. CaptainTiVO

    CaptainTiVO Member

    36
    0
    Nov 3, 2001
    Austin, TX, USA
    The Streambaby folder is here: C:\Users\Hunter\Documents\bin\streambaby-0.54\
    I installed the service using "Run as Administrator". I then changed the "Properties\Logon" to my user account.
    Unfortunately, I get the same errors.
    Also, I just noticed this caveat: "Note: Windows services by default don't have access to network drives, so if any of your videos are on network drives you will have a problem. (Same goes but worse if the streambaby app is installed on a network drive)"
    Of course, all my media files are on mapped network shares :-(.

    Is this the problem? I did some searching and found some solutions to this, most requiring a bit more programming than I know in Windows (Map a network drive to be used by a service)
     
  4. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    Well you should first try with non-network drives just to eliminate that as a factor. If it works that way, then for network shares maybe you could try using UNC format instead of mapping. So, for example this format instead of mapping to a volume name:
    \\server\path\to\share
     
  5. CaptainTiVO

    CaptainTiVO Member

    36
    0
    Nov 3, 2001
    Austin, TX, USA
    OK, so I tried with local dirs, and UNC network share. Both work fine when started manually but both fail when installed as a service. I tried Googling "error 1067" and did not find an answer. I tried disabling anti-virus and windows firewall. Same error. Has anyone got this to work on Windows 7?
     
  6. superflysocal

    superflysocal Member

    79
    1
    Nov 26, 2009
    I have a tivo Roamio Pro and I don't have hydra but I cannot seem to get to Streambaby. I thought the HME was broken even without Hydra but now there are people here saying that it's only broken in Hydra. Can someone please clarify?

    Edit: Nevermind i found it. It is at the bottom of the list after all of the regular apps.
     
    Last edited: Mar 18, 2018
  7. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    See following which describes how to reset HDUI which may be what you need (assuming you have streambaby running and you are not using VPN):
    Streambaby - new streaming application
     
  8. superflysocal

    superflysocal Member

    79
    1
    Nov 26, 2009
    Nevermind i found it, it was at the bottom of the list. Apparently it was fixed with 20.7.4.

    I haven't messed with SB for a while because i thought it was dead. Do we still need to disable mp4.module for it to work?
     
  9. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    0.54 version of Streambaby disables mp4.module internally.
     
  10. fyodor

    fyodor Active Member

    659
    36
    Sep 19, 2006
    Am I correct that Streambaby does not support 4K content?
     
  11. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    If the ffmpeg you are using with streambaby can handle transcoding 4K content on the fly to mpeg2 it may work, but I've never tried.
     
  12. jcthorne

    jcthorne Well-Known Member

    3,016
    124
    Jan 28, 2002
    Houston
    The Bolt does not really support 4k all that well. Does not do HDR video at all and very limited on bit rate in 4k resolution. A very poor 4k streamer. Its not streambaby, its the bolt.

    There is also no way to upload 4k content to the Tivo hard drive to play locally either.
     
  13. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    Yes, but remember streambaby is transcoding all H.264 video now anyway since TiVo broke streaming of H.264 video, so any non-mpeg2 video is transcoded by streambaby anyway. So theoretically if the 4K content in question can be transcoded on the fly by ffmpeg in better than real time then it could work with streambaby.
     
  14. fyodor

    fyodor Active Member

    659
    36
    Sep 19, 2006
    Right-I was looking to play it natively. I understand that this is a limitation on the Tivo end, not the software end, but I just wanted to make sure before proceeding with other solutions.
     
  15. jcthorne

    jcthorne Well-Known Member

    3,016
    124
    Jan 28, 2002
    Houston

    Can ffmpeg even convert 4k HDR video encoded with HEVC to mpeg2? Even in less than real time? I do not think any of the video tools have mastered 10bit color to 8bit recode and preserve a reasonably accurate color space. Its not a matter of processing power.

    Then, if one had a 4k 8bit video file in mpeg2 format, could streambaby even stream it? Would be a pretty high bit rate using mpeg2 and do not know if Tivo can even display that. Has any one tried?

    I can tell you a 4k 8bit video in mpeg2 will not transfer and play using pytivo.
     
  16. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    If pyTivo can't do it then neither will streambaby.
     
    thewebgal likes this.
  17. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,018
    143
    Jul 9, 2001
    Central Jersey
    Hi Kevin,

    I'm attempting to run two simultaneous instances of Streambaby on two physically different PCs - a laptop and a desktop. In Streambaby.ini, I have them named differently (title=) so that on the TiVo Apps screen I see two separate entries, but whichever instance I start first is the only instance that both links on the TiVo Apps screen resolves to. I get the same results if I re-launch Streambaby via kmttg on the respective PC.

    I have DEBUG turned on and I even wait for the "HME receiver has disconnected" to no avail. The only way to get the second instance recognized is to stop the first. Is this a limitation of HME?
     
  18. moyekj

    moyekj Well-Known Member

    11,818
    518
    Jan 23, 2006
    Mission...
    I don't think it's an HME limitation, rather something in streambaby probably. I didn't write most of streambaby and haven't looked at the code for a long time, so don't really know for sure...
     
  19. vanclute

    vanclute Member

    218
    8
    Aug 3, 2003
    FYI I used to run two SB servers in our home, and in the last couple of years it stopped behaving reliably. One would show up consistently, one would show up sometimes. If it would show, it would usually be after going into TiVo settings and re-fetching the DHCP IP. Even that wasn't a 100% solution though. I finally gave up and now we run one SB instance, that simply mounts the other server's drive over the network and uses it that way. It's convoluted, especially if the remote machine reboots as the remote volume won't automatically re-mount. But it's the only reliable way I've been able to have two separate machine's drives show up.

    This used to work, but something happened that broke it. My money is on one of the many TiVo updates.
     
    wkearney99 likes this.
  20. reneg

    reneg Active Member

    951
    114
    Jun 19, 2002
    I'm way, way back on the 0.30 version of Streambaby. I am running one instance of Streambaby on two different computers without issue. The .ini files are pretty much the same except the title.

    Occasionally, only one of the instances is listed on the Tivo. A quick Tivo UI reset (thumbs down, thumbs up, play, play) fixes that and both instances are listed after the UI reset.
     

Share This Page