1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    745
    77
    Jul 9, 2001
    Central Jersey
    Congratulations on your *FIRST* LIKE in (almost) 17 years! :clapping:

    I've just begun playing around with Streambaby myself, along with the kmttg 'Web Server' (which reminds me that Kevin still hasn't answered my 'Web Server' question from OVER a week ago. :eek::confused: )

    And, besides just getting into switching over to 'Managed Switches' (unintended word play) for QoS, VLANs and VPNs are on my 'Round Tuit' list (for learning and experimenting)...
     
  2. May 1, 2017 #3462 of 3520
    vanclute

    vanclute Member

    182
    4
    Aug 3, 2003
    Holy crap my first like? Really?? That's hilarious... shows how much I pay attention to such things, I had no idea. Man I've been around these forums a long time. Good grief. Obviously signed up when I got my first TiVo. Time sure flies...

    I played with kmttg for a while years ago, it was really quite cool but I didn't have the patience to set it all up to run unattended etc. Especially when I discovered that other people have already done all that work and post the torrents online anyway! Not worth the hassle. :D Didn't know there was a web server version now though... that's intriguing. I do not however, need another project! LOL
     
  3. May 1, 2017 #3463 of 3520
    vanclute

    vanclute Member

    182
    4
    Aug 3, 2003
    Well crap, so much for that theory. Back to where I was before... seems as though everything suddenly working was just a byproduct of having rebooted everything. Guessing the VPN just wasn't engaged yet when I checked. Now StreamBaby won't show up again on any of the TiVos (2 premieres and a Roamio). The roamio is even behind the same router as the media mac, so in theory if this were any kind of router issue blocking outside traffic, that would be the one TiVo that would always work. But it doesn't either.

    This definitely looks to be the fault of Tunnelblick routing all non-browser traffic through itself and interfering with SB. Does anyone have any idea if it's possible to "whitelist" or "blacklist" tunnelblick for specific applications or ports? I've been researching but so far haven't found any info that seemed like it would work, and I could understand enough to implement it.
     
  4. May 2, 2017 #3464 of 3520
    dchomak

    dchomak New Member

    20
    0
    May 3, 2015
    I tried your suggestions and it works with the dir /s command but not with the search within Windows Explorer or Streambaby.

    Any ideas?
     
  5. leswar

    leswar leswar

    133
    3
    Apr 14, 2005
    Vero Beach
    With the latest 20.7.2.RC22 release streambaby app no longer appears anywhere on my two updated Roamios.
    Still operational on my one Bolt running 20.7.1.RC2. Fear its coming update.

    Does this mean we have lost streambaby like similar functionalities lost in previous updates (i.e. no music streaming via pyTiVo on Roamios).

    I love streambaby video quality and subtitles - superior to anything else. Hate to see it end. Say it isn't so.
     
  6. moyekj

    moyekj Well-Known Member

    11,528
    213
    Jan 23, 2006
    Mission...
    I can confirm on my TiVo Elite that got this horrible looking 20.7.2.x update that local HME apps no longer appear in the menu. I suspect for series 4 units that still have the ability to run SDUI one could switch to SDUI to run HME apps such as streambaby, but for all intensive purposes yes this update eliminates local HME app functionality completely!
     
    bwhitney likes this.
  7. lpwcomp

    lpwcomp Well-Known Member

    9,018
    188
    May 6, 2002
    John's...
    Have you tried "Add an App"?
     
  8. leswar

    leswar leswar

    133
    3
    Apr 14, 2005
    Vero Beach
    add an app produces an unexpected server error msg_v310 id.
    Never really understood "add an app" or could get it to see my pc in the past, anyhow.
     
  9. moyekj

    moyekj Well-Known Member

    11,528
    213
    Jan 23, 2006
    Mission...
    "Add an App" theoretically should work for an IP hosted on WAN side (i.e. outside your LAN), but doesn't work for LAN hosted HME apps.
     
  10. reneg

    reneg Member

    797
    24
    Jun 19, 2002
    HME was broken in the early releases of 20.7.1 and it was fixed before the final release. Can only hope they fix it again.
     
  11. Aug 6, 2017 #3471 of 3520
    natallica

    natallica Member

    83
    1
    Jan 10, 2005
    Fairfax, VA
    I hope there's an eventual fix for this.

    TiVo Elite can no longer see streambaby in the menus unless I switch to the SD UI and even then if I select streambaby it just hangs on "One Moment..."

    Is there any workaround to run streambaby with the new OS?
     
  12. Aug 6, 2017 #3472 of 3520
    moyekj

    moyekj Well-Known Member

    11,528
    213
    Jan 23, 2006
    Mission...
    Just tried on my Elite and from SDUI streambaby appeared and ran fine for me.
    So at least series 4 that have SDUI option streambaby is still available and works.
     
  13. Aug 7, 2017 #3473 of 3520
    natallica

    natallica Member

    83
    1
    Jan 10, 2005
    Fairfax, VA
    I had to reboot and then it worked. Guess I'll be switching between UIs for now. The SDUI now looks bizarre for every day use.
     
  14. Patrick2050

    Patrick2050 New Member

    16
    1
    Aug 11, 2017
    No streambaby on my Roamio running 20.7.2.RC24.
     
    Last edited: Aug 22, 2017
  15. moyekj

    moyekj Well-Known Member

    11,528
    213
    Jan 23, 2006
    Mission...
    Look up a few posts. TiVo broke access to local HME apps. Only way to get to them is with SDUI on series 4 units. Series 5 and later are SOL.
     
  16. lpwcomp

    lpwcomp Well-Known Member

    9,018
    188
    May 6, 2002
    John's...
    There was a slim hope that it would be restored by RC24. Alas, no joy.
     
  17. moyekj

    moyekj Well-Known Member

    11,528
    213
    Jan 23, 2006
    Mission...
    Actually, all hope is not lost. I just verified you can still launch via kmttg Remote tab, Remote sub-tab, choose "streambaby" next to "Launch App" button and then press the button. i.e. TiVo only broke access to launching HME apps, the apps themselves run fine once launched.

    So there is still an (inconvenient) way to run streambaby for those that really want to.
     
    ClearToLand and Mikeguy like this.
  18. reneg

    reneg Member

    797
    24
    Jun 19, 2002
    Kevin, thanks for pointing that workaround out.

    I still have a trouble ticket open with Tivo on the "Add an App" functionality. I'm not convinced that they will resolve the issue, but my trouble ticket is now in "escalated" status (whatever that means). I did get two phone calls about the issue from someone at Tivo that clearly had no idea what "Add an App" did. I tried to explain as plainly as I could so a SW engineer might find the information useful, but without visibility into the trouble ticket, I don't know how much useful information actually was entered by that person.
     
  19. moyekj

    moyekj Well-Known Member

    11,528
    213
    Jan 23, 2006
    Mission...
    If things are truly working properly though, "Add an App" is not necessary for local HME apps. So I would say "Add an App" being broken is yet another thing not working, along with local HME apps not appearing in the list of Apps.
     
  20. thewebgal

    thewebgal MacAphile AV geek

    434
    14
    Aug 10, 2007
    DC 'burbs
    Last edited: Aug 22, 2017

Share This Page