Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. MacGuruTX

    MacGuruTX Member

    49
    0
    Sep 19, 2006
    San Diego, CA

    Advertisements

    memory worked great, thank you!

    Next random question: Historically I've been double saving my media files. Once to an external drive and movies folder that has always worked correctly.

    i wanted to start also sharing my iTunes Tv shows folder, This way I can get to shows that i sync with my ipad without having to put them in two places.

    I have the following ini settings
    dir.1=/Volumes/Media Storage/TiVo-Shows
    dir.1.name=My Videos
    dir.2=/Volumes/Texas/Users/macgurutx/Music/iTunes/"iTunes Media"/"TV Shows"
    dir.2.name=iTunes TV

    The Directory 2 path shows up on the streambaby menu, but for some reason is says no files present? When I look at this folder from the OS cmd line using that string, it goes to the correct root Tv Shows folder. I see a series of folders there organized by itunes and the folders (show names) contain .m4v files.

    Any suggestions on this one?
     
  2. moyekj

    moyekj Well-Known Member

    12,179
    828
    Jan 23, 2006
    Mission...
    That hybrid path specification looks strange with quotes in the middle.
    Get rid of the quotes in the path (around iTunes Media and TV Shows).
     
  3. MacGuruTX

    MacGuruTX Member

    49
    0
    Sep 19, 2006
    San Diego, CA
    For anyone else with the issue, in OS X you have to use Quotes to deal with the spaces in the folder names. Although

    /Volumes/Texas/Users/macgurutx/Music/iTunes/"iTunes Media"/"TV Shows"

    works from the command line, it doesn't with streambaby.

    if you instead quote the entire path, then it will work correctly
    ie:
    "/Volumes/Texas/Users/gregmiddleton/Music/iTunes/iTunes Media/TV Shows"
     
  4. Apr 1, 2016 #3324 of 3662
    fcfc2

    fcfc2 Well-Known Member

    2,587
    548
    Feb 19, 2015
    I finally got my files to show up, but all of them show the same error, "ERROR: 0xffff" when I attempt to play them. All of the one's I have tried so far are .mp4's. Suggestions, please and thank you.
     
  5. Apr 1, 2016 #3325 of 3662
    moyekj

    moyekj Well-Known Member

    12,179
    828
    Jan 23, 2006
    Mission...

    Advertisements

    First of all you aren't trying to stream to a Mini are you? Because that's not supported. If you are streaming to a DVR not a Mini add the following to your streambaby.ini file and restart Streambaby to see if it helps:
    mp4module.interleave=false
     
  6. Apr 1, 2016 #3326 of 3662
    fcfc2

    fcfc2 Well-Known Member

    2,587
    548
    Feb 19, 2015
    Of course I was.....Sorry.
     
  7. Apr 8, 2016 #3327 of 3662
    Rodney

    Rodney TiVo'd since 9/17/01

    115
    12
    Jan 26, 2002
    The...
    I upgraded my Mac to El Capitan last weekend, losing Pytivox. Since I was only using the Streambaby portion anyway, I downloaded .49 from SourceForge and it works like a charm!

    Thanks Moyekj for this!
     
  8. dchomak

    dchomak New Member

    27
    0
    May 3, 2015
    Streambaby continues to work flawlessly.
    I was wondering, is there a way for the search function to search more than 1 drive at a time? Maybe a DOS command?
     
  9. az1097

    az1097 Member

    87
    3
    Apr 3, 2013
    I just downloaded the latest version 0.49, extracted and configured but when I run, it says "java is not recognized as an internal or external command, operable program or batch file". Why is it not running correctly?
     
  10. moyekj

    moyekj Well-Known Member

    12,179
    828
    Jan 23, 2006
    Mission...
    You don't have java path in your PATH variable. Edit streambaby.bat (if on Windows) and substitute java for full path to java.exe such as:
    "C:\Program Files (x86)\Java\jre1.8.0_77\bin\java.exe"
     
  11. May 2, 2016 #3331 of 3662
    ehagberg

    ehagberg Member

    97
    1
    Dec 27, 2004
    Montclair, NJ
    I'm trying to use the latest streambaby and have set up a simple config file with no special settings at all yet (had to specify the ip= parameter)... and I've enabled debugging as described in the wiki, but after streambaby starts up and sees my tivo, I go to my tivo and click on streambaby and get the "V301" error saying I should try again in a few minutes. And nothing is logged by the app when I'm trying to access it from the tivo.

    Well, that was yesterday afternoon, and evening. I rebooted the tivo to see if that would help... but it didn't. So I tried many different versions of java, as some have claimed that they needed to use older java versions in the past... and that also didn't solve things.

    Anyway - any ideas on what else I should check? This is running on linux - Fedora 23 - btw.

    Thanks,
    -Eric
     
  12. chrispitude

    chrispitude New Member

    518
    0
    Apr 23, 2005
    Hi all,

    We LOVE Streambaby! It has singlehandedly made it possible for us to migrate all our kid DVD/Blu-ray movies onto my Linux fileserver, and with a simple kid-friendy TiVo interface.

    Until now, I've only ripped our DVD movies. Recently I bought a Blu-Ray drive and started ripping Blu-Ray discs with MakeMKV. The resulting .mkv files play flawlessly on the Linux box.

    Streambaby shows the .mkv files. When I attempt to play them, they start playing just fine. The Streambaby console shows transcoding via ffmpeg. However, somewhere between 10-30 minutes into the title, the video and audio will start skipping. Then usually, playback freezes, the screen goes black, and the TiVo restarts itself.

    If I choose "Quality: Medium" instead of "Quality: Same" when playing the .mkv, it always plays back in its entirety with no issue.

    So my questions are:

    1. How do I debug the lockups, especially given that it's transcoding at either quality?
    2. Is there a way to process/demux/etc. the .mkv file to allow direct (non-transcoded) playback of the video and audio streams?

    Thanks!! Again, our family LOVES this application!
     
  13. moyekj

    moyekj Well-Known Member

    12,179
    828
    Jan 23, 2006
    Mission...
    Don't know how to debug a TiVo lockup. But perhaps easiest thing to try is to set the default quality setting to be below "same". Quality Wiki is:
    https://sourceforge.net/p/streambaby/wiki/QualitySettings/

    So you could try something like this in your streambaby.ini file:
    quality.default=6

    This only affects quality of transcodes. Compatible videos that are not transcoded are not affected. So by setting the above it would be equivalent to manually choosing quality below same which you said seems to work when playing the mkv files, without having to manually set quality each time when playing them.
     
  14. jonw747

    jonw747 Active Member

    637
    32
    Aug 2, 2015
    So, another option for him would be to encode his videos so they are compatible with the TiVo and take the load off his server. Although, there may be space/bitrate .vs. quality trade-off to be made.
     
  15. chrispitude

    chrispitude New Member

    518
    0
    Apr 23, 2005
    I appreciate the suggestion! The server is a pretty fast machine (i7-4790k) with plenty of storage space, and the transcoding load doesn't stress the machine much. For now, I'm storing everything in original quality.

    Thanks! This gives me some ideas to try.

    I do have a question. When I select one of these .mkv files from the selection interface, the title information does not show the bitrate. However, an "ffmpeg -i" of the .mkv file does show the bitrate:

    Code:
    Input #0, matroska,webm, from 'Cloudy_With_A_Chance_Of_Meatballs.mkv':
      Metadata:
        title           : Cloudy With A Chance Of Meatballs
        encoder         : libmakemkv v1.9.9 (1.3.3/1.4.4) x86_64-linux-gnu
        creation_time   : 2016-04-13 01:45:17
      Duration: 01:29:53.39, start: 0.000000, bitrate: 32350 kb/s  <------
        Chapter #0:0: start 0.000000, end 287.370417
        Metadata:
          title           : Chapter 01
        Chapter #0:1: start 287.370417, end 536.577708
        Metadata:
          title           : Chapter 02
        Chapter #0:2: start 536.577708, end 872.788583
        Metadata:
          title           : Chapter 03
        Chapter #0:3: start 872.788583, end 1230.229000
        Metadata:
          title           : Chapter 04
        Chapter #0:4: start 1230.229000, end 1465.547417
        Metadata:
          title           : Chapter 05
        Chapter #0:5: start 1465.547417, end 1843.132958
        Metadata:
          title           : Chapter 06
        Chapter #0:6: start 1843.132958, end 2189.604083
        Metadata:
          title           : Chapter 07
        Chapter #0:7: start 2189.604083, end 2569.900667
        Metadata:
          title           : Chapter 08
        Chapter #0:8: start 2569.900667, end 2796.794000
        Metadata:
          title           : Chapter 09
        Chapter #0:9: start 2796.794000, end 3163.535375
        Metadata:
          title           : Chapter 10
        Chapter #0:10: start 3163.535375, end 3307.429125
        Metadata:
          title           : Chapter 11
        Chapter #0:11: start 3307.429125, end 3642.722417
        Metadata:
          title           : Chapter 12
        Chapter #0:12: start 3642.722417, end 3943.105833
        Metadata:
          title           : Chapter 13
        Chapter #0:13: start 3943.105833, end 4383.754375
        Metadata:
          title           : Chapter 14
        Chapter #0:14: start 4383.754375, end 4665.243917
        Metadata:
          title           : Chapter 15
        Chapter #0:15: start 4665.243917, end 5393.388000
        Metadata:
          title           : Chapter 16
        Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc
    Is this reported in a different form than streambaby is looking for?

    I also noticed that the transcoding command line for "Quality: High" has "-s 1312x736". Is it intended that even the highest non-same quality reduces the resolution below 1080p?

    Thanks!
     
  16. moyekj

    moyekj Well-Known Member

    12,179
    828
    Jan 23, 2006
    Mission...
    In the quality settings link I gave above it looks like there are settings to control transcoding resolution, for example:
    quality.highres= (default: 720)

    Note that video files in mkv container cannot be streamed natively because TiVo doesn't accept mkv container period, so streambaby will always transcode those to mpeg2. Even if you did remux to mp4 container chances are the video bit rates are too high for TiVo to handle anyway. So you are probably better off letting it transcode, but you can play with the quality settings to raise the resolution, bitrate, etc.
     
  17. jonw747

    jonw747 Active Member

    637
    32
    Aug 2, 2015
    Animation compresses really well. It makes some sense to re-encode the movies your kids are going to be watching over and over and over in to a TiVo friendly format, and then put those in your StreamBaby folder. 2M-5M bps should still look awfully good.
     
  18. chrispitude

    chrispitude New Member

    518
    0
    Apr 23, 2005
    So I made some progress on the crashes! I took the "Same quality" ffmpeg command line and converted the .mkv to .mpg in linux. That .mpg file played without transcoding through Streambaby, but crashed the Roamio in the same way. So the problem was with the Roamio's handling of the mpeg file.

    I found a freeware utility to plot the dynamic bitrate of the file (first attachment). Average bitrate 12812kbps, peak bitrate 88691kbps!

    So I added only "-maxrate 25000k" to the ffmpeg command line and reencoded, and got the results shown in the seconds attachment. The peak bitrates are all nicely limited to 25000kbps now! And the Roamio plays the file back through Streambaby flawlessly.

    So the question now becomes, how do I add "-maxrate 25000k" to the default "Same quality" command line?
     

    Attached Files:

  19. moyekj

    moyekj Well-Known Member

    12,179
    828
    Jan 23, 2006
    Mission...
    Check the Wiki. There are a few ini settings that control what ffmpeg options are used for transcode:

    ffmpegexe.transcode= (default:-acodec ac3 -vcodec mpeg2video -f vob -async 1 -r ${closest.mpeg.fps} -v 0)

    ffmpegexe.transcode.sameqargs (default: -qscale 0 -ab 192k)

    ffmpegexe.transcode.qualargs (default: -bufsize 4096k -b ${bitrate}k -maxrate 8000k -ab ${abitrate}k -s ${xres}x${yres})

    So you can probably set this for same quality transcodes:
    ffmpegexe.transcode.sameqargs=-qscale 0 -ab 192k -maxrate 25000k
     
  20. moyekj

    moyekj Well-Known Member

    12,179
    828
    Jan 23, 2006
    Mission...
    FYI, I released new 0.50 version with above change to add -maxrate 25000k to default ffmpegexe.transcode.sameqargs setting.
     

Share This Page

spam firewall

Advertisements