Strange HW Issue with Tivo Roamio; persistent reboot cycle

Discussion in 'TiVo Help Center' started by tom326, Apr 21, 2016.

  1. tom326

    tom326 New Member

    1
    0
    Apr 21, 2016

    Advertisements

    I bought my first (and only Tivo), a Roamio model TCD846500 (the base version, 0.5 TB HD, can do cable or OTA) not quite 3 years ago, with lifetime subscription based on the rave reviews from a friend and longtime Tivo user.

    A few weeks ago it got into a cycle of constant reboots (green led and the initial starting screen on TV, the amber light flashes a bit, then looks like reboots, and just keeps doing this). It eventually (after quite a few hours of this), successfully booted, and worked for a little while, but soon all video was badly pixelated. I tried rebooting to see if it would fix it,
    but now is continually in this reboot cycle.

    Some googling suggested these symptoms were likely to be a bad hard drive, and the forum suggested replacement is easy. I tried installing a 250 GB SATA drive I had lying around just as proof of concept before ordering a new drive, but no avail. I also checked, and the original drive seems to be working (attaching drive to a linux PC, I was able to do SMART tests which passed and read the entire disk using dd).

    More googling, and I found a list of kickstart codes for the Tivo, and with both the original 0.5 TB and the test 0.25 TB drives, tried a variety of codes (e.g. the weeknees page tivo-kickstart-codes.php) without avail. Indeed, the kickstart codes did not appear to do _anything_; the start up screen appears, the amber light flashes, I press pause for 2 secs, the amber light stops flashing and is steady, I enter the code, the green and amber lights alternate for a while, then the system just returns to the previous reboot cycle. In particular, code 57 does not result in a GSOD (not even sure what that looks like, but not seeing it), code 54 does not give SMART test screen, codes 51/52 do not give the sw install page shown, the dial-in codes do not display dial-in page (not that I have a phone plugged into the Tivo anyway).

    Any help would be appreciated. Right now I have a _very_ expensive black paperweight.:(
    Any suggestions?
     
  2. ej42137

    ej42137 Well-Known Member

    3,742
    573
    Feb 15, 2014
    Los Angeles
    I suggest this is not a hard drive problem, but you probably know that. Try calling TiVo and asking how much it would cost for them to repair it. (I'm sure others would be interested in the result.)

    The other alternative would be to ask Weaknees to attempt a repair.
     
  3. unitron

    unitron Well-Known Member

    16,594
    62
    Apr 28, 2006
    semi-coastal NC
    Find someone who knows something about electronics to see if the power supply is performing as it should just to eliminate it as a possible cause of trouble. They can be less than they need to be without being completely dead so that you get a TiVo that works but doesn't work correctly.
     
  4. foghorn2

    foghorn2 Well-Known Member

    1,488
    454
    May 4, 2004
    Las Vegas
    Yeah, check the power adapter first, if you are using a cable tuning adapter and its a Cisco STA1520, use its power supply and test.
     

Share This Page

spam firewall

Advertisements