Soundbar audio problem

Discussion in 'TiVo Help Center' started by Jeffkics, Apr 6, 2020.

  1. Jeffkics

    Jeffkics New Member

    4
    0
    Apr 6, 2020
    Here is my setup
    Hdmi from tivodvr to soundbar input
    Hdmi arc out to hdmi arc input on tv.

    I get a 5 second delay of audio when changing channels. Video comes right on but audio comes in after.
    Also if I press tivo button, video comes up in top right but audio cuts out for 5seconds again. If I go to settings it happens again. If I goto my shows it happens again. I press back it happens again. You get the point.
    Any ideas?
    Only thing I did was change the pcm / Dolby setting and that did not help.
    Thanks in advance.
     
  2. NorthAlabama

    NorthAlabama tabasco rules

    10,686
    2,605
    Apr 19, 2012
    sweet home, al
    if your sound bar has an optical audio input, try running an optical cable directly from the tivo to your sound bar.
     
  3. Jeffkics

    Jeffkics New Member

    4
    0
    Apr 6, 2020
    Ok I tried that and it does the same thing.

    I disconnected the arc hdmi just to make sure the optical was working and it was.
     
  4. Jeffkics

    Jeffkics New Member

    4
    0
    Apr 6, 2020
    I just made a change to see what happen.
    I ran the hdmi from tivo directly to tv, and then I did optical out of tv to my soundbar.
    This configuration works without any audio delay.
    But now I cant use the arc features of my soundbar. Like power on off with tv, volume control with tivo, etc.
    Any ideas of what this can be and how to fix it.
    Sony ht-xt1 soundbar
     
    Last edited: Apr 6, 2020
  5. NorthAlabama

    NorthAlabama tabasco rules

    10,686
    2,605
    Apr 19, 2012
    sweet home, al
    :up:
    have you tried programming the tivo remote to operate both the tv & soundbar? this works for my tv & avr, flawlessly (the options are in the remote programming menu in your tivo).

    in my experience, using arc in the setup is hit or miss, sometimes it works, other times it doesn't, and sometimes it works for a while then stops working unexpectedly - for this reason, i gave up trying to use arc a long time ago.
     
  6. Jeffkics

    Jeffkics New Member

    4
    0
    Apr 6, 2020
    It worked with my old tivo, I just upgraded to the new voice controlled one.
    I programmed the remote for my soundbar so it is working this way. However I have alexa turn my tv on and off which wont turn the soundbar on or off without the arc.
     
  7. mblloyd

    mblloyd Member

    61
    1
    Feb 11, 2007
    Mercer...
    Maybe you are getting closer. How about this lash up which solved my same problem.
    (Roku Series 6 TV and Denon sound bar)
    HDMI CABLE from TiVo to HDMI #1 on your TV.
    HDMI cable from TV’s HDMI/ARC to sound bar.
    If you do’t get your desired result, maybe your HDMI cables need to be upgraded to include the audio connections. —Which were originally lacking in my case.
     

Share This Page