SO3 Error Fixed and New 2TB HD EURX installed

Discussion in 'TiVo Series3 HDTV DVRs' started by sanjonny, Apr 23, 2016.

  1. sanjonny

    sanjonny Member

    210
    1
    Nov 2, 2008

    Advertisements

    First of all, Thanks to Unitron and SBL and others. This is all recent and redundant, but all in one writeup with links to more info. To update the drive you will need Winmfs, Ultimate Boot CD (if PUIS see below) and i did it on windows 10 machine.

    Background: I had upgraded my tivo to a 2TB drive but using the old directions so it could only see 1.2 TB and the drive never worked right. I also had the original 500GB drive and a new 1TB drive that I had imaged and replaced. FYI the 1TB drive was a WD BLUE and seemed to work fine. Its this model

    http://www.amazon.com/Blue-Desktop-...1&redirect=true&ref_=oh_aui_search_detailpage

    It shipped with intellipark disabled and worked fine out of the box.

    I took out the 2TB drive and using the original 500 GB drive made an image and then restored that to a new 1TB drive (the blue) about a month ago and that all worked wonderful (Some learnings will be below but we are still on background) I also set aside the OLD 2TB (that was only 1.2TB) and it sat for a month.

    So I started get S03 errors WHICH WERE NOT THE HARD DRIVE! Because I had used the old drive image from years ago, it had not run garbage collection and it had not run it for 2 years (since I used an old image to create) So basically it was updating the guide but had not cleaned up the garbage for years because of the old image. So what did I do but pull the new drive and put the old one in (the 2TB that was 1.2) and since the old but working when I pulled it drive had sat for a month or more, it also threw the S03 error. This was because it too had not done garbage collection in awhile.

    Do NOT run Repeat Guided Setup. Do not run Clear & delete everything. You will get stuck in a loop. I verified this:eek:

    As referred in this thread, because of the tuning adapter, the garbage collection had not run. You can check the last garbage collection on the system info screens.

    The quick solution was to unplug the tuning adapter for several hours and not have anything record and that forced its own garbage collection, which cleared the S03 code and then it was able to update the guide data. I unplugged the tuning adapter from the tivo and from power. Some of that info is from this thread.

    http://www.tivocommunity.com/tivo-vb/showthread.php?p=10863084#post10863084

    Another way to accomplish it as mentioned is to go to the settings, channel list and then hit enter. (this is some secret voodoo that I guess lets you keep your season passes and to do list maybe?) It will ask to reset up parts of guided setup but I don't think you will get stuck. Supposedly this works and does not reset your season passes. It just clears your program data and reindexes and such. You can also I think run Clear Program information and TODO list, but I think you lose all your setup recordings. I would recommend pulling the drive and backing it up Just in Case before trying the other methods. The best way to try is unplugging the TA completely and see if that forces GC. It worked for me!

    Since I already had everything apart in troubleshooting, I figured it would be a good idea to update to a new 2TB since Unitron let me know we can now use all of the 2TB with the latest or at least 11-M version software.

    I ordered the Amazon WD20EURX and details to follow, but when placed in the Tivo, it would not even spin up. Turns out even thought it is not supposed to have PUIS mode which means Power UP in Standby, it did and this causes it not to turn on in the Tivo. So it had to be turned off. I did this and then the drive booted perfectly. Note that the drive is not supposed to have that turned on, but it was not a big deal to turn it off if you have The ULtimate Boot CD. Mine boot cd was a few years old and it still had the required HDAT2 program. Here are some links...
    The drive I bought...

    http://www.amazon.com/Western-Digit...&redirect=true&ref_=oh_aui_detailpage_o00_s01

    Details discussing the HDAT2 on Ultimate Boot CD to check intellipark and Power Up in Standby. Basically boot the drive with UBCD and HDAT2 can be found on the Ultimate Boot CD under: HDD> Diagnosis > HDAT2
    Thanks SBL for the quick directions....

    Once HDAT2 is running, select the drive you want to check the PUIS setting on, then select command menu > command feature sets. You should see 'Power-Up in Standby (PUIS) feature set' listed at the bottom with a status of enabled or disabled. If enabled, arrow down until the feature set is highlighted then hit return. It will ask for confirmation that you want to change the status. Enter Y to proceed with disabling PUIS.

    http://www.tivocommunity.com/tivo-vb/showthread.php?t=536101


    After disabling (If it was enabled of course Power Up in Standby, if it was not enabled, do not change anything) then I copied the 1.2TB (again was actually a 2TB disk) using Winmfs and expanded it and supersized it. I recommend deleting most recorded shows so the copy goes faster. It took mine only 30 minutes to copy what remained on the disk

    The quick version is to insert both drives into computer. Click on winmfs (i think shift right click to run as administrator) You have to run it as administrator.

    Select the from Tivo Drive. Use mfscopy to copy info to the new tivo drive. I selected 2000 as the swap file size. I think this is mass overkill, but its 30 minutes of video for insurance. DO NOT let it expand when the copy is done and make sure not to go to another window while it is copying because the timer will not work afterward. If you accidentally do, just wait till its finished

    After it is finished, SWITCH to the new tivo drive in file settings, then check it out with mfsinfo make sure you have the right drive and then run mfsadd to expand it out to 2TB. It will tell you that the partition is larger than 1TB and will not work, but tell it thats okay and do it anyway and it should work fine (mine did)

    I am not sure if it can go even bigger, maybe someone else can post if 3TB works. Anyway, then you can click supersize which also works fine and then you are done. Put the new disk in the tivo and boot up. In some expansions you may have to run the kickstart 57, but I think that is not with copying files, but only using images. My suggestion is after you boot succesfully with the new drive and netconnect a few times, pull it out and make an image. Never hurts to have a few images floating around.

    Here are links to more details on copying and expanding using winmfs. When only using an image to restore, you can still expand, but you cannot downsize. I tried it several ways and it would not work. So either stay the same size or go larger if copying or using just the backup image. Restoring a backup will probably automatically do the kickstart 57 green screen and run for awhile. If it does not, you have to manually do it. (Only when restoring image, not needed for the copy option most times) On the HD tivo you boot the tivo and watch the green light. When it flashes hit pause immediately and hold it till the yellow and red lights come on. then hit 57 and I think they go out. Wait a bit and it will reboot and go thru a few screens and then the green screen. You should be good to go when it finishes!

    Make sure to read Unitron post 7 for detailed info.....
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=514967


    This post has or had a version of winmfs at post 10198
    http://tivocommunity.com/tivo-vb/showthread.php?t=370784&page=340

    Please comment below on anything else I need to add or change or experiences. I did this to save a few hours for the next person as I looked at hundreds of threads but most except new threads are outdated or require running thru alot of pages to get all the info together. Again thanks to everyone else who I copied to get things working and I hope this helps you!

    More details on EURX drives
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=535282
    Some info for Premiere blue and other drives.
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=535300
     

Share This Page

spam firewall

Advertisements