Slingbox software v 1.5 supposed to support Tivo Series 3, but it doesn't work

Discussion in 'TiVo Series3 HDTV DVRs' started by tivoknucklehead, Sep 25, 2007.

  1. tivoknucklehead

    tivoknucklehead Well-Known Member

    1,343
    213
    Dec 12, 2002
    Orlando Florida
    FYI, its a bug. Had to go back to setting my Sling up as a Series 2 for it to work. Specifically, the Tivo button on the remote ends up grayed out when "Series 3" is selected on setup
     
  2. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    Try running the setup again. On the old software my TiVo HD wouldn't enable the TiVo button using the S2 remote but it worked fine with the S3 remote. After the upgrade it appears to work just the same.
     
  3. moyekj

    moyekj Well-Known Member

    12,071
    775
    Jan 23, 2006
    Mission...
    I had the same problem... ended up rolling back to S2 remote and that works fine for what I care about. sfhub has posted his own fix to the problem in this forum before.
     
  4. tivoknucklehead

    tivoknucklehead Well-Known Member

    1,343
    213
    Dec 12, 2002
    Orlando Florida
    I fixed it by completely uninstalling old version, including settings, and reinstalling. a pain, but it works now
     
  5. moyekj

    moyekj Well-Known Member

    12,071
    775
    Jan 23, 2006
    Mission...
    Confirmed, thanks for posting. Went to Add/Remove programs and completely removed Slingplayer then re-installed 1.5 and now I got the proper S3 remote and it works properly. Only thing that's missing that I liked on the S2 remote was the standby button.
     
  6. SeanC

    SeanC ECT

    9,691
    21
    Dec 30, 2003
    Someplace
    Weird. I did a straight upgrade to 1.5, didn't have any problems.
     
  7. lawilson2

    lawilson2 New Member

    438
    0
    Oct 6, 2005
    Chicago
    All you have to do is after installing the update, rerun the AV setup, and choose the S3 remote. Works great.
     
  8. sfhub

    sfhub Well-Known Member

    2,883
    484
    Jan 6, 2007
    To clarify, I actually didn't have any problems with the S3 remote upgrade from Sling.

    My problem with the upgrade was it only supported a single unit.

    I needed support for multi-unit control. Since the Sling S3 support is for unit ID 0 it will control all S3s. That meant I needed to go back to using S2 support for multi-unit. Problem with that was some of the buttons didn't work right (Clear and Aspect). I ended up building my own custom device upgrade to replace the one Sling provides. The new upgrade supports unit 1-6 and has Clear and Aspect buttons functioning properly.

    The binary drop in upgrade files are here:
    http://www.hifi-remote.com/forums/dload.php?action=file&file_id=4804

    The source files are here (you can use JP1 tools to customize any button for any TiVo function including standby):
    http://www.hifi-remote.com/forums/dload.php?action=category&cat_id=98
     
  9. Chimpware

    Chimpware New Member

    334
    0
    Jan 30, 2002
    Recently had an issue where I had no remote show up in 1.5 (on more than 1 machine inclduing Mac). Tried to re setup the SlingBox Pro and I got a message that said:

    This Slingbox model does not fully support USA. A/V devices from this country may be missing from the device list and impossible to control.

    Same message regardless of country I choose. Anyone seen this?
     
  10. MisterUCLA

    MisterUCLA Member

    38
    0
    Mar 31, 2002
    sfhub,

    I've been using your multi-unit fix for the last few weeks now. Thanks for that.

    Have you figured out how to get the S3 remote to show up?

    thanks.
     
  11. rodalpho

    rodalpho New Member

    486
    0
    Sep 12, 2006
    So they actually fixed the S3 support? Fantastic! I reported the buggy remote codes several times, great to hear they did it right.
     
  12. sfhub

    sfhub Well-Known Member

    2,883
    484
    Jan 6, 2007
    I corresponded with the person handling remote development at Sling to see how I could bind my updates to the S3 graphical remote remote. After they started with the new packaging of remotes in the obfuscated file structures, it isn't easy to make that happen. On the plus side, they downloaded my updates and gave me the impression they would either include mine or their own version (bound to the S3 graphical remote representation) for the next batch of remote updates.
     
  13. bkdtv

    bkdtv New Member

    7,902
    2
    Jan 9, 2003
    DC Metro Area
    Once you install the new 1.5 software, select the "Tivo Series3" remote under the Slingbox -> Remote Control menu.
     
  14. moyekj

    moyekj Well-Known Member

    12,071
    775
    Jan 23, 2006
    Mission...
    And if for some reason the Tivo button and a couple of other buttons are greyed out (as was for my case) you will have to completely remove the software 1st (from Add/Remove programs in Control Panel) and then re-install 1.5, then it should work.
     
  15. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    Or just run the configuration again for that slingbox. That seems to fix issues like these.
     
  16. sfhub

    sfhub Well-Known Member

    2,883
    484
    Jan 6, 2007
    When you install a custom upgrade, it defaults to using the S2 remote image. It is related to the way the upgrade descriptor file was created.
     
  17. moyekj

    moyekj Well-Known Member

    12,071
    775
    Jan 23, 2006
    Mission...
    OT for this thread but Slingbox related:
    I have the AV unit which for has both S-video and composite video inputs. I'm using S-video and audio inputs for an S3.

    Though the AV is intended for a single device input I was thinking can't I use the composite video as input from a different device (such as a ReplayTV) for video only? Are you able to configure for 2 different devices and dedicate 1 IR blaster to each? Or is only 1 device configuration allowed at a time for the AV? (If that is allowed then I presume I could even use a Y splitter for audio as long as only 1 device is on at a time).
     
  18. sfhub

    sfhub Well-Known Member

    2,883
    484
    Jan 6, 2007
    I think you can use a Y-split/merge on the audio. The IR blasters all send the same IR signal no matter how many IR transmitters there are so if you strategically place 1 IR transmitter, it is just as good as having the IR transmitter with 4 heads.

    If the UI allows you to select between s-video and composite, then you have the same interface as the slingbox pro (you just have fewer inputs), which also forces you to select the input to switch devices.
     
  19. rodalpho

    rodalpho New Member

    486
    0
    Sep 12, 2006
    The new software still doesn't let me map the "aspect" button using the S3 remote. So frustrating.
     
  20. Arcady

    Arcady Stargate Fan

    3,959
    3
    Oct 14, 2004
    Philadelphia...
    The aspect button works in the Mac version, so I'd complain to Sling about it. Definitely a bug.

    Edit: I just installed SlingPlayer 1.5 on my Vista box here at work for the hell of it, and the aspect button works for me...
     

Share This Page