shd400 image from mfstools to winmfs

Discussion in 'DVD TiVo Units (Archive)' started by greggt007, Jun 7, 2012.

  1. Jun 7, 2012 #1 of 12

    greggt007 New Member

    Dec 8, 2005
    i have a sdh400 with a bad hard drive. well two really. i have one working sdh400 with an upgraded 160gb drive. i am trying to get the other two working again to sell them off. i had though i made an image of an original 80gb drive with mfs tools 2.0. it made a *.bak file that was just over a gig, which i thought was large. now i remember back to when i did this i remember reading that once you upgrade to, say, a 160gb drive, you cant then upgrade to any other drive. it is a one time only thing. is this still true, even with winmfs? i tried using what i thought was the .bak file from mfs tools to put the image on a 250gb drive i have with winmfs but that doesnt work. i tried making an image with winmfs of my working drive to the 250gb drive, and also a 80gb drive spare, but that doesnt work either. i only have a usc-pata connector. i tried to get my laptop to boot using mfstools2 and it hangs halfway through, even though i think it can do usb if it does boot into mfstools. maybe i will try my other laptop. any other suggestions? i dont wanna pay $40 for the sdh400 image, i'd rather just sell them as nonworking i suppose...
  2. Jun 7, 2012 #2 of 12

    motorcycle_rider New Member

    Apr 29, 2009
    I believe that I posted a link to my copy of the image in the need an image thread. Please check there.
  3. Jun 9, 2012 #3 of 12

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC
    If it's like the non-satellite, non-DVD TiVos, then it has a limit of 6 MFS type partitions per drive, or 3 MFS pairs.

    If it's like the regular Series 2s, it comes from the factory with 2 pairs already, which means one upgrade adds the remaining allowable pair.

    WinMFS will only restore an image made using WinMFS, and only WinMFS can restore an image made with WinMFS.

    The MFS Live cd (which you should have even if you don't have a TiVo) can restore images made with MFS Tools. It's basically the newer version of MFS Tools.

    You can make a tuncated backup image of an expanded drive, with either the MFS Live cd or WinMFS, and then restore it to a drive at least as large as the original factory drive, and it will only put on the first 2 MFS pairs if you don't specifically tell it to expand.

    You should be able to use WinMFS to make a good truncated image from that 160GB drive out of the one that's still working.

    Are you running WinMFS with administrator privileges?

    Does it see that 160GB drive at all?

    If so, select it and click on mfsinfo, and copy the result to a text file and save it, it might come in handy.
  4. greggt007

    greggt007 New Member

    Dec 8, 2005
    i appreciate the help and the image motorcycle rider. however, i could not get your image to work with winmfs. i tried using winmfs on three computers and they all gave me weird errors or crashed winmfs, but i think it was due to the 250gb hard drive i was trying. anyway, on my last straw, i seriously was throwing in the towel if it didnt work, i tried using mfstools2 with my old image (which was over 1gb, big for a tivo image i think) and somehow got it to work! thanks to all those on here for their help.

    only issue now is the 250gb tivo is reporting 83 hours, while my 160gb tivo is correctly reporting 189 hours...
    too bad i just closed up the tivo. i think i need to supersize it or expand it in winmfs maybe?
  5. unitron

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC
    Are you showing any old recordings on that 250?

    I suspect the 1GB size of the backup may have been due to not compressing it and/or including recordings.

    Also, you might have made that image from a drive that had already had the 3rd MFS pair added, so it might have restored with them at their previous size.

    You really need to make yourself a copy of the MFS Live cd and use it instead of MFS Tools for working with non-WinMFS images.

    It wouldn't have been a bad idea to have gotten or made a bootable cd with the diagnostic software of the manufacturer of that 250 and run the long test on it before trusting it.
  6. greggt007

    greggt007 New Member

    Dec 8, 2005
    Mfsinfo (Drive 1)

    Boot Page
    Boot Page: root=/dev/hda7
    Active Boot Partition: 6 Active Root Partition: 7
    Backup Boot Partition: 3 Backup Root Partition: 4

    MFS Super Header
    state=0 magic=abbafeed
    devlist=/dev/hda10 /dev/hda11 /dev/hda12 /dev/hda13 /dev/hda14 /dev/hda15
    zonemap_ptr=1121 total_secs=487061504

    Zone Maps
    Z0: type=0
    map_start=1121 map_size=1 backup_map_start=524286
    next_map_start=132194 next_map_size=34 next_backup_map_start=524252
    zone_first=1122 zone_last=132193 zone_size=131072 min(chunk)=131072
    free=131072 checksum=212e22f4 logstamp=4904705 num_bitmap=1
    Z1: type=2
    map_start=132194 map_size=34 backup_map_start=524252
    next_map_start=132228 next_map_size=34 next_backup_map_start=524218
    zone_first=524288 zone_last=69924863 zone_size=69400576 min(chunk)=2048
    free=68849664 checksum=3939fd87 logstamp=4906485 num_bitmap=17
    Z2: type=1
    map_start=132228 map_size=34 backup_map_start=524218
    next_map_start=69924864 next_map_size=1 next_backup_map_start=70449151
    zone_first=132262 zone_last=524213 zone_size=391952 min(chunk)=8
    free=272496 checksum=b4acbbc7 logstamp=4906741 num_bitmap=17
    Z3: type=0
    map_start=69924864 map_size=1 backup_map_start=70449151
    next_map_start=70055937 next_map_size=34 next_backup_map_start=70449117
    zone_first=69924865 zone_last=70055936 zone_size=131072 min(chunk)=131072
    free=131072 checksum=b6e2a0fc logstamp=4904705 num_bitmap=1
    Z4: type=2
    map_start=70055937 map_size=34 backup_map_start=70449117
    next_map_start=70055971 next_map_size=34 next_backup_map_start=70449083
    zone_first=70449152 zone_last=158494719 zone_size=88045568 min(chunk)=2048
    free=86482944 checksum=741c39cd logstamp=4906485 num_bitmap=17
    Z5: type=1
    map_start=70055971 map_size=34 backup_map_start=70449083
    next_map_start=158495745 next_map_size=9 next_backup_map_start=158496758
    zone_first=70056005 zone_last=70449076 zone_size=393072 min(chunk)=8
    free=368768 checksum=85fa7322 logstamp=4906521 num_bitmap=17
    Z6: type=2
    map_start=158495745 map_size=9 backup_map_start=158496758
    next_map_start=0 next_map_size=0 next_backup_map_start=3735928559
    zone_first=158496768 zone_last=487061503 zone_size=328564736 min(chunk)=32768
    free=328269824 checksum=c9d8e227 logstamp=4906485 num_bitmap=15

    Partition Maps
    #: type name length base ( size )
    1 Apple_partition_map Apple 63@1 ( 31.5K)
    2 Image Bootstrap 1 1@157447232 ( 512.0 )
    3 Image Kernel 1 8192@157447233 ( 4.0M)
    4 Ext2 Root 1 524288@157455425 ( 256.0M)
    5 Image Bootstrap 2 4096@157979713 ( 2.0M)
    6 Image Kernel 2 4096@157983809 ( 2.0M)
    7 Ext2 Root 2 262144@157987905 ( 128.0M)
    8 Swap Linux swap 260096@158250049 ( 127.0M)
    9 Ext2 /var 262144@158510145 ( 128.0M)
    10 MFS MFS application region 524288@158772289 ( 256.0M)
    11 MFS MFS media region 69400576@88046656 ( 33.1G)
    12 MFS Second MFS application region 524288@159296577 ( 256.0M)
    13 MFS Second MFS media region 88046592@64 ( 42.0G)
    14 MFS New MFS Application 1024@159820865 ( 512.0K)
    15 MFS New MFS Media 328564736@159821889 ( 156.7G)
    16 Apple_Free Extra 10543@488386625 ( 5.1M)

    Total SA SD Hours: 259 Total DTV SD Hours: 226 100 % Free
    Software: 9.3.2b-01-2-264 Tivo Model: SD-H400

    that is my msfinfo, i see 6 mfs partitions. it is saying 259 hours here, with 33g, 42g, and 156g. but in the system info screen it says 83 hours....
  7. greggt007

    greggt007 New Member

    Dec 8, 2005
    yes the 1gb image may have had recordings, i may have gotten it from my 160gb drive. however, if i did get it from the 160gb drive, instead of the stock 80gb, wouldnt my new 250gb drive see 160gb of space?

    should i try mfsadd?
  8. unitron

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC
    I'm assuming the drive 1 mfsinfo in the other post is from the 250GB drive which you restored the 1GB of backup image onto with that old version of MFS Tools.

    (you really need to make yourself a copy of the MFS Live cd v1.4, and use that instead of MFS Tools)

    I don't know if that old MFS Tools can properly deal with drives larger than 137GB or not. In other words, I don't know if it has an LBA48 aware kernel.

    Also, that's an S1 type partition layout, not the "optimized" version introduced with the Series 2 TiVos, but I don't know if the "optimized" layout was used on every S2 ever made right from the beginning or not, so I don't know if you failed to use the -p option or if MFS Tools even has that option or if that particular model TiVo uses the S2 layout or the S1 layout.

    You appear to have the latest and last version of the S2 software on there, or nearly so, so it should be able to handle either version of the layout, but I've learned the hard way better to have the version you're supposed to, especially when making a back-up.

    I put a 500GB in an S2 DT without using the -p option and although it worked in the TiVo just fine, I could not make a truncated backup from it (and of course the backup from the original 80GB drive had something wrong with it).

    Does that 250GB drive actually boot up?

    If so, when you go into "Now Playing", what's there?

    If there's anything listed, is it really there if you try to play it?
  9. greggt007

    greggt007 New Member

    Dec 8, 2005
    yes, your assumption is correct. i am pretty sure mfs tools can handle greater than 137, it did my 160gb fine. i did the -zxpi command.

    yes i had to do a clear and delete everything, so npl is empty. the 250gb boots fine now. it sees the 83 hours. i just did an extended test on it, it's a wd, and it passed. did a truncated backup fine too. did supersize fine. just not sure if i should risk mfsadd.
  10. unitron

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC
    Okay, I was wrong about the S1 layout, didn't examine the partiton map closely enough/forgot how it gets put in print, so nevermind any of that.

    If that 1GB image came from a different unit, with a different TiVo Service Number, then any recordings in it will not be recognized by a TiVo with a different TSN.

    -zxpi means you used the -z option, the -x option, the -p option, and the -i option.

    The -p option put the partitions on there in the "optimized" layout. That's why partition 13 starts at sector 64 instead of partition 2.

    The -x option means it already ran mfsadd (x for expand), which is why you have that 3rd MFS pair.

    I think -z means your backup boot and root partitions are empty, but I'm not certain, it was never all that well documented on my level of understanding, and I never understood the need for it.

    The -i option has something to do with from where the restore command gets its input.

    Since you don't have any recordings to save we can mess with the drive.

    Did you do the truncated backup with WinMFS?

    If so, use WinMFS to restore to that drive and then try it out in the TiVo again.

    (you can always use the other TiVo's drive as a source to put a new image on that drive if necessary)
  11. druknmonkey

    druknmonkey New Member

    Dec 29, 2012
    Did you ever figure this out? I recently got an sd-h400 with a bad drive also and when i tried the image that motorcycle_rider posted in the other thread i have the same problem. No matter what i do Winmfs always crashes at the end of the restore. If i try to boot the disk anyway i get a message about external storage device missing and when i choose to remove the device it just reboots and repeats. Tried on my windows 7 desktop with the drive installed internally, tried externally with usb adapter on win 7 and XP laptops. Always same result. Also always run as administrator. HELP!!!
  12. Ronnie Poofs

    Ronnie Poofs New Member

    May 20, 2020
    I see this is a very old thread but is the Toshiba SD-H400 (264) disk image still available for download?

Share This Page