Several videos don't transfer properly

Discussion in 'TiVo Home Media Features & TiVoToGo' started by lrhorer, Aug 3, 2011.

  1. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    I'm having a problem with several videos, and I hope someone can figure out how I might fix them. Fairly short test clips of one of the videos can be found here.

    Failure 1:

    I trimmed the videos to length using VideoRedo TV Suite and saved them as .mpg files. When I try to push or pull these videos using pyTivo, about 18 seconds of the video transfers to the TiVo, and then the transfer aborts. The clip of this one is named test.mpg.

    PyTivo reports:
    Code:
    INFO:pyTivo:192.168.1.103 [02/Aug/2011 23:54:59] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo:192.168.1.102 [02/Aug/2011 23:54:59] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo:192.168.1.101 [02/Aug/2011 23:54:59] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo.video.video:[02/Aug/2011 23:55:19] Queued "/usr/share/pyTivo/Unverified/test.mpg" for Push to HD Theater
    INFO:pyTivo:192.168.1.3 [02/Aug/2011 23:55:19] "POST /TiVoConnect HTTP/1.1" 200 -
    DEBUG:pyTivo.video.transcode:starting ffmpeg, will wait 10 seconds for it to complete
    INFO:pyTivo:192.168.1.3 [02/Aug/2011 23:55:25] "GET /TiVoConnect?Command=QueryContainer&Container=Unverified HTTP/1.1" 200 -
    INFO:pyTivo:192.168.1.3 [02/Aug/2011 23:55:25] "GET /main.css HTTP/1.1" 200 -
    DEBUG:pyTivo.video.transcode:ffmpeg output=FFmpeg version SVN-r25838, Copyright (c) 2000-2010 the FFmpeg developers
      built on Jan 21 2011 08:21:58 with gcc 4.4.5
      configuration: --enable-libdc1394 --prefix=/usr --extra-cflags='-Wall -g ' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-avfilter --enable-libdirac --disable-decoder=libdirac --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-libvpx --enable-librtmp --extra-libs=-lgcrypt --disable-altivec --disable-armv5te --disable-armv6 --disable-vis
      libavutil     50.33. 0 / 50.33. 0
      libavcore      0.14. 0 /  0.14. 0
      libavcodec    52.97. 2 / 52.97. 2
      libavformat   52.87. 1 / 52.87. 1
      libavdevice   52. 2. 2 / 52. 2. 2
      libavfilter    1.65. 0 /  1.65. 0
      libswscale     0.12. 0 /  0.12. 0
      libpostproc   51. 2. 0 / 51. 2. 0
    [mpeg @ 0x1606760] max_analyze_duration reached
    
    Seems stream 0 codec frame rate differs from container frame rate: 59.94 (60000/1001) -> 59.94 (60000/1001)
    Input #0, mpeg, from '/usr/share/pyTivo/Unverified/test.mpg':
      Duration: 00:10:26.74, start: 0.200000, bitrate: 8030 kb/s
        Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 38810 kb/s, 25.58 fps, 59.94 tbr, 90k tbn, 59.94 tbc
        Stream #0.1[0x80]: Audio: ac3, 48000 Hz, 5.1, s16, 384 kb/s
    At least one output file must be specified
    
    DEBUG:pyTivo.video.transcode:Bug in VideoReDo
    DEBUG:pyTivo.video.transcode:aFreq=48000; vFps=59.94; container=mpeg; kbps=8030; mapAudio=[('0.1', '[0x80]')]; vHeight=1080; vCodec=mpeg2video; Supported=True; aKbps=384; par=None; millisecs=626740; par2=1.0; par1=1:1; mapVideo=0.0; vWidth=1920; dar1=16:9; aCodec=ac3
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:TRANSCODE=YES, vCodec mpeg2video not compatible, /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:TRANSCODE=YES, vCodec mpeg2video not compatible, /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:TRANSCODE=NO, all compatible, /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:TRANSCODE=NO, all compatible, /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.mind:__login
    {'cams_security_domain': 'tivocom', 'cams_login_config': 'http', 'cams_cb_password': 'XXXXXXXX', 'cams_original_url': '/mind/mind7?type=infoGet', 'cams_cb_username': 'XXXXXXXXXXX'}
    DEBUG:pyTivo.mind:pcBodySearch
    {}
    
    <pcBodyList><isBottom>true</isBottom><isTop>true</isTop><pcBody><bucketNumber>-1</bucketNumber><levelOfDetail>low</levelOfDetail><name>pyTivo</name><pcBodyId>tivo:pc.1001365511</pcBodyId><type>pcBody</type></pcBody></pcBodyList>g
    DEBUG:pyTivo.mind:bodyOfferModify&bodyId=tsn:64800018029EB15
    {'subtitle': 'test.mpg', 'description': '', 'pcBodyId': 'tivo:pc.1001365511', 'publishDate': '2011-08-03 04:5537', 'partnerId': 'tivo:pt.3187', 'duration': 626, 'size': 629145600, 'title': 'Unverified', 'url': 'http://192.168.1.50:9032/Unverified/test.mpg?Format=video/mpeg', 'bodyId': 'tsn:64800018029EB15', 'source': 'SH999999', 'state': 'complete', 'encodingType': 'mpeg2ProgramStream'}
    
    <bodyOffer><bodyId>tsn:64800018029EB15</bodyId><bodyOfferId>tivo:bo.15010921</bodyOfferId><createDate>2011-08-03 04:55:44</createDate><description /><duration>626</duration><encodingType>mpeg2ProgramStream</encodingType><levelOfDetail>high</levelOfDetail><offerId>tivo:of.bs.15010921</offerId><partnerId>tivo:pt.3187</partnerId><pcBodyId>tivo:pc.1001365511</pcBodyId><publishDate>2011-08-07 00:17:00</publishDate><size>629145600</size><source>SH999999</source><state>complete</state><subtitle>test.mpg</subtitle><title>Unverified</title><updateDate>2011-08-03 04:55:44</updateDate><url>http://192.168.1.50:9032/Unverified/test.mpg?Format=video/mpeg</url></bodyOffer>g
    DEBUG:pyTivo.mind:subscribe&bodyId=tsn:64800018029EB15
    {'uiType': 'cds', 'idSetSource': {'contentId': 'tivo:ct.bs.15010921', 'type': 'singleOfferSource', 'offerId': 'tivo:of.bs.15010921'}, 'bodyId': 'tsn:64800018029EB15', 'title': 'pcBodySubscription'}
    
    <subscribeResult><subscription><autoRecord>true</autoRecord><bodyGeneratesCandidates>false</bodyGeneratesCandidates><bodyId>tsn:64800018029EB15</bodyId><hdOnly>false</hdOnly><idSetSource><contentId>tivo:ct.bs.15010921</contentId><offerId>tivo:of.bs.15010921</offerId><type>singleOfferSource</type></idSetSource><isAdult>false</isAdult><isForKids>false</isForKids><levelOfDetail>high</levelOfDetail><showStatus>rerunsAllowed</showStatus><subscriptionId>tivo:sb.15010981</subscriptionId><title>pcBodySubscription</title><type>subscription</type><uiType>cds</uiType></subscription></subscribeResult>g
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:CACHE HIT! /usr/share/pyTivo/Unverified/test.mpg
    DEBUG:pyTivo.video.transcode:TRANSCODE=NO, all compatible, /usr/share/pyTivo/Unverified/test.mpg
    INFO:pyTivo:192.168.1.102 [02/Aug/2011 23:56:31] "GET /Unverified/test.mpg?Format=video%2Fmpeg HTTP/1.1" 206 -
    INFO:pyTivo.video.video:[02/Aug/2011 23:56:31] Start sending "/usr/share/pyTivo/Unverified/test.mpg" to HD Theater
    DEBUG:pyTivo.video.video:"/usr/share/pyTivo/Unverified/test.mpg" is tivo compatible
    INFO:pyTivo.video.video:[Errno 104] Connection reset by peer
    INFO:pyTivo.video.video:[Errno 32] Broken pipe
    INFO:pyTivo.video.video:[02/Aug/2011 23:56:38] Done sending "/usr/share/pyTivo/Unverified/test.mpg" to HD Theater, 5242880 bytes, 5.68 Mb/s
    ERROR:pyTivo:Exception during request from ('192.168.1.102', 1317)
    Traceback (most recent call last):
      File "/usr/lib/python2.6/SocketServer.py", line 560, in process_request_thread
        self.finish_request(request, client_address)
      File "/usr/lib/python2.6/SocketServer.py", line 322, in finish_request
        self.RequestHandlerClass(request, client_address, self)
      File "/usr/share/pyTivo/httpserver.py", line 64, in __init__
        client_address, server)
      File "/usr/lib/python2.6/SocketServer.py", line 618, in __init__
        self.finish()
      File "/usr/lib/python2.6/SocketServer.py", line 661, in finish
        self.wfile.flush()
      File "/usr/lib/python2.6/socket.py", line 297, in flush
        self._sock.sendall(buffer(data, write_offset, buffer_size))
    error: [Errno 32] Broken pipe

    Failure 2:

    I convert the video to a transport stream (.ts) file using VRD, then I perform a Quick Stream Fix and convert the file back to .mpg. QSF does not report any frames removed or corrupted. The new video shows the same issues, only transferring a few seconds before quitting. This is test2.mpg.

    Failure 3:

    I use HDTVtoMPEG2 to convert the .ts file to .mpg. Now the video transfers fully (I think, it's hard to tell for sure), but the TiVo only thinks about 1 minute of video has transferred. I can play the video on the TiVo, but I can only FF and RW in about a 1 minute window. After playing some number of minutes of the video, the TiVo thinks it is still at the 1 minute mark. Pausing, exiting, and re-starting the video from the paused point causes the TiVo to jump back to the 1 minute mark in the video, effectively starting all over again. This is test1.mpg

    Failure 4:

    I tried running VRD QSF on the file created by HDTVtoMPEG2. QSF reports it removed one audio frame, but otherwise doesn't complain. Once again the system transfers a few seconds of video and quits.
     
  2. moyekj

    moyekj Well-Known Member

    12,125
    795
    Jan 23, 2006
    Mission...
    FYI. Downloaded test.mpg and confirmed it wouldn't transfer for me with pyTivo (push or pull) and couldn't stream with streambaby either. However, I simply ran it through VRD qsfix (version 4.20.6.621) and the resulting video then transferred fine and played through all 4 minutes on my Premiere.
    Don't know what version of VRD you are using but you can download latest beta TVSuite version which I used above here.
     
  3. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    I have the latest build of 3.2. I'll try a test using 4.2.
     
  4. dlfl

    dlfl Cranky old novice

    8,874
    695
    Jul 6, 2006
    Dayton OH
    I may not be keeping up with all the latest pyTivo bells and whistles, but I am really puzzled by this debug output line in the first post:

    DEBUG:pyTivo.video.transcode:Bug in VideoReDo

    VideoReDo ??? What does pyTivo know about VideoReDo ?
     
  5. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    I tried 4.2 and it worked! I've upgraded to the latest gold release version of VRD TV Suite. Indeed, I went one step further and converted the problematic video to h.264. Now not only do they transfer correctly, but they do so in 1/3 the time. It takes more than 10 hours to recode, though.
     

Share This Page