Server loses configured IP address

Discussion in 'TiVo Home Media Features & TiVoToGo' started by scottwmlewis, Oct 10, 2007.

  1. scottwmlewis

    scottwmlewis New Member

    5
    0
    Sep 27, 2007
    Desktop 2.5 is up and transferring programs and I can view my PC from the tivo set.

    When I reboot my computer, the NIC address selected in the server properties changes to my 'outside' NIC address. I have a dual NIC installation; one for the private LAN and one that connects to my gateway/cable.

    I read that I could modify a '.cfg' file to set the IP address to use. But, I cannot find any cfg file related to TiVo Desktop.

    Any help locking down the address would really be appreciated.
     
  2. Interactive

    Interactive New Member

    64
    0
    Jan 16, 2003
    McKinney, TX
    I have a similar issue where Desktop keeps re-selecting the Microsoft Loopback Adapter IP address that's used for X-Drive. I just installed Dekstop 2.5 on my laptop as well (just for testing) and found that a similar thing happens there; it trys to pull my IP address from my cellular card (which wasn't even active at the time). It seems that in both cases, the IP address I WANT it to choose is lower on the list in the drop down. It also seems that Desktop is defaulting to the IP that's top of the list. Each time I select the correct IP it works fine, then as soon as I reboot, it all goes back to the wrong adapters.

    I, too, need to find a way to lock this down. Any ideas?

    Is there some way to re-order the network connection list? Would that even make a difference?
     
  3. F8ster

    F8ster The Very Last One

    232
    0
    May 26, 2002
    Not sure it'll help, but here's how you do it:

    Start - Network Connections
    Advanced - Advanced Settings...
    Adapters and Bindings tab
    Under Connections, select the desired default and use the up-arrow (the little green one to the right of the box) to move it to the top

    Probably worth rebooting afterwards.
     
  4. Interactive

    Interactive New Member

    64
    0
    Jan 16, 2003
    McKinney, TX
    I never knew this was there! However, when I went in to change the setting, the LAN card was already higher on the list than the loopback connector. In fact, the loopback was the lowest on the list. First was my 1394 Firewire card, then LAN, then loopback. I went ahead and moved the LAN up to 1st anyway. I'll try to reboot and see what happens.....
     
  5. scottwmlewis

    scottwmlewis New Member

    5
    0
    Sep 27, 2007
    Wish I could say this worked for me. The server still picks the outside (internet) NIC for the server connection.

    I'll keep tinkering with the tivo server/desktop now that I've changed the order of my connections.
     

Share This Page