Series1 DirecTiVo Software Update (3.5.0) Migration Thread

Discussion in 'TiVo Upgrade Center' started by tivoupgrade, Apr 26, 2006.

  1. Apr 26, 2006 #1 of 304

    tivoupgrade Sponsor

    Sep 27, 2000
    Chicago, IL...


    updated 9/2/08

    3.5d has been rolled out for Series1 DirecTV TiVo units. The information (and fixes) discussed below still applies and has been slightly revised to reflect current status (some of the information is no longer relevant.

    As mentioned in this thread, an update to the aging, but still viable Series1 DirecTV TiVo line of DVR's (Sony SAT-T60, Philips DSR6000, and Hughes GXCEBOT systems) is impending.

    Here is what we know so far:

    LBA48 Support
    The 3.5.0 release does not contain an LBA48 kernel - this means anyone who is using a > 137GB drive and has used an LBA48 kernel, or kernel utility (such as CopyKern) will experience strange behavior when selecting programs from the Now Playing List.

    We have confirmed that use of CopyKern, or direct use of Todd Miller's modified 2.4.24 kernel from the 3.1.0 software release, will NOT work when applied to 3.5.0. In fact, inititial tests will put the unit into a reboot loop if you attempt to do this (so don't...).

    Note that TiVo has not yet released the source code modifications for 3.5 on their site, but it is expected that they will do so shortly. Once that happens, work can begin on creation of a newly modified kernel with LBA48 support. We will release a utility (at no charge) to the community, to aid in installation of the new kernel.

    update: 5/10/2006 - 5:02CDT

    Thanks to Todd Miller, we have an EXPERIMENTAL kernel that appears to be working for us in the lab. It is a recompiled version of the 3.1 kernel (the new config file is included in the tarred and gzipped contents along with the kernel).

    You can download it from here, use tpip to install it and post your experiences to this thread. If you are unfamiliar with the kernel updating techniques and wish to not learn the details of updating your kernel and using tpip, then please be patient, we will update CopyKern and our free CD soon.

    3.1+ Experimental Kernel

    update: 5/12/2006 - 7:31CDT

    New Release of the LBA48 CD (ver 4.04) includes a revised copykern and a recompiled kernel (labeled 3.10+) in the s1_kernels directory. We have done preliminary testing with this kernel in conjunction with version 3.5 of the Series1 DirecTV TiVo release and early tests are encouraging. If you have built LBA48 drives which are spuriously rebooting, or contain content that is not accessible through the "Now Playing" list, we encourage you to use copykern to transplant this newly updated kernel. Also note that you will need to use killinitrd to zap the new initrd (or use nic_config in the silicondust network driver release to achieve the same result).

    Please see the PTVupgrade LBA48 Boot CD for more details.

    Network Hacks
    By definition, ALL hacks will be disabled as a result of a software update. This is because the new version of the software will be installed in what is now your "inactive" partition. The inactive partition will become active, and your active partition will become "inactive" after the update.

    TurboNet drivers should still be intact in the new version of the software (however, telnet and ftp will not be accessible until you install them). CacheCard drivers will not be be intact as they were never part of the standard software release.

    Prom Flash
    We have confirmed that a prom update is not part of the update to 3.5; therefore, use of tivoflash is not required when rehacking your units.

    Will applications work?

    We have confirmed that versions of TiVoWebPlus 1.2.1 and 1.2.2 and 2.0 are almost entirely functional with 3.5.0. We have not tested many of the user contributed modules. Anyone with specific experiences or details is encouraged to post their observations and workarounds here.[/COLOR]

    Folks experiencing the update to 3.5.0 and beginning to re-hack their units, please post your experiences and best-practices recommendations here. There are probably more questions that answers at this point, so please be patient as the upgrade will be rolling out over the next several weeks and will take some time to propagate.

    Happy upgrading!

  2. Apr 26, 2006 #2 of 304

    lew Well-Known Member

    Mar 12, 2002
    It looks like the slice files D/L Monday. Are you planning to install it and see what changes or are you waiting for Directv to initiate the upgrade via phone call?
  3. Apr 26, 2006 #3 of 304

    brophey Woof woof!

    Feb 19, 2002
    Atlanta, GA
    I must be the only one who's system has upgraded.

    It does a big 'Updating DB. This will take awhile.' when it booted up, so I imagine it's going to screw up a lot of programs that play in the DB, ie, TiVoWebPlus.

    On the plus side, my 110hr box, fully loaded, loads the Now Playing list in about 3-5 seconds if not cached, and almost instantly if cached.

    At any rate, it's becoming increasingly more difficult to grab an actual PC around my house here to test the hacks. Plus, I have no idea how to officially fix anything if anything goes wrong. ;)

    But, since it's not my main TiVo anymore, I'm willing to help out with any testing. I do have a network card in there (I forget which one it is. TurboNet? The one that's fully integrated into itself.)
  4. Apr 27, 2006 #4 of 304

    vertigo235 Well-Known Member TCF Club

    Oct 27, 2000
    Hopefully it uses the same type of database that 6.X uses, since TiVowebplus works with that just fine.
  5. Apr 27, 2006 #5 of 304

    ADent Active Member

    Jan 7, 2000
    Denver, CO


    CacheCard drivers installed and working.

    Doesn't seem quite as snappy as 3.1.x sometimes - but I think the DDB is getting reindexed.
  6. Apr 27, 2006 #6 of 304

    curtis-r New Member

    Apr 26, 2006
    Hughes DirecTV 30 (or 40) hour Series 1 Tivo. This week it started to reboot spontaneously. Last night it rebooted 4 times while watching pre-recorded material! Driving me crazy.

    Software 3.1.0c2-01-1-031. No hacks.

    Any help would be greatly appreciated.
  7. Apr 27, 2006 #7 of 304

    tivoupgrade Sponsor

    Sep 27, 2000
    Chicago, IL...
    If you have telnet access to your TiVo, you can verify whether or not the new software has been downloaded (but not installed yet) by typing the following:

    echo mls /SwSystem | tivosh
    If you see something like this:

    Name                       Type        FsId      Date  Time   Size
    ----                           ----          ----        ----    ----     ----
    3.1.0c2-01-1-031    tyDb       29558  07/29/04 17:31    708
    3.5-01-1-031           tyDb       83344  04/27/06 07:37    680
    ACTIVE                    tyDb       29558  07/29/04 17:31    708
    It means the new software has downloaded, but the 3.10c2 software is still active.

    If you want to attempt to "force" the install, you can do so, but you should do this first:

    Edit the file /tvbin/installSw.itcl and find the line (its around line 155) where you see the "reboot" command, and replace the word reboot with "exit 0".

    Now type:

    ./installSw.itcl 3.5-01-1-031
    Once the installation is completed, the final steps won't be taken until you reboot the unit, but if you want to now mount the inactive partition, poke around, etc and even possibly attempt to preserve some of your hacks, you can do so.

    I have just completed the above steps, but have not looked at any of the system files and have no idea whether it will be as simple as just moving drivers and binaries to their respective places in the new partitions or now. Perhaps some of you will forge ahead and we can compare results.

    Do tread at your own risk, of course.
  8. Apr 27, 2006 #8 of 304

    tivoupgrade Sponsor

    Sep 27, 2000
    Chicago, IL...
    The manual installation documented above worked just fine.

    I attempted to preserve hacks and drivers by copying things over from the old active partition to the new one, but failed. I forgot a couple of files, and as it turned out, killinitrd was need again. So, things to do after you've manually invoked the install and rebooted your unit

    1) pull the drive from your unit
    2) backup drive using mfstools
    3) reinstall network drivers using nic_install and don't forget to kill the initrd when asked

    4) reinstall hacks

    the kernel install is

    Linux version 2.1.24-TiVo-2.5

    This build is NOT lba48-aware.

    First attempts to install 3.1 lba48 kernel with copykern, did not have good results.

    If any of you out there have experience building the kernel, consider rolling up your sleeves and building 3.5...

    As a quick test, I installed TiVoWebPlus 1.2.1 and the startup was *almost* clean (see below); I haven't figured out what functionality has been affected by this error, yet:

    bash-2.02# TivoWebPlus Project - v1.2.1
    The program comes with ABSOLUTELY NO WARRANTY.
    This program is licensed under the GPL.
    See the 'copyright' and 'README' files for copyright and credit information.
    Loading modules...
    --hackman Version 4.0.2--
    -Root directory mounted read-write
    -Freepages left at 128  192     256
    -Thursday, April 27, 2006, 03:08 PM, local time
    -initializing logo index
    -initializing channel table
    --caching 699 channels for source of type=6 (DirecTV)
    errNmNameNotFound object not found (errNmNameNotFound)
        while executing
    "mfs find $guideindexdir/ChannelTable"
        ("uplevel" body line 2)
        invoked from within
    "uplevel $body"
        invoked from within
    "transaction {uplevel $body}"
        (procedure "RetryTransaction" line 5)
        invoked from within
    "RetryTransaction {
        set channeltablefsid [lindex [mfs find $guideindexdir/ChannelTable] 0]
        set channeltabledata [mfs get $channeltablefsid]
        (procedure "init_channelindex" line 125)
        invoked from within
        (file "./modules/index.itcl" line 736)
        invoked from within
    "source $module "
    Loaded 0 resource definitions
    Accepting Connections
    And lastly, for those of you patching tivoapp; you'll need to find the new offsets. I have no idea what they are, and I'm not certain whether the folks on DDB have looked at this stuff yet. Please don't ask me, I don't know...

    Meetings to go to, but will do some more tonight/tomorrow and update with any other discoveries.
  9. Apr 27, 2006 #9 of 304

    ISWIZ Southern Yankee

    Aug 29, 2000
    I had used InstantCake and got the update. No problems seen so far.
  10. Apr 27, 2006 #10 of 304

    rhuntington3 Well-Known Member

    May 1, 2001
    Any more LBA48 news on V3.5?
  11. Apr 27, 2006 #11 of 304

    Blackfoot Member

    Jul 12, 2002
    RSM, CA
    I have two SAT T-60's both which have drives built with the InstantCake CD. One has a 200 Gb drive that is pretty empty and the other has a 300 Gb drive that is about 1/2 full. The 200 Gb drive unit is working, has the 3.5 software and I can watch TV and any previously recorded shows. The 300 Gb drive will not boot. Almost like the cache card drivers are set to read only (from some previous upgrade) or there is more than 137 Gb of data on the drive.

    I was thinking about pulling the drive out and re-installing the cache card drivers but am not sure if that will resolve anything. After that, I need to find the new tivoapp codes.
  12. Apr 27, 2006 #12 of 304

    tivoupgrade Sponsor

    Sep 27, 2000
    Chicago, IL...
    I've just verified that the kernel installed with 3.5 is NOT lba48-aware.

    Whats' worse, is that my first attempt to use the 3.1 kernel provided by Todd Miller (installed with copykern) did not work - the system came up almost completely, but rebooted in the final stages. I have not picked through the logs yet.

    [edit:] kernel log file attached

    Attached Files:

  13. Apr 28, 2006 #13 of 304

    Blackfoot Member

    Jul 12, 2002
    RSM, CA
    I attempted to reinstall my cache card drivers and dumped the log to my screen. I don't have a floppy to dump it on so I may have to summerize it as best I can.

    I starts up and the first error message is that is can't open /var/mtab. It goes on to activate swap partitions.... Yeah who am I kidding about getting this in there.
    It starts the fan control then errors that it can't open /dev/tivoconfig.
    Checks on new software installation but errors that it could not check because it can't open the object (errDbNotFound)
    Scans for phase3 and 4 repair scripts
    Says rc.sysinit completes
    MCP startup is complete
    Using a smartSorter
    Creating ApgReader
    And the last line is InitializeProgramOrDie failed: 0x30001
  14. Apr 28, 2006 #14 of 304

    MadMike wacked on the juice

    Oct 10, 2005
    My T-60 booted the 3.5 software yesterday. I pulled the drive and ran Steve Jenkins cd to get telnet, ftp and tivoweb going. The web interface comes up except for the NPL, I get this:

    --cut here--
    action_nowshowing " "
    can't read "cache_ns_rec": no such variable
    while executing
    "lsearch $cache_ns_rec $fsid"
    (pricedure "print_nowshowingrow" line 64)
    invoked from within
    "print_nowshowingrow $chan $rec $nstype $rcount"
    ("uplevel" body line 4)
    invoked from within
    "uplevel $ body"
    invoked from within
    "ForeachMfsFileTrans fsid name type $nowshowingdir "" 15 (
    set rec [db $db openid $fsid]
    if {$nstype == 6} {
    print_nowshowingrow $chan $r..."
    (procedure "::action_nowshowing" line 61)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--

    Any ideas?
  15. Apr 28, 2006 #15 of 304

    ronsch Active Member

    Sep 7, 2001
    Mine had already installed and rebooted. Can I use bootpage to drop back to the previous lba48-aware implementation on the inactive partition or did the upgrade do a database conversion that will only corrupt everything if I try and drop back to 3.1?
  16. Apr 28, 2006 #16 of 304

    Blackfoot Member

    Jul 12, 2002
    RSM, CA
    I was wondering the same thing. But it does do a database upgrade, so it sounds like it wont work.
  17. Apr 28, 2006 #17 of 304

    vertigo235 Well-Known Member TCF Club

    Oct 27, 2000
    All this talk is making me glad I allready added softwareupgrade=false to my bootpage!
  18. Apr 28, 2006 #18 of 304

    Blackfoot Member

    Jul 12, 2002
    RSM, CA
    I grabbed a spare 120 gb drive and restored my 3.1.0c2 software on it. Upgraded it to 3.5 and attempted to backup a show using the original unscramble.o module but it failed.

    Speaking of the SoftwareUpgrade=false, where can I find that. I know I have seen it before, but I think my eyes are starting to cross. I am going to restore my 3.1.0c2 image again and want to make sure that when my tivo calls home it doesn't try to update.

    Ultimately I want to update the kernel and apply the tivoapp patch, but this way gets the tivo back up and it makes my wife happy to have her tv back again.
  19. Apr 28, 2006 #19 of 304

    ronsch Active Member

    Sep 7, 2001
    I think you can set it as a bootpage parameter but I haven't tried that myself. On my SA on or about line 740 of rc.sysinit is a reference to upgradesoftware where it checks to see if there is an update to install and then does it.

    I believe you need to add the following statement:

    export upgradesoftware=false

    immediately before the check for that flag:

    if [ "$upgradesoftware" = false ]; then

    That should prevent the upgrade from happening. I'm still kicking myself for not adding it to my DTivo but who ever thought there would be a new release for S1.....

    I have a backup of my image with all my hacks except the update to to implement wireless networking but that will be easy enough to redo. It's the nearly 284 hours of programming including a lot of movies I haven't watched yet that I hate to lose. I may just put my smaller 250gb drive back in with upgradesoftware fixed and wait and see if the hacking Gods can come up with an lba48 kernel to go with this release.
  20. Apr 29, 2006 #20 of 304

    catbert00 New Member

    Sep 10, 2003
    I realized that I got the upgrade when I couldn't access TiVoWebPlus today. I did notice a couple days ago that my favorite channels were gone - but I just swore at the TiVo and didn't think anything else of it.

    So I cracked open the case tonight and reinstalled the Airnet drivers and I'm all connected again. I made copies of the important lines in my rc.sysinit and profile files to assist me in getting back on my feet ASAP after an upgrade.

    TiVoWebPlus had problems - but I see that is mentioned as to be expected. I don't really have much else in the way of hacks.

    My main problem is that I get a "failed while negotiating" message when trying to make the daily or test call using the network. I verified my prefix is OK (and even re-entered it).

    I didn't go through the TiVoflash step. Could that be my problem?

    Any other ideas?

Share This Page

spam firewall