Series 3 no "Video on demand menu"

Discussion in 'TiVo Help Center' started by Ev Jon, Dec 31, 2016.

  1. Ev Jon

    Ev Jon New Member

    10
    0
    Dec 12, 2016
    My series 3 Tivo is working fine except that the main menu does not have "Video on Demand". It does have: "Now Playing List", "Watch Live TV", "Find Programs", "Netflix", "Music Photos & Showcases", and "Messages and Settings" in that order.
    It is hardwired to a 50Mbps ethernet. Its software version is 11.On.H1-01-2-652

    How can I fix this? Thanks!
     
  2. HerronScott

    HerronScott Well-Known Member

    7,328
    1,050
    Jan 1, 2002
    Staunton, VA
    That menu item was replaced with the Netflix item as it was the only one that was left back in April 2015.

    Menu change

    Scott
     
  3. Ev Jon

    Ev Jon New Member

    10
    0
    Dec 12, 2016
    My daughter has the same model Tivo and the same software version as mine. It does have "Video on Demand" but does not have Netflix. She has a NetFlix account and it worked on her Tivo until after I replaced the hard drive. When she selects "Video on Demand" it says there was an error and we need to connect to the network. It is successfully connected to the network and the "Connect" menu item finishes normally but "Video on Demand" still says there was an error and she has no "Netflix" in her main menu.

    Any ideas how we can get Netflix in the menu? Thank you.
     
  4. TheCryptkeeper

    TheCryptkeeper Active Member

    129
    39
    Dec 31, 2009
    I have the same problem. I am connected to the network via ethernet, can successfully receive updates, but every time I try to access Video on Demand I receive an error message that says I need to connect to the network. I've tried rebooting, using wireless adapter, but nothing seems to work.
     
  5. Ev Jon

    Ev Jon New Member

    10
    0
    Dec 12, 2016
    I have just heard from TIVO support that this is a known problem and has been for several months. At this point they do not know what is causing it.

    They said that the following procedure often fixes it but, if fixed, the problem may come back again, perhaps a couple of months later. They also said that the fact that this procedure works makes no sense at all, but it does often work.
    1. Unplug ALL cords from the back of the Tivo
    2. Plug in only the power cord and the video out (such as HDMI) cable
    3. Wait for power up to complete
    4. Go to "Settings", "Phone & Network", "Connect to Tivo service now" & wait until it fails
    5. Reboot your router after the failure & wait for the reboot to complete
    6. Plug in the internet cable and the Coax cable
    7. Now "Connect to Tivo Service" again & it should complete
    8. Go to main menu. "Video on Demand" should be gone & "Netflix" should be there.

    If you try this, please let me know if it worked. Thank you.
     
  6. Jan 1, 2017 #6 of 22
    HerronScott

    HerronScott Well-Known Member

    7,328
    1,050
    Jan 1, 2002
    Staunton, VA
    If that doesn't fix it and you are interested in trying an image made after the menu change, let me know and I'll try to create a new HD (652) image with 11.0n.H1.

    Scott
     
  7. Jan 1, 2017 #7 of 22
    Ev Jon

    Ev Jon New Member

    10
    0
    Dec 12, 2016
    Thank you. However both of the Tivos mentioned in this discussion already are showing that they have version 11.On.H1-01-2-652
     
  8. Jan 1, 2017 #8 of 22
    HerronScott

    HerronScott Well-Known Member

    7,328
    1,050
    Jan 1, 2002
    Staunton, VA
    How did this TiVo get to this version though without getting the change that happened in April 2015? Has it been reimaged recently and what version was used to image?

    Scott
     
  9. Jan 1, 2017 #9 of 22
    Ev Jon

    Ev Jon New Member

    10
    0
    Dec 12, 2016
    Yes it was reimaged recently, not sure what version was used to reimage. The 1st time I looked after the reimage was a couple of days later when it had the current version.

    A Tivo tech support guy said that a few Series 3's are having a problem with having either the "Netflix" or "Video on demand" menu items and then a week or two later having the other one. It can switch back and forth. It is a problem that he said they are working on but it is not high priority.

    I think it may indeed have something to do with the reimage. That is when the problem started.
    Is there any way to force the Tivo to re-download the latest upgrade?
     
  10. TheCryptkeeper

    TheCryptkeeper Active Member

    129
    39
    Dec 31, 2009
    My TiVo HD has Version 11.On.H1-01-2-652 as well. I am also having an issue transferring recordings from it to my Roamio. When the Roamio tries to access the TiVo HD, I receive a similar message about a problem with my network, reconnecting to TiVo Service, etc. Funny thing is that I can transfer from the Roamio to the TiVo HD without any issues. I spoke with TiVo Tech Support about the transfer problem and this is another software glitch with the TiVo HD they have been aware of for several months. It seems like these issues may be related.

    Ev Jon, as soon as I get the chance, I'll give your fix a try and let you know my results.
     
  11. Wil

    Wil Unknown Member

    4,643
    239
    Sep 26, 2002
    Rovi has turned the Tivo, many years too early, into Oliver Wendell Holmes' One-Hoss Shay.
     
  12. HerronScott

    HerronScott Well-Known Member

    7,328
    1,050
    Jan 1, 2002
    Staunton, VA
    These problems are not related (the Netflix/VOD menu item and the transfers from S3/HD to Roamio). The transfer issue you mention above was introduced with the 20.6.3 update on the Premiere, Roamio and Bolt series and will be resolved in the next update from what we hear.

    The Netflix/VOD menu issue seems to occur with reimaged S3/HD units. When that was originally changed back in April 2015, it was done during a normal connection and no software update so I suspect it was a one time job that was sent out to change the menu item which would explain why units reimaged with an image made before that date still have the old VOD menu item. We can't really confirm this without identifying the date and version of the image that was used to verify it was from before April 2015 and then reimaging with an image made after April 2015.

    Scott
     
  13. TheCryptkeeper

    TheCryptkeeper Active Member

    129
    39
    Dec 31, 2009
    I guess I just noticed both problems at the same time and assumed they were related, since they both referred to my network not working properly. Thanks for setting it straight. The Netflix/VOD worked fine up until a week or two ago, which was around the time I also noticed the transfer function on my Roamio wasn't working. Sorry about the confusion.

    I reimaged my TiVo HD well before April of 2015 with a 2 TB hard drive. If I put the original drive back in, update it, then re-reimage the 2 TB hard drive, will that resolve the issue?
     
    Last edited: Jan 2, 2017
  14. HerronScott

    HerronScott Well-Known Member

    7,328
    1,050
    Jan 1, 2002
    Staunton, VA
    So I'm confused on your issue since the VOD menu item went away and was replaced by Netflix in April 2015. Did that happen on your HD or not? If it didn't and you have not reimaged your HD, the VOD menu item should not have been working as far as I know.

    Scott
     
  15. TheCryptkeeper

    TheCryptkeeper Active Member

    129
    39
    Dec 31, 2009
    Not as confused as I am now. When I go to TiVo Central, I have a Video On Demand Link. When I click on the VOD, I get the "Network Problem" message. My unit originally came with a 60 GB hard drive, which I upgraded to 2 TB two to three years ago. If you upgrade the hard drive, doesn't that require re- imaging from the original?
     
  16. HerronScott

    HerronScott Well-Known Member

    7,328
    1,050
    Jan 1, 2002
    Staunton, VA
    Yes you would have either copied your original drive or imaged the new drive with one of the images available and if it was 2-3 years ago, you should have gotten the change. Do you have Netflix on your Now Playing menu?

    Scott
     
  17. TheCryptkeeper

    TheCryptkeeper Active Member

    129
    39
    Dec 31, 2009
    No, it was there before, but disappeared from the Now Playing menu and Video on Demand doesn't work.
     
  18. TheCryptkeeper

    TheCryptkeeper Active Member

    129
    39
    Dec 31, 2009
    Unfortunately, it did NOT work. My TiVo HD still shows Video on Demand in TiVo Central. No access to Netflix, only instructions to 'Connect to the TiVo service now', which accomplishes nothing. The software version is 11.On.H1-01-2-652. HerronScott, will the new image correct this problem?
     
    Last edited: Jan 3, 2017
  19. HerronScott

    HerronScott Well-Known Member

    7,328
    1,050
    Jan 1, 2002
    Staunton, VA
    Unfortunately, I don't know especially since it's a big unknown as to why it went away in your case.

    Scott
     
  20. TheCryptkeeper

    TheCryptkeeper Active Member

    129
    39
    Dec 31, 2009
    I spoke with TiVo Technical Support. They said this is a know issue that has occurred with many TiVo HD owners. They are working on a fix.
     

Share This Page