S3 stuck in guided setup loop

Discussion in 'TiVo Series3 HDTV DVRs' started by Jabber, Oct 2, 2017.

  1. Oct 2, 2017 #1 of 14
    Jabber

    Jabber New Member

    12
    0
    Aug 2, 2007

    Advertisements

    Hello, here's my tale of woe.

    The box is a Tivo S3 (TCD648250B) which suffered from the bad capacitor problem. It was powered off for a few months until I had time to get the new capacitors and replace the bulging ones.

    After replacing the capacitors, the box seemed to be fine, but that night, it failed to get program data with the dreaded S03 error. After doing some research, I tried kickstart 57 without any improvement. I also tried kickstart 54 (the SMART test) just to check, and the drive passed without any problems.

    Unfortunately, following another piece of advice online, I went to the channel list and re-selected my provider. And that's sort of the end of the story right there, since if it can't get past a S03, the Tivo repeats guided setup forever, so now I have a brick. To try and get past the S03, I tried selecting broadcast instead of cable (using the rationale that the broadcast data set may be smaller and more likely to be able to complete). I tried different zip codes, I even tried Canadian post codes. No luck with any of these.

    Before I do anything else, does anyone have any advice on where to go with this next? The box has lifetime service, so it's worth my spending some time on fixing it. I'm very comfortable in Linux and have no problem taking the thing apart - I just don't know what to do next.

    The drive currently in the Tivo is not the original one. I replaced the drive with a larger one back in 2009. I do still have a backup dd image of the original drive.

    In an ideal world I'd be able to save the shows on my current drive, but I suppose if all else fails I could just dd the backup image onto my current drive?

    Any advice would be very appreciated!
     
  2. Oct 2, 2017 #2 of 14
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,292
    1,063
    Apr 6, 2000
    SF Bay Area
    To correct error S03, you must run "Clear Program info & ToDo List" and this may take many hours. Guided Setup does not fix errors, only does channels.

    This is a common and wrong method to fix S03s.
     
  3. Oct 3, 2017 #3 of 14
    sfhub

    sfhub Well-Known Member

    2,883
    485
    Jan 6, 2007
    Can you select zip 00000?

    Another thing you could try is after it gives you the S03 error, I think it gives you an opportunity to retry. Once I was stuck in guide setup loop and I let it sit there for 1hr while I got distracted, then I came back and hit retry (actually by accident) and to my surprise, it got further in the loading before it gave me S03 error. I repeated this over and over and it got a little further every time. Eventually it was able to complete the whole thing.

    After that whenever I get S03 I always to Clear Program Info and ToDo List. I always get S03 upon the 2nd instance of full loss of guide (this is after Comcast added the 1xxx channels that seems to overload the garbage collection), so I try and make sure it never gets that far out of whack.

    Worse case, you can get an image and reinstall, but I would do it on a fresh drive first (leaving your current one in tact, stuck in reboot loop). I think a lot of the images are before the Rovi guide format change, and some people have had issues getting their TiVo's to update to the latest OS when using an older OS. Once you are sure the image you got can work on the test drive, then I would use it on your real drive. The thinking being if it doesn't work on the test drive, you have the opportunity to try more esoteric things with your existing drive.
     
    Last edited: Oct 3, 2017
  4. Oct 3, 2017 #4 of 14
    Jabber

    Jabber New Member

    12
    0
    Aug 2, 2007
    I absolutely would do this... except for the aforementioned guided setup loop. I do not have the option to do anything other than repeat guided setup.
     
  5. Oct 3, 2017 #5 of 14
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,292
    1,063
    Apr 6, 2000
    SF Bay Area

    Advertisements

    With the latest update 20.7.2, Almost all of these are moved under Help.

    Since you already started GS, you have to let it finish. As the previous post explained.
     
  6. Oct 3, 2017 #6 of 14
    Jabber

    Jabber New Member

    12
    0
    Aug 2, 2007
    Gave it a whirl - same S03 result though.

    Good idea, I'll try a few cycles of that. Maybe it'll get me past the problem.

    That's good advice. If it comes to it, I'll try restoring on a different drive first. It's certainly best to preserve what I have just to be safe.
     
  7. Oct 3, 2017 #7 of 14
    sfhub

    sfhub Well-Known Member

    2,883
    485
    Jan 6, 2007
    S3s didn't get a 20.7.2 update.
     
  8. Oct 3, 2017 #8 of 14
    sfhub

    sfhub Well-Known Member

    2,883
    485
    Jan 6, 2007
    BTW I'm assuming you don't care about shows that might be on this S3?

    On newer TiVos, if you put a different drive in, that makes the shows on the original drive inaccessible.

    I don't *think* it does that on older TiVos, but I don't know for sure as I haven't swapped drives in a long time.
     
  9. Oct 3, 2017 #9 of 14
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,292
    1,063
    Apr 6, 2000
    SF Bay Area
    Drats! Foiled again! o_O
     
  10. Teeps

    Teeps Well-Known Member

    2,158
    84
    Aug 16, 2001
    Torrance,Cal...
    OP, does your cable system use a tuning adapter?
    If so, make sure the usb cable is disconnected.

    In the end I believe you will need a new hdd or at the very least a clean image for TiVo Model 648 VERISON 11m

    There are several members here that have links for downloading the image your TiVo needs.

     
  11. Jabber

    Jabber New Member

    12
    0
    Aug 2, 2007
    No tuning adapter.

    Looks like it's going to be a new image or my restoring my old (pre-Rovio) image onto a new drive and seeing if it updates.

    Any chance of saving the various shows on the old drive, or are they a lost cause at this point?
     
  12. Teeps

    Teeps Well-Known Member

    2,158
    84
    Aug 16, 2001
    Torrance,Cal...
    In my limited experience with this sort of problem. Unless the distressed hdd heals, the recordings are lost.
    TiVo made sure that digital to digital transfer was impossible, outside the box; exception being cloning a current working drive to another drive of same size.
     
  13. sfhub

    sfhub Well-Known Member

    2,883
    485
    Jan 6, 2007
    Does your S3 have a phone connection. I'm thinking if you have a local # that still works, you can try it. They may break up the guide data into different chunks over phone that might get by.

    Also when it goes to loading data, does it fail right away with S03, or does it get to some percentage, then fail?
     
  14. sfhub

    sfhub Well-Known Member

    2,883
    485
    Jan 6, 2007

Share This Page

spam firewall

Advertisements