S1 upgrade - 20Gb ok, but 300Gb fails to boot

Discussion in 'TiVo Upgrade Center' started by mhyne, Jan 15, 2006.

  1. mhyne

    mhyne New Member

    8
    0
    Jan 12, 2006
    Today I decided to try and upgrade my S1 to a 300Gb HDD.

    I downloaded the PTVupgrade LBA48 CD v4.01 upgrade CD and created a backup image (original disk was 14Mb). I then restored this to a 20GB drive and popped this in my Tivo to test - all worked well.

    I then did this for the 300Gb drive using the following commands:

    mfsrestore -x -s300 -zpi /mnt/tivo.bak /dev/hdc

    followed by "copykern" (after I mounted the CDROM disk).

    However, when I boot the Tivo with the 300Gb disk, It fails on boot and gives me the green "problem" screen.

    Have I missed something or does anyone know how to debug this further. I trying reproducing the procedure and it give the same problem - the mfsrestore and copykern steps seam to work ok.

    Matt
     
  2. funtoupgrade

    funtoupgrade New Member

    2,000
    0
    Mar 15, 2005
    mfsrestore -x -s300 -zpi /mnt/tivo.bak /mnt/hdc

    Don't know if above is a typo or what you actually used but the last part should be /dev/hcd and not mnt/hdc. I have no experience with drive large than 200GB so never have needed a swap file bigger than 127 but 300 seems too big to me. I recall reading some formulas for figuring out the number to use here on the forum but the seach forum function sucks (in my opinion).
     
  3. mhyne

    mhyne New Member

    8
    0
    Jan 12, 2006
    It's was a typo - now corrected.

    From what I have read, people have been saying to use 300Mb swap for a 300Gb disk. Having said that, I would not think that the swap would be an issue.
     
  4. JamieP

    JamieP Member

    991
    0
    Aug 2, 2004
    You left off -r 4, needed when creating partitions > 274GB. You also need an lba48 aware tivo kernel. I assume "copykern" takes care of that, but I would double check.

    If you use swap > 127GB, you need to make sure it gets initialized properly with tpip, and you need to make sure your kernel can grok a v1 swap. See this for more info.
     
  5. mhyne

    mhyne New Member

    8
    0
    Jan 12, 2006
    Fixed.

    mfsrestore did not have a -r option on the CDs that I had, so I instead ran the following to complete by upgrade:

    mfsrestore -s300 -zpi /mnt/tivo.bak /dev/hdc
    mfsadd -x -r 4 /dev/hdc

    Lastly, ran copykern to reset the swap and fix the LBA48 kernel in place.

    Tivo then came up with 300+ hours of recording ... not bad.

    I then when to silicondust and downloaded their latest turbonet driver CD and installed these.

    All I have to do now is work out what recommended hacks I need to install and hack away.
     
  6. Diana Collins

    Diana Collins Well-Known Member TCF Club

    3,331
    797
    Aug 21, 2002
    New York...
    Without using tpip you still have an uninitialized swap, which will likely result in instability. mfsrestore can not properly initialize a swap larger than 127MB. You need to use tpip to fix that.
     
  7. mhyne

    mhyne New Member

    8
    0
    Jan 12, 2006
    As the last step, I ran copykern which effectively runs tpip as part of the process.
     
  8. ronsch

    ronsch Active Member

    2,003
    0
    Sep 7, 2001
    Tallahassee,...
    I just installed a 300gb drive in my DSR6000 over New Years and later realized that I neglected to use the -r 4 option. My TiVo has been recording like mad but only claims to have 284 hours. I'm hoping mfsrestore just stopped at the 274GB partition limit and that I'm just wasting a little space instead of facing a future failure. I used a swap partition of 256 as that should be more than enough for a 300gb DirecTiVo.
     

Share This Page