S1 Canada Postal Code Entry Cable Only No Proxy

Discussion in 'TiVo Underground' started by Jadawin, Jan 15, 2006.

  1. Jadawin

    Jadawin New Member

    24
    0
    Jan 19, 2002
    I really got tired of trying to find this post (http://www.tivocommunity.com/tivo-vb/showthread.php?t=260977&page=2&pp=30) with a search engine, and since I'm having problems, I thought I'd move the pertinent part over here, with a title I can find in a search. :)

    First the original reply:

    10-29-2005, 09:12 PM #56
    pjwlk Registered User
    Join Date: Oct 2005


    Finally, I have my Series 1 (Yes that's right a SERIES 1) Tivo recording from Canadian Cable using my life-time subscription with Tivo! It took me days of searching the Internet (I still can't get on the forums at tivocanada for what ever reason). My journey took me from Canada to the US, New Zealand, Australia and South Africa! There is a lot of mis-information, half-truths and speculation out there on how to get a series 1 running outside of the US. Since TiVo no longer supports the series 1 software (current version 3.0-01-1-000) I decided to give it my best shot with the info I dug up before having to breakdown and buy a series 2 with a new life-time subscription.

    After a lot of experimenting and learning by trial and error, I found the advice from a guy who calls himself "jealec" to be the primary contributor to my final solution. It also wound up being the simplest solution overall (that I could find). Some of the other procedures may have worked for me eventually, but all of them presented hurdles that I did not know how to overcome (I have only minimal knowledge of both internal workings of the TiVo software and of the use of Linux itself.).

    I've put together a description below of what I had did in order to get my TiVo up and running for Canadian cable in the Toronto Ontario area. Everything seems to be working just fine and my Tivo has called home successfully a second time. Please note that I did not invent or create any of these procedures, files or scripts that are used here and that any credit you may wish to give for any of them should go to the original creators themselves.

    Also, please be advised that I am in NO way advocating that you try this with your TiVo and that having said that, I will not accept any responsibility if you do attempt to do so using what you read here. In other words, if you wind up letting the smoke out of your TiVo or damaging it in some other way. You'll be on your own my friend.

    1) Make sure, before continuing, that you have backed up your TiVo drive(s) and that you can Telnet and FTP into your TiVo. (Search the forums for how-to info if need be.)

    2) If you don't already have the following files download them for transfer to your TiVo. dbget.tcl, dbset.tcl and dbload.tcl. (It's not clear to me if dbload is actually needed or not but it didn't hurt)

    3) Remount the hard drives for Read/Write using this Telnet command: mount -o remount,rw /

    4) FTP the files dbget.tcl, dbset.tcl and dbload.tcl from your PC to your Tivo's /tvbin directory.

    5) Make sure permissions for each file are set properly.
    cd /tvbin [ENTER]
    chmod 755 dbget [ENTER]
    chmod 755 dbset [ENTER]
    chmod 755 dbload [ENTER]

    6) Read the file /tvlib/tcl/tv/Addr.itcl and look for lines similar to:
    variable TS_DEF_HOST "204.176.49.2"
    variable TS_DEF_PORT "80"

    Make note of the Host and Port being used.

    7) Make sure that the last line of your /etc/tclient.conf reflects the info you copied in step 5. (Back up the file before you edit it.) Make the proper string by adding "127::", without the quotes, to the Host IP you noted above, then add a colon, then add the port number, then add three colons. In my case, the last line in tclient.conf now reads as 127::204.176.49.2:80::: (I've read that the IP should either be 127::204.176.49.1:80::: or 127::204.176.49.2:80::

    8) Remount the hard drives for Read Only using this Telnet command: mount -o remount,ro /

    9) Exit Telnet. Exit [ENTER]

    10) Execute a "Clear and Delete everything" function from your Tivo's menu. (TiVo says it will take an hour, mine took 3 hours.) The TiVo should reboot after clearing everything and before the Guided Setup starts, if it doesn't then reboot it by unplugging the power cord and plugging it back in again.

    11) Start the Guided Setup and continue as normal until you get to the zip code screen. When the GS asks you for a zip code just enter any zip, (I used 48234), then continue on as normal until your TiVo says it's going to make the first call home. Execute the steps 12-18 before allowing the call.

    12) Start the tivo shell (you will see a percent sign as the prompt until you exit.)
    tivosh [ENTER]

    13) % dumpobj /State/LocationConfig [ENTER]

    Your Tivo will respond with some like this below:

    % LocationConfig 593780/10 {
    * IndexPath* * * = /State/LocationConfig
    * PostalCode* * = 48234
    * TimeZoneOld* * = 1
    * Version* * * * = 27
    }

    14) Copy the number that your tivo prints out beside the LocationConfig (in this case 593780/10) Use your number in the following commands replacing 593780/10 with yours. This following step verifies that you are reading from the correct spot in the database.

    % % dbget 593780/10 PostalCode [ENTER]

    48234 (TiVo's response)

    15) Now set the same database location with the first four characters of your Postal code. (Replace 593780/10 with the numbers you copied in step 14 and replace G8Z1 with first 4 characters of your postal code.)

    % % dbset 593780/10 PostalCode {G8Z1} [ENTER]

    16) Here you double check the database has accepted your Postal Code entry. (Replace 593780/10 with the numbers you copied in step 15.)

    % % dbget 593780/10 PostalCode [ENTER]

    G8Z1 (TiVo's response)

    TiVo's response must match the first four characters of your Postal Code for it to work correctly. If it does match then exit the tivo shell by pressing the ctrl-c keys.

    17) Remount the hard drives for Read Only with this Telnet command: mount -o remount,ro /

    18) Exit Telnet: exit [ENTER]

    19) Finish the Guided Setup as normal. You should now see a list of your local cable/satellite providers to choose from for Tivo to get the Guide data for.

    If you need to do the guided setup again you will have to reset the zip code using the "dbset 593780/10 PostalCode {48234}" command using the TiVo shell (similar to step 15) or do a "clear and delete everything" again so you can get past the zip code entry screen again. Hopefully somebody will come up with a hack soon that will allow us to enter our postal codes easily just like the series 2 units do.
     
  2. Jadawin

    Jadawin New Member

    24
    0
    Jan 19, 2002
    Now, this works for me, to a point. And then it doesn't :D

    There's at least one 'logic flow' problem in it, in that there's a mount RO without a mount RW before it.

    My system: S1 Phillips, TivoWeb (yes, still), CacheCard, B drive added (120GB)
    Did a C&DE. Took down my old proxies. Followed the steps above.

    When I ctrl-C out of the tivosh, the system does a reset on me.

    Comes back in Guided Setup, of course. Postal code TRIES to show, but the letter fields are blank, and I have to zero it out again to get it to work.

    I have a 'dbget' and a 'dbset' that are not .tcl, that I found with a search here. They seem to work. I have no dbload.

    Going to try again without exiting the tivosh (/ is still RO at this point, changes are being made).

    Mostly, this post is documentation, but if you have a clue as to what process is dying to make my TiVo reboot, please, comment! :)
     
  3. Sep 4, 2007 #3 of 11
    westcoastguy420

    westcoastguy420 New Member

    1
    0
    Mar 6, 2005
    anyone have any luck with this? i get the numeric values of my postal code showing up in the 5 digit zip field after it tells me there are no providers in my area. ie _3_3_
    i did check before allowing the call and the dbget showed postalcode v3r3
    any other ideas? as for the tclient.conf file can i edit this through joe using bash or do i have to save the file edit it and reupload it. im finding that the changes im making to this file do not take even after a chmod 755 and a remount as rw
    and finally where exactly do the changes to that file go? at the last line at the bottom under the engineering test part or near the top where the address 204.176.49.1 is referenced with 101:: do i simply change the 101 to 127 or add the whole new string at the bottom? has anyone been able to make this work?
     
  4. Sep 9, 2007 #4 of 11
    n4zmz

    n4zmz TiVoholic

    23
    0
    Mar 28, 2002
    Your problem might be related to the fact that you are not running a proxy to translate the requests from your series 1 to the mothership. Upon initial research on the issue, it was determined that a proxy was the easier way to go. tivoZA created one which is in use in Canada.
     
  5. pjwlk

    pjwlk New Member

    9
    0
    Oct 21, 2005
    The series 1 TiVo can't show the alphabetical characters so any boxes with letters in them show up blank. The numeric values are what's left over from the first 4 characters or your postal code. I just discovered that the hack only works for cable providers for some reason and doesn't find any providers for satellite. The hack works fine with the double remount as read only. Not sure why it's needed but you don't need to mount as read/write

    I don't use a proxy and everything works fine for me with the exception of no providers for satellite.
     
  6. gord12345

    gord12345 New Member

    2
    0
    Dec 31, 2009
    Jadawin

    Just landed a S1 with lifetime and cachecard and then figured out the software does not support Cdn (I'm in Edmonton) postal codes.

    Wondering if your workaround is still working for you?

    I know even less about Linux but might try to educate myself...
     
  7. Jan 3, 2010 #7 of 11
    classicsat

    classicsat Astute User

    17,877
    0
    Feb 18, 2004
    Ontario Canada.
    All I can say is try it and see.
     
  8. stevo1

    stevo1 New Member

    1
    0
    Dec 27, 2009
    I recently acquired a series 1 with lifetime here in Toronto and this process does work... it was a nice learning experience for linux and ftp. A few things to note:

    1. make sure that you ftp dbget and dbset to your Tivo in binary mode so they are usable.
    2. type exit to leave tivo shell (not sure if this is critical, but control-c seemed to kick me back a couple of steps in guided setup to reveal those blank zip code spots).
    3. if you don't already have network functionality, you may have to try that tivoZA thing and do everything while your drive is mounted in your PC

    I will be using this technique for my other (unsubbed) S1 boxes so that they at least give the correct channels. I'm also fooling around with Tivoweb.

    Steve

    Series 2 w/Lifetime
    Series 2 Pioneer 810H w/Basic
    Series 1 w/Lifetime - for my mom
    2 Series 1 unsubbed w/Turbonet
    Series 1 unsubbed w/nothing
     
  9. dcstager

    dcstager 1st Gen Tivo Owner

    587
    5
    Feb 16, 2002
    Skagit...
  10. gord12345

    gord12345 New Member

    2
    0
    Dec 31, 2009
    Thanks Stevo

    I did get it working around the middle of January (using the "hackpack" stuff I found at Tivoza which included the dbget, dbset and dumpobj) - same procedure as the one in this thread. Lots of fun playing with, only a little frustrating. Then I was swamped getting ready for our Feb vacation and never got around to looking at the forums again until today.

    I never did get the Tivoza proxy system to work.

    Just got another S1 and did the postal code fix (tried the proxy again, still can't figure that out) but I got the dbset method done pretty fast this time.

    You collection sounds like mine:

    two S1 Philips upgraded HD's with cachecards, both lifetime
    S2 Dual Tuner with lifetime (first one I got)
    S2 Pioneer 57H/DVD with basic
    two S1 Sony 2000 with nothing (to play around with)
    one S1 Sony 2000 with lifetime (but damaged in shipping)


    On to the next thing - did you get Tivoweb working?
     
  11. Leota

    Leota New Member

    5
    0
    Oct 22, 2011
    Thanks a lot for this work around :D
     

Share This Page