Roamio stuck on Welcome! Starting up... green center light blinks once then stays lit

Discussion in 'TiVo Roamio DVRs' started by speedster326, Oct 28, 2019.

  1. speedster326

    speedster326 New Member

    1
    0
    Oct 28, 2019
    Trying to figure out if my Tivo Roamio 500GB (Model TCD846500, both OTA & Cable Card options) with Lifetime subscription can be saved. It was working fine (albeit, there was the occasional random reboot), but when I returned to the room last week, it was suddenly stuck on the "Welcome! Starting up..." screen with the internal green light staying blinking about 20-30 seconds after power up and then remaining lit AND the green circular area lit up on the front left of the device.

    I've seen lots of posts and articles about the power supply and various blinking front lights, but I haven't found any instances of the green light blinking briefly and then remaining lit indefinitely. Does anyone have any other ideas? Is it worth trying to have the Weakness Repair Service folks take a look? I emailed with them briefly and they said it is always either the power supply or the hard drive, but I've replaced both and the issue persists.

    Here's what I've tried so far:
    • Purchased a replacement power supply on Amazon. Even though it says on the box and in the listing that it was 12vdc 2amp, I just noticed the sticker on the wall wart itself says it's 12vd 0.5am. Aargh. I was able to snag a comparable 12vdc 2amp wall wart from a Seagate external drive and have tried that as well. Neither has an impact - still getting the endless "Welcome! Starting up..." screen with solid green lights. The yellow/amber light never lights up, so I can't try any of the troubleshooting codes.
    • Replaced the original 500GB hard drive (a WD Green Drive) with a brand new WD Red 3TB NAS drive (WD30EFRX). No change, green lights still on and center one blinks once about 20 to 30 seconds after power up, then stays lit. I even tried exchanging the RED drive with another in case it was bad, and the second new one has no effect. I waited more than 30 minutes with both drives in case the system needed time to initialize the drive, but no change.
    Would appreciate any suggestions!
     
    Last edited: Oct 29, 2019
  2. Slumpert

    Slumpert Member

    47
    34
    Oct 18, 2019
    If you have a cable card installed, have you tried to remove it and see if it boots up?
     

Share This Page