1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roamio Seems Sluggish after Update

Discussion in 'TiVo Roamio DVRs' started by MBritt, Jun 6, 2018.

  1. MBritt

    MBritt New Member

    3
    0
    Jun 6, 2018
    Anyone else notice their Roamio being sluggish and less responsive after the user interface update?
     
  2. JoeKustra

    JoeKustra in the other Alabama TCF Club

    14,907
    2,240
    Dec 7, 2012
    Ashland, PA...
    Hydra or Encore? But no, no change with last month's updates.
     
  3. MBritt

    MBritt New Member

    3
    0
    Jun 6, 2018
    The Hydra interface is what slowed down the responsiveness of my Roamio OTA. It feels like upgrading to a new IOS on an iPhone where everything runs slower. At least several of the interface quirks have been fixed in auto updates.
     
  4. Barnstormer

    Barnstormer Member

    57
    21
    Sep 23, 2015
    So far I have not upgraded to Hydra. I don't think I am missing very much.
     
  5. marhil

    marhil New Member

    18
    5
    Oct 14, 2015
    I noticed my Roamio and minis have been sluggish lately. I've been on Hydra since it came out and did not have the sluggish issue until about a month ago or so. Sometimes when I go to change a channel the channel information is missing. Sometime if I hit the 'Guide' button the channel information is the grid is missing or very slow to populate. Sometimes get a 'lost connection' message. Tried rebooting the Roamio and minis but that does not help. Any I do notice the Roamio and minis are less responsive to commands, mostly when I change channels.
     
  6. JoeKustra

    JoeKustra in the other Alabama TCF Club

    14,907
    2,240
    Dec 7, 2012
    Ashland, PA...

Share This Page