Roamio Plus bad HDMI port after 11/20 update.

Discussion in 'TiVo Roamio DVRs' started by kad7777, Nov 26, 2019.

  1. kad7777

    kad7777 Member

    67
    14
    Mar 20, 2008
    I'm extremely curious. Anyone else have this problem?

    Thought it was very odd that I went to sleep and woke up Wednesday (11/20) with a dead signal on my TV when I turned it on. Of course, tried everything under the sun and the conclusion (from Tivo) was "it happens" and would I like a replacement for $280. Could be coincidence, but my spidey sense is tingling.
     
  2. KLINK

    KLINK Member

    158
    2
    Aug 17, 2004
    I had the same thing happen to me with my Bolt on 11/23. They said $79 for a renewed Bolt and $199 deposit. I get $199 back when I return the damaged Bolt. They gave 90 days to return the bad box.

    The renewed box was a Vox.
     
  3. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,410
    3,507
    Dec 7, 2012
    Ashland, PA...
  4. kad7777

    kad7777 Member

    67
    14
    Mar 20, 2008
    I was told $79 for renewed Bolt replacement. $199 to keep my lifetime service (because warranty expired), and $369 deposit that will be returned when they get my Roamio. Just happy my component connections work so I can still use Tivo. Still odd to me that the hdmi port crapped out on the same day of the update. Called Tivo to let them know in case they get other calls relating to the same issue
     
  5. kad7777

    kad7777 Member

    67
    14
    Mar 20, 2008
    Thanks for linking my other post
     
  6. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,410
    3,507
    Dec 7, 2012
    Ashland, PA...
    I was going to make some suggestions, but they are covered in that post.
     

Share This Page