Restore error - Need help

Discussion in 'TiVo Upgrade Center' started by cma371, Aug 21, 2007.

  1. cma371

    cma371 New Member

    18
    0
    Jul 30, 2007

    Advertisements

    My hard drive crashed and I tried to restore a backup image to another hard drive that was the same size but not the exact same hard drive. I get an error that "backup target is not large enough". Is there any command that I can use to restore to ignore this error?
     
  2. Da Goon

    Da Goon Registered Abuser

    1,396
    0
    Oct 22, 2006
    Try leaving off the -x switch from your restore command if you were using it. If not, then just as the message suggests, the image may not fit on that drive.
     
  3. HomeUser

    HomeUser Active Member

    2,452
    13
    Jan 12, 2003
    A2 Michigan
    Some information that might help
    - TiVo model?
    - Boot CD you are using?
    - The command options you are using
    - The size of the drives?

    I will assume it is the SD-H400 you were looking for an image for.
    If you are uning the MFSLive CD leave out the larger swap -s 128 and expand x then the command would be something like
    restore -zpi /mnt/cdrive/sd-h400.bak /dev/hdc
     
  4. ciper

    ciper Active Member

    2,011
    1
    Nov 4, 2004
    How about model numbers of both hard drives so we can verify they really are the same size. Two drives sold as "40gb" rarely have the exact same amount of space even if they are from the same manufacturer.
     
  5. cma371

    cma371 New Member

    18
    0
    Jul 30, 2007

    Advertisements

    original hard drive -- Maxtor DiamondMax 16, 80gb ATA/133
    replacement -- Western Digital - WD800 - 80gb

    Toshiba SD-400

    using weaknees Cd

    used mfsrestore -r4 -bzpi /mnt/dos/tivo.bak /dev/hdd

    mfsrestore -r4 -bzi /mnt/dos/tivo.bak /dev/hdd

    mfsrestore -bzpi /mnt/dos/tivo.bak /dev/hdd

    same error "backup target not large enough
     
  6. spike2k5

    spike2k5 New Member

    419
    0
    Feb 21, 2006
    WD is slightly smaller so the error message is accurate. You have to find a bigger drive to restore to.
     
  7. cma371

    cma371 New Member

    18
    0
    Jul 30, 2007
    ok, thanks I was hoping there was a way to ignore the error and let it restore. The image is only 1gb and the drive is 80gb.
     

Share This Page

spam firewall

Advertisements