Remove Netflix.....How?

Discussion in 'TiVo Premiere DVRs' started by Resist, Jan 26, 2012.

  1. Resist

    Resist Well-Known Member

    2,021
    53
    Dec 21, 2003

    Advertisements

    If there a way to remove Netflix from my Tivo Premiere with firmware 20.2? I don't have a Netflix account and don't plan on getting one.
     
  2. Mike Pfeifer

    Mike Pfeifer What?

    50
    0
    Mar 16, 2011
    Chicago
    You can remove it from being displayed by going to settings, channels, my video providers. Unselect it there.
     
  3. Resist

    Resist Well-Known Member

    2,021
    53
    Dec 21, 2003
    Thanks! I had deleted it with 14.9 but it's been so long that I forgot how.
     
  4. gteague

    gteague golftango

    528
    0
    Apr 1, 2007
    dfw (euless)
    that one's easy to forget. for some reason i don't associate those 3rd-party sites with 'channels' at all. i only found it again by accident when i got a new tivo and it was driving me nuts.

    /guy
     
  5. mchiles

    mchiles Member

    74
    2
    Jul 13, 2007

    Advertisements


    Hey, I am not seeing that option under "Settings>Channels" I have an Elite running 20.2

    My Video Providers is not an Option
     
  6. bshrock

    bshrock Member

    267
    0
    Jan 6, 2012
    Is the Elite yours or is it one provided by the Cable Co?

    Cable Co DVR's probably do want you to use the competition.
     
  7. mchiles

    mchiles Member

    74
    2
    Jul 13, 2007


    I owned the Elite. It is not a cable provide DVR.
     
  8. bshrock

    bshrock Member

    267
    0
    Jan 6, 2012
    You need to enable transfers. See the instructions in "Show the Steps" Before you begin: Activating your TiVo box on your Netflix account

     
  9. mchiles

    mchiles Member

    74
    2
    Jul 13, 2007
  10. WizarDru

    WizarDru New Member

    147
    0
    Jan 18, 2005
    Malvern, PA
    Does this work for Hulu Plus in the same way? I'll have to enact that change tonight!
     
  11. SugarBowl

    SugarBowl Member

    861
    12
    Jan 4, 2007
    north carolina
    TiVo with HD menus: Go to TiVo Central > Messages & Settings > Settings > Channels > Video Provider List. Select Netflix to uncheck or check the box.

    TiVo with SD menus: Go to TiVo Central > Video On Demand > Netflix, and then select ‘Show in Now Playing List.’ Choose to “Don’t Show” or “Show” Netflix in Now Playing List.
     
  12. WizarDru

    WizarDru New Member

    147
    0
    Jan 18, 2005
    Malvern, PA
    Outstanding! Goodbye Hulu and other services I don't use.

    Thanks.
     

Share This Page

spam firewall

Advertisements