Reelgood app and Amazon Prime launching

Discussion in 'TiVo Stream 4K' started by moyekj, May 13, 2020.

  1. spiderpumpkin

    spiderpumpkin Say no to Hydra!

    300
    176
    Dec 1, 2017

    Advertisements

    When you did the cmd package install-existing com.tivo.atom did it say success or something else? If it said success then it should be in the apps. Maybe disabled still? If it didn't say success then you probably need to enable it before you can reinstall it.
     
  2. moyekj

    moyekj Well-Known Member

    12,280
    935
    Jan 23, 2006
    Mission...
    No success or failure indication really. Just ran this in shell again and you can see responses:
    Code:
    SEI400TV:/ $ pm enable com.tivo.atom
    Package com.tivo.atom new state: enabled
    SEI400TV:/ $ cmd package install-existing com.tivo.atom
    Package com.tivo.atom installed for user: 0
    SEI400TV:/ $ reboot
    
     
  3. spiderpumpkin

    spiderpumpkin Say no to Hydra!

    300
    176
    Dec 1, 2017
    It was installed this time. If it was installed the first try then you would have gotten an installed already error. Did you look for it in system settings- apps? It should be in there. Even when uninstalled it is still in there but under system apps.
     
  4. moyekj

    moyekj Well-Known Member

    12,280
    935
    Jan 23, 2006
    Mission...
    OK, after this last set it finally came back now, so yes I had to enable first and then install.

    I verified that direct launch into Prime episodes now works and starts playback, so looks like TiVo did issue a fix for that.
     
  5. spiderpumpkin

    spiderpumpkin Say no to Hydra!

    300
    176
    Dec 1, 2017

    Advertisements

    Glad to hear it works. Those adb shell unistall commands really don't do any permanent damage because the apks are still there just deactivated and hidden. The uninstall does a better job than disable at hiding them deeper in the system apps instead of just putting them in disabled app section.
     
  6. zyzzx

    zyzzx Go Bucks! TCF Club

    5,111
    237
    Jan 22, 2002
    Severna...
    I believe this issue is fixed now. I was able to launch a few Prime shows directly from the Reelgood app this morning on my TS4K.
     
    mrizzo80 and aaronwt like this.
  7. mrizzo80

    mrizzo80 Well-Known Member

    3,208
    556
    Apr 16, 2012
    I don’t think it’s fixed. I just tried to open an AP show from ReelGood and it just opened the AP home screen.

    I have auto-update apps enabled at the OS-level.
     
  8. moyekj

    moyekj Well-Known Member

    12,280
    935
    Jan 23, 2006
    Mission...
    I didn't get any notification yet from Reelgood on my ticket about this so assume it's not fixed yet.
     
  9. mrizzo80

    mrizzo80 Well-Known Member

    3,208
    556
    Apr 16, 2012
    I think this might be resolved now. It launched episodes from two different shows correctly.
     
  10. zyzzx

    zyzzx Go Bucks! TCF Club

    5,111
    237
    Jan 22, 2002
    Severna...
    It’s working here. Every Amazon Prime episode I’ve launched this week has started directly.
     
  11. zyzzx

    zyzzx Go Bucks! TCF Club

    5,111
    237
    Jan 22, 2002
    Severna...
    Another issue: Is there any way to launch Amazon Prime 4K shows directly from Reelgood? The standard version gets loaded with no apparent way to indicate the 4K version.
     
  12. moyekj

    moyekj Well-Known Member

    12,280
    935
    Jan 23, 2006
    Mission...
    Yes, working for me now too. Never did get an email from Reelgood based on my issue report stating they fixed it.
     
  13. mrizzo80

    mrizzo80 Well-Known Member

    3,208
    556
    Apr 16, 2012
    Thanks again for taking the time to report the issue to them.
     
    moyekj likes this.

Share This Page

spam firewall

Advertisements