ReadyNAS fast transport (TS) restores bad, pytivo okay

Discussion in 'TiVo Home Media Features & TiVoToGo' started by jth tv, Apr 7, 2020.

  1. jth tv

    jth tv Well-Known Member

    1,723
    151
    Nov 15, 2014

    Advertisements

    RN214 ReadyNAS backups work great using fast transport.
    But for me, T3 Roamio restores of those files does Not.

    Yet a PyTiVo Desktop restore of those same ReadyNas files does work fine.

    Perhaps there is a configuration problem with ReadyNAS. I have been unable to find the ReadyNas log of Restores. Hopefully there are some logs somewhere on ReadyNAS that will help, I could sh to take a look.

    Any ideas ?
     
    Last edited: Apr 7, 2020
  2. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,097
    168
    Jul 9, 2001
    Central Jersey
    TS Sync Errors?

    When you speak of "pytivo restore", do you mean @wmcbrine PyTiVo or @Dan203 PyTiVo Desktop? IIRC, Dan added code to ignore TS Sync Errors when sending files back from PC -> TiVo.

    Personally, I only use PyTiVo Desktop to (repeatedly) download shows via Transport Stream (to get unscrambled Closed Captions with zero TS Sync Errors) and then I use Streambaby to view these shows (with FULL TiVo Trick Play from my NAS). Since my NAS is also running Plex, I can also view these shows on my Amazon Fire Tablets.

    I'm *VERY* thankful to @Dan203 for adding "0x47 every 188" (PyTiVo Desktop / "0x47 every 188" / TS Sync Errors: Do You Use It?). :thumbsup:

    [And confused by the lack of support / interest from other TCF members back in 2017. :confused: ]
     
  3. jth tv

    jth tv Well-Known Member

    1,723
    151
    Nov 15, 2014
    Using PyTiVo Desktop to restore the ReadyNAS files works great. I'll edit message 1 and read up on the TS Sync Errors. Thanks.
     
    Last edited: Apr 7, 2020
  4. jth tv

    jth tv Well-Known Member

    1,723
    151
    Nov 15, 2014
    ReadyNas uses minidlna to restore files to Tivo. I turned on minidlna debugging. The logs are filled with a Sony Receiver and a Sony BluRay talking DLNA even though they are in standby, so I had to unplug them to make the logs easier to read.

    There was nothing that would explain the problem, the file stops transferring and nothing in the log explains why.
     

Share This Page

spam firewall

Advertisements