Q: Intermittent blank "Now Playing" list after applying Zipper hacks?

Discussion in 'TiVo Underground' started by JeffHayes, Dec 26, 2005.

  1. JeffHayes

    JeffHayes New Member

    6
    0
    Oct 9, 2004
    I have upgraded my DVR80 with a 300GB hard drive. Used the Weaknees upgrade instructions to allow for large drives.
    restored using: mfsrestore -s 150 -r 4 -xzpi /mnt/tivo.bak /dev/hdc

    Updated the system with the Zipper. (PS: The Zipper Rocks, as far as hacking goes. Way fast no problems.)
    The Zipper performed the following hacks:
    - Installed channel logos
    - Replaced the “Almost There” splash screen
    - Installed a profile with “aliases”
    - Installed customized Version of Tivowebplus.
    - Installed a fully functional cron setup
    - Removed MRV/HMO expiration certificates from MFS.
    - Made a Backup of Season Passes and Wishlists.
    - Appended Crontab to Make a Weekly Backup of Your Season Passes and Wishlists..
    - Updated fakecall.tcl with a Version That Works with 6.2.
    - Added Showcases and Yellow Stars.
    - Installs NCID CallerID Application.
    - Installs USB 2.0 Drivers.
    - Confirmed network settings are appropriate for MRV.
    - Installs the joe Text Editor.
    - Customizes Your Bash Prompt.

    Corrected the invalid SWAP file.
    - Telnet into system performed the following:
    - mkswap /dev/hda8
    - swapon –a
    - Verified SWAP now active in log files.


    Everything seems to work as it should, but I have found an issue with the “Now Playing” list. Intermittently, when I remove a program and the list refreshes, or simply enter the “Now Playing” menu item, the list will be blank.

    This problem seems to correct itself buy waiting for a few minutes then trying again, or rebooting the system.

    Has anyone else seen this?
    Is this a known problem and or a fix to this problem?
     
  2. Gunnyman

    Gunnyman Just a boring dude

    31,804
    831
    Jul 10, 2003
    Upstate...
    this behavior is usually indicative of incorrect DNS settings.
    Do the settings on the tivo for DNS reflect the ones in your router?
     
  3. JeffHayes

    JeffHayes New Member

    6
    0
    Oct 9, 2004
    Ah ha....

    Currently, my wireless bridge is not working, so when I need to work with Tivo, I make a manual connection with a cross-over cable.

    So there is no live connection to the Router or DNS servers until I get my Wireless Bridge up and running. (Waiting on Talsiman 1.11 to be released for the WRT54GS v4 router)

    Q: Why do I need a live DNS connection for the Now Playing list to work?
    Q: What else might be broken without the live DNS / Internet connection?
     
  4. Gunnyman

    Gunnyman Just a boring dude

    31,804
    831
    Jul 10, 2003
    Upstate...
    I am not entirely sure why DNS needs to work but MRV will NOT work without it.
     
  5. JeffHayes

    JeffHayes New Member

    6
    0
    Oct 9, 2004
    Good enough.

    I will follow up after I get full connectivity to my DTivo.


    Thanks again.
     
  6. JamieP

    JamieP Member

    991
    0
    Aug 2, 2004
    It doesn't have to work. It just has to "fail fast" to avoid the now playing display delay. Don't set a DNS server, or set it to 0.0.0.0; same for the default route. Ref: ADH's post 222440 at DDB. On a SA tivo, just remember to set it back to a valid DNS server once you get the network working if you want the tivo to "phone home" across the network.
     
  7. dnemec123

    dnemec123 Member

    497
    0
    Jan 24, 2004
    Oregon
  8. teberly

    teberly New Member

    11
    0
    Dec 23, 2005
    Here are the contents of my etc/host file:

    ******
    # Copyright (c) 2001 TiVo Inc.
    127.0.0.1 localhost.localdomain localhost
    *******

    What were your edits?
     
  9. JeffHayes

    JeffHayes New Member

    6
    0
    Oct 9, 2004
    quick follow up.

    Establishing a live link to the network and solved the slow "Now Playing" list problems.

    I agree, it should fail fast when the DNS server is not available.
    I will experiment with the hosts files and other files a bit later.

    Thanks for all of you assistance.
     
  10. dnemec123

    dnemec123 Member

    497
    0
    Jan 24, 2004
    Oregon
  11. magnus

    magnus Tivo User

    2,507
    0
    Nov 12, 2004
    Texas

Share This Page