pyTivoX

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Yoav, Dec 10, 2008.

  1. Rdian06

    Rdian06 New Member

    463
    0
    Apr 12, 2008

    Advertisements

    http://www.tivocommunity.com/tivo-vb/showthread.php?t=434361

    FYI, this was easy to find when you search this forum for: pyTivo group
     
  2. Oct 2, 2010 #1042 of 1455
    elmeng

    elmeng Member

    52
    0
    Mar 7, 2009
    Thanks, Rdian06.
    That did help allot. The webpage that did break it all down for me I found with a google search. http://pytivo.sourceforge.net/wiki/index.php/Metadata#seriesId
    I then start a search for some seriesId of TV shows and found a few.

    I'm still looking for:
    The Vampire Diaries
    Smallville
    Nikita

    Leslie
     
  3. Oct 9, 2010 #1043 of 1455
    mnb

    mnb Member

    34
    0
    Sep 15, 2004
    The problem I'm having with pytivox is that streambaby stops showing up in Showcases after a while.

    I go to the Mac, quit pytivoX. Wait 30 seconds or more. Restart it. Go back to the Tivo... it still doesn't show up.

    When it works, it works great. I noticed this error in the streambaby log last time I restarted it:

    Sat 2010/10/09 13:02:28.513| |main|Main|mdns_type=_tivo-hme._tcp.local. factory=StreamBabyStreamFactory[/streambaby/,pyTivoX - Conductor.local] port=7290
    Exception in thread "JmDNS.SocketListener" java.lang.StringIndexOutOfBoundsException: String index out of range: -1
    at java.lang.String.substring(String.java:1937)
    at javax.jmdns.impl.JmDNSImpl.toUnqualifiedName(JmDNSImpl.java:1461)
    at javax.jmdns.impl.JmDNSImpl.updateRecord(JmDNSImpl.java:933)
    at javax.jmdns.impl.JmDNSImpl.handleResponse(JmDNSImpl.java:1025)
    at javax.jmdns.impl.SocketListener.run(SocketListener.java:68)
    at java.lang.Thread.run(Thread.java:637)



    I installed the latest beta and I get a different Java error:
    Sat 2010/10/09 13:25:04.025| |main|Main|mdns_type=_tivo-hme._tcp.local. factory=StreamBabyStreamFactory[/streambaby/,pyTivoX - Conductor.local] port=7290
    Exception in thread "JmDNS(10.local.).SocketListener" java.lang.IllegalArgumentException: The instance name component of a fully qualified service cannot be empty.
    at javax.jmdns.impl.ServiceInfoImpl.checkQualifiedNameMap(ServiceInfoImpl.java:356)
    at javax.jmdns.impl.ServiceInfoImpl.<init>(ServiceInfoImpl.java:197)
    at javax.jmdns.impl.ServiceInfoImpl.<init>(ServiceInfoImpl.java:181)
    at javax.jmdns.impl.DNSRecord$Pointer.getServiceInfo(DNSRecord.java:553)
    at javax.jmdns.impl.DNSRecord$Pointer.getServiceEvent(DNSRecord.java:564)
    at javax.jmdns.impl.JmDNSImpl.updateRecord(JmDNSImpl.java:1264)
    at javax.jmdns.impl.JmDNSImpl.handleRecord(JmDNSImpl.java:1398)
    at javax.jmdns.impl.JmDNSImpl.handleResponse(JmDNSImpl.java:1417)
    at javax.jmdns.impl.SocketListener.run(SocketListener.java:72)
    at java.lang.Thread.run(Thread.java:637)
     
  4. Marconi

    Marconi TiVo Junkie

    451
    0
    Sep 8, 2001
    Page, AZ USA
    It may be a per-share option in pyTivo but there's only one place to set alpha on/off in pyTivoX prefs. Is there a config file I can put into each share to set the alpha to on or off? IOW, how do I set alpha sorting for each share separately using pyTivoX?
     
  5. jsprung

    jsprung New Member

    8
    0
    Aug 29, 2002

    Advertisements

    I just picked up a Tivo Premier last week to try ( I'm getting tired of Directv stringing me along) and am very interested in PYTivo. I know PYTivo has been out for several years now and maybe that is why I am having some issues finding out basic setup information so I apologize in advance if this has been discussed much earlier.

    I have all my videos stored on a Drobo system externally and PYTivox had no problem finding my VIDEO-TS files or my MP4 files. I guess I must have all these files encoded incorrectly for PYTivo because I get a bunch of different errors depending upon if I am using PYTivo or StreamBaby. This is what is happening:

    On all my Video_TS files under PYTivo I get the "copyright" restriction error. An example of my current movie file structure looks like the following: Video/Movies/American Beauty/Video_TS/"a whole bunch of VTS files".

    On my Apple or my Netgear media player you just point to the TS files and your fine. On the Tivo, it keeps digging deeper into the file structure so I assume it need to be set up differently. I'm sure this make sense to someone.

    For my MP4 files ( all TV shows converted from Handbrake ) nothing shows up on PYTIVO

    Now for streambaby I am getting different error my messages:

    For my MP4 files, everything shows up beautifully with all the cover art and descriptions intact but when I hit play I get the FFMpeg app crashing on my Mac. For the Video_TS files the same thing happens as well.

    Any thoughts, Thx

    -Jason
     
  6. TexasMan

    TexasMan TexasMan

    6
    0
    Apr 11, 2010
    This is what I'd suggested previously that there's some sort of Java error being thrown up most likely due to the last two update of Java by Apple. So far, it seems like no one's willing to try to resolve it so I'll just continue to utilize the copy to aspect rather than the streaming which no longer seems to work with the latest software and updates from Apple.
     
  7. Nov 7, 2010 #1047 of 1455
    grifforama

    grifforama New Member

    4
    0
    Nov 15, 2006
    Quicj question for everyone.
    I'm running pytivoX on my premiere, and I see the pytivox app under Showcases and Extras. I don't see Stream Baby Stream anywhere, but I have noticed that when I go into the pytivox app on the Tivo, it's actually streaming using SBS (I check logs and they update when I watch videos)
    Is this correct ? Has it been merged into 1 app ?
     
  8. Nov 7, 2010 #1048 of 1455
    pilotbob

    pilotbob New Member

    293
    0
    Nov 8, 2007
    Florida
    When you are in the Showcases menu you are using StreamBaby, you are streaming when you play from here. Yes, it says pyTiVoX. When you are in the Now playing list it is pyTivo it is copying/pulling.

    BOb
     
  9. Doug0915

    Doug0915 New Member

    4
    0
    Sep 27, 2008
    maximum file size for push?

    I've got the latest beta loaded 1.4.1b and noticed that when I tried to push a 7GB mp4 it would almost push the whole thing and then as soon as it would finish the file would get deleted. Is there a maximum file size for pushing .mp4 files to the tivo on pytivox?
     
  10. wmcbrine

    wmcbrine Well-Known Mumbler

    11,892
    936
    Aug 2, 2003
    No, there is no maximum.

    Instant deletion happens when the size estimated at the beginning of the transfer is smaller than the actual size of the data transferred. This, in turn, only happens when the file is transcoded (and of course, usually not even then). So it looks like your MP4 is not actually in spec for a push. Either that, or perhaps it's being processed by qtfaststart, and something is going wrong there.
     
  11. Doug0915

    Doug0915 New Member

    4
    0
    Sep 27, 2008

    Interesting. I'm using ffmpeg 0.6.1 and usually when I get an .mkv using h264 and AC3 I do a quick copy of the video and transcode of the audio to an mp4 container (cause it's quick, and don't lose video quality). It seems to work doing instant streaming, but of course with a huge file (7GB) if I streamed it there would be re-buffering every 1GB or so (right?) which is pretty annoying on a nice long movie. :)

    I'd take my test.mkv and do

    ffmpeg -i test.mkv -vcodec copy -acodec libfaac -ab 160k -ac 2 test.mp4

    That is what I usually create and then push. What do you recommend to figure out what the problem is? Do a re-transcode of the video with -sameq to try and make the .mp4 spec?

    thanks!
     
  12. grifforama

    grifforama New Member

    4
    0
    Nov 15, 2006
    Great. Thanks for the clarification.
     
  13. TexasMan

    TexasMan TexasMan

    6
    0
    Apr 11, 2010
    Not a Bonjour problem on my end. I have several devices which utilize it and they're working fine. I guess I'll just have to live with copying over to the Tivo rather than streaming. I'm hopeful there'll be an update soon which restores the functionality of StreamBaby for me. I did notice on the forums I don't seem to be the only Mac user with this problem.
     
  14. lofreco

    lofreco New Member

    7
    0
    Apr 9, 2010
    California
    Yes, pyTIVOx works great.. just installed in on a Mac OS X, 10.6.5 Snow Leopard. Can view any video format, .avi, .wmv, etc.

    videos show up on your playlist. Very simple setup.

    No need to spend money on ROXIO TOAST, like TIVO tech support will tell you to do.
     
  15. Dec 1, 2010 #1055 of 1455
    ldc3000

    ldc3000 Member

    95
    0
    Jun 24, 2004
    NC
    I'm so thankfully I found this. Now I don't have to go out and buy a separate set top box to watch my personal videos.
     
  16. Dec 3, 2010 #1056 of 1455
    gvegastiger

    gvegastiger New Member

    24
    0
    Apr 30, 2008
    My Tivo series 2 apparently got an update last night and now my shared folders don't show up in my Now Playing List anymore.

    I tried to stream them in the Showcase area but my Tivo just says Please Wait indefinitely.

    Any help would be appreciated. I've tried resetting the Tivo and pyTivoX and my Mac. Any ideas?

    Oh, I'm running pyTivoX on OS X 10.6.5
     
  17. Dec 3, 2010 #1057 of 1455
    wmcbrine

    wmcbrine Well-Known Mumbler

    11,892
    936
    Aug 2, 2003
    Series 2 TiVos don't support streaming. Beyond that, I dunno. If the Series 2 is moving past 9.3.2b, you're the first to report it. Did you actually see an upgrade message?

    Oh, but try rebooting.
     
  18. Dec 4, 2010 #1058 of 1455
    gvegastiger

    gvegastiger New Member

    24
    0
    Apr 30, 2008
    I didn't see an upgrade message. I just noticed that it had connected yesterday morning and updated.

    I shut it down, but I haven't tried a hard reboot yet. I'll give that a try.
     
  19. Dec 4, 2010 #1059 of 1455
    gvegastiger

    gvegastiger New Member

    24
    0
    Apr 30, 2008
    Unplugging my Tivo for 5 mins did the trick. Thanks for the help.
     
  20. Dec 4, 2010 #1060 of 1455
    RealityCheck

    RealityCheck New Member

    61
    0
    Feb 15, 2007
    Does PyTivoX mp4 uploading (without transcoding) add DRM to the files? The Apple QuickTime Trailers I uploaded (saved as an .mp4 container vs. .mov) have DRM Notices.
     

Share This Page

spam firewall

Advertisements