pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. HerronScott

    HerronScott Well-Known Member

    7,611
    1,123
    Jan 1, 2002
    Staunton, VA

    Advertisements

    A Roamio Pro with TE3 is really not all that different from an S3 other than being HD (unlike TE4 which is a big change). I was very happy moving from our 2 S3 OLED to 1 Roamio Pro.

    Scott
     
  2. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    54,410
    7,494
    Apr 17, 2000
    Nevada
    There were multiple versions of the Series 2. The first two versions were fine, and the DT was actually pretty good. It was the third incarnation, the 5400 series units, that were hot garbage. But at least they had a functional UI. To this day the Premiere units still have a half finished UI, which is why I stick by my statement that it's the worst TiVo ever made.
     
  3. lesrhorer

    lesrhorer New Member

    29
    3
    Oct 10, 2020
    I will allow I am not all that familiar with the Roamio. The Bolt really sucks, especially since they can no longer be rolled back from TE4. All the HD menus are unacceptable. There is no arguing a used Romio is more expensive. The big difference between the S3 and the Romio - and this is a deal killer for that comparison - is the Romio cannot be hacked by any means of which I know. Of course, neither can the Premiere, but then it is cheaper, and I am not asking the Premiere to do much of anything. The S3s handle that.
     
    Last edited: Oct 24, 2020
  4. lesrhorer

    lesrhorer New Member

    29
    3
    Oct 10, 2020
    I did not find them so. They were a pain to hack.

    I never had one, but I was completely underwhelmed by the specs of its hardware.

    Meh. The S3 retains its functionality, especially the power and flexibility of its search engines.

    As I admitted before, its hard to argue that point. I can pull (most) videos off the Premiere, and it can pull videos off my server. I don't need it to do much more. Oddly enough, rather adding additional support to your point about the Premiere, I found two actual bugs in the Premiere's already pathetic search engines.

    1. The series M*A*S*H cannot be located by the title search engine. Go figure. 'One of the most popular series of all time. The S3, of course, finds it just fine. It can't be found by a title wishlist search on the Premiere, either.
    2. M*A*S*H comes on on both WGN America and on MeTV. Because of the way Season Passes work, if one wishes to record all episodes of M*A*S*H, one must have a Season Pass for both. On the S3, no problem. Simply create two season passes, one for each channel. On the Premiere, setting an additional Season Pass for the same program on a different channel deletes the previous Season Pass. Pathetic.

    The S3 search engines are terrific. The search engines on the S4 (and above, I think) are a crock of $%^%.
     
    Last edited: Oct 24, 2020
  5. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    54,410
    7,494
    Apr 17, 2000
    Nevada

    Advertisements

    Just to be clear TiVoToGo worked on S2 units as well. PyTiVo Desktop works the same on an original S2, without hacking, as it does on a brand new Edge. In fact better because with analog recordings there was no way for the cable company to "protect" certain channels.
     
  6. lesrhorer

    lesrhorer New Member

    29
    3
    Oct 10, 2020
    With the addition of a USB - Ethernet adapter, yes. The DT sported an Ethernet jack.
     
  7. leswar

    leswar leswar

    219
    20
    Apr 14, 2005
    Vero Beach
    Tried to install the latest PyTivo Desktop 1.6.27 on WIndow 7 Ultimate and got this instead "A required privilege is not held by the client" with no error code numbers.
    I have 1.6.23 installed presently.

    What to do?
     
  8. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    54,410
    7,494
    Apr 17, 2000
    Nevada
    Does that happen when installing or when running after the install?

    That error is a Windows error caused by invalid disk privileges. By default the installer should automatically elevate to admin privileges. Is it doing that? Are you allowing it?
     
  9. leswar

    leswar leswar

    219
    20
    Apr 14, 2005
    Vero Beach
    I downloaded from the website..closed PyTivoDesktop and then right clicked on the installer-1.6.27 and chose "run as administrator" and the error message appears. Never had this problem with earlier versions when installing in the past.

    I checked properties on the file and choose security tab/ "Everyone, SYSTEM and Administrators" have "full control", "read and excute", "read", "write".
    All are greyed out but "checked" to allow. "Special permissions" is the only one not checked and I cannot check it (not allowed becaUSE it too is greyed-- empty box).

    What am I doing wrong?
     
  10. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    54,410
    7,494
    Apr 17, 2000
    Nevada
    The installer hasn’t changed, so that’s odd. Instead of right clicking what happens if you just double click?
     
  11. leswar

    leswar leswar

    219
    20
    Apr 14, 2005
    Vero Beach
    Double clicking produces the same result.

    Installing previous versions are no problem. They will install if I want.

    BTW, I wasn't really sure which version I had installed currently. Thought it might be .23.
    But there was no "about pytivo" choice to see under "settings" menu as to which version
    I had installed. That seemed strange (???).

    So I tried to install .24 and it did install with no problems.
    And under "settings" `about Pytivo Desktop'... (now showing) indicated .24 is the current program running.

    Next I did a hard reboot. Shutdown pyTivo Desktop and tried double clicking on .27 installation file.
    But no joy. Same error message. Tired right click installing as admin.; tried r.click. as SYSTEM. Tried r.c.
    on "Install as Revo Uninstall Pro" (my usual choice when installing programs). Same old same old, no joy.

    PyTivo folder appears under C: drive (C:\PyTivo).
    But last night (actually very early this morning) I could have sworn that it was under "C:\Program Files (x86)"
    or maybe "C:\Program Files". I thought maybe that would be a problem with permissions and Windows 7.
    But it was late and I was tired. So may I was confused. It does in fact appear in "C:\PyTivo" folder.

    I also re-downloading the .27 installer from the website in case of a corrupted first download.
    And was using it in the above attempts.
     
  12. leswar

    leswar leswar

    219
    20
    Apr 14, 2005
    Vero Beach
    No advice?
    That's okay because I accidentally hit on a solution. I was downloading a different program unrelated via FireFox and trying to install it.
    Got the same error message ("A required privilege is not held by the client") as when I was trying to install PyTivo Desktop 1.6.27. Huh? What gives.

    But I was able to install an earlier version of the same program that resided on my hard drive. But not the newer version just downloaded via FF.
    The same was true of PyTivo Desktop... an earlier version on HD installed but not the newer version d/l via FF.

    I hit upon the solution using Microsoft Edge to do the downloading. When I used ME both latest programs installed --no error message.
    I tested older programs on my HD. All these older versions will install while anything downloaded using FF will produce the error message and will not install.

    So I surmise this is some type of FF (ver. 85.0.2-64bit) induced problem.
    For now I will be forced to due my d/ling with Microsoft Edge.
     
  13. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    54,410
    7,494
    Apr 17, 2000
    Nevada
    Sorry never saw your previous reply. Glad you figured it out though.
     
  14. mlippert

    mlippert Active Member

    317
    76
    Apr 2, 2010
    Massachusetts
    @leswar That is really odd. I did some googling based on the error message you listed, and found this thread:
    how to fix problem (a required privilege is not held by the client ) in windows 10

    The interesting reply was "ust discovered if I right click on the program and scroll down to select from a Trusted Source I can then install it"

    I'm guessing now that you've got it working you are done w/ testing, but thought you might find this useful (I'm curious if it would fix your issue). My WAG is that somehow Edge is flagging the download as from a trusted source but Firefox doesn't.
     

Share This Page

spam firewall

Advertisements