pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. danspam

    danspam New Member

    1
    0
    Dec 24, 2014

    Advertisements

    I am getting the 'CERTIFICATE_VERIFY_FAILED' error with python 2.7.9 and have just updated pyTivo to the latest but it has not solved it. Still getting the same error unfortunately.
     
  2. wmcbrine

    wmcbrine Well-Known Mumbler

    11,785
    850
    Aug 2, 2003
    It does solve it. You might reexamine your update prodecdure?
     
  3. jcthorne

    jcthorne Well-Known Member

    3,116
    196
    Jan 28, 2002
    Houston
    I was just setting up pytivo on a new laptop this morning and downloaded the latest pytivo. I installed python 279 and the PIL. When trying to push, python gave error messages trying to log into the tivo mind server.

    I removed python 279 and installed 276, restarted pytivo and tried again. All works normally on the new install. There is definitely something going on in 279 and pytivo.

    276 seems to work just fine so no need of a fix for me. I had been using 272 on the old machine for a number of years, never having a need to update.
     
  4. email68

    email68 New Member

    25
    0
    Dec 8, 2014
    I experienced sometime similar and put it Python 2.7.6 to fix it.

    Another thing to try is make sure the IOS app can download a show. That was another issue I ran into. Turns out Tivo support had to activate something and I had to connect to Tivo for an update, then reboot the Roamio.

    After that it's working great.
     
  5. wmcbrine

    wmcbrine Well-Known Mumbler

    11,785
    850
    Aug 2, 2003

    Advertisements

    I can only repeat what I told danspam. There was a problem with 2.7.9. It is now fixed, definitively. If you're still having a problem, then either you aren't running my latest version, or it's a different problem.
     
  6. jcthorne

    jcthorne Well-Known Member

    3,116
    196
    Jan 28, 2002
    Houston
    Mine was a different problem. Not an SSL error but at login to the tivo mind server, when starting a push, immediately after sending the username it returned some sort of string format error. Sorry I did not take a screen pic, already removed 279 and installed 276 and all works fine. If no one else reports the problem then it was just my install for some reason and for now I have no need to update to 279.

    I always install from the 'download zip' button on the git hub. Did so this morning so what ever version was sent then. Don't see a version number at startup.
     
  7. Jan 4, 2015 #5047 of 6046
    innocentfreak

    innocentfreak Well-Known Member

    9,212
    49
    Aug 25, 2001
    Florida
    It has been a while and my google-fu is failing me.

    Was there ever a solution for pushing videos with dual audio tracks so you could either select them on the TiVo or automatically use the English audio?
     
  8. Jan 7, 2015 #5048 of 6046
    jcthorne

    jcthorne Well-Known Member

    3,116
    196
    Jan 28, 2002
    Houston

    Has there been any update on the broken push metadata problem with the mind server? IE any resolution other than pull only?
     
  9. Jan 7, 2015 #5049 of 6046
    DFergATL

    DFergATL New Member

    23
    0
    May 31, 2005
    I just installed and configured pytivo. for the most part, not to bad to setup. I have my music, pictures and two video sections.

    However, whenever I transfer a video, any video no matter how long, It stops transfering and then I can't access anything from pytivo unless I reboot the tivo itself. happens every time, without fail. I don't have to do anything to the server at all, only rebooting the tivo will resolve.

    Windows 8.1 x64

    P.S. I stand corrected. It seems to be only mp4 files.

    P.P.S. I now have gotten the same error when canceling a transfer. I don't know what is wrong but I have had to reboot my tivo 5 times to night and I only installed this 3 hours ago.

    P.P.P.S. Ok, it has now happened 6 times in 3 hours. This time it was just transferring a file. I can't keep rebooting my tivo every 10 to 15min.

    I read in an other thread that this is corrupt file issue. I have tried to transfer 8 files, 6 of them are bad? I am not sure if tivo is really going to work for me. I wanted just one box to do my home theater and if I have to keep my firetv just because tivo won't play files every other setup device will and doesn't support DNLA (it's 2015 for Pete's sake!!) then maybe tivo just isn't worth the money. For the cost of the hardware this type of thing should just work, out of the box.

    INFO:pyTivo.video.video:[07/Jan/2015 21:04:18] Done sending "M:\Videos\Misc\3090
    33324.mp4" to Living Room, 12590080 bytes, 4.61 Mb/s
    ERROR:pyTivo:Exception during request from ('192.168.0.7', 33804)
    Traceback (most recent call last):
    File "C:\Python27\lib\SocketServer.py", line 599, in process_request_thread
    self.finish_request(request, client_address)
    File "C:\Python27\lib\SocketServer.py", line 334, in finish_request
    self.RequestHandlerClass(request, client_address, self)
    File "C:\pyTivo\httpserver.py", line 92, in __init__
    client_address, server)
    File "C:\Python27\lib\SocketServer.py", line 657, in __init__
    self.finish()
    File "C:\Python27\lib\SocketServer.py", line 716, in finish
    self.wfile.close()
    File "C:\Python27\lib\socket.py", line 279, in close
    self.flush()
    File "C:\Python27\lib\socket.py", line 303, in flush
    self._sock.sendall(view[write_offset:write_offset+buffer_size])
    error: [Errno 10054] An existing connection was forcibly closed by the remote ho
    st
     
  10. Jan 7, 2015 #5050 of 6046
    wmcbrine

    wmcbrine Well-Known Mumbler

    11,785
    850
    Aug 2, 2003
    It's certainly possible. I can only say that your experience is not typical.

    Note that "bad" in this context doesn't necessarily mean "corrupt"; it might just be that the video doesn't conform to the rather narrow set of specs accepted by the TiVo.

    I take it you were pushing from the pyTivo web interface. You could try pulling from the TiVo's My Shows list instead, which would force the videos to be transcoded to MPEG2, using known good specs.
     
  11. Jan 7, 2015 #5051 of 6046
    DFergATL

    DFergATL New Member

    23
    0
    May 31, 2005

    Actually I am pulling from Tivo. never did a push from pyTivo. All of this has been done from the tivo itself. any suggestions, any at all??

    Ya I know that "bad" doesn't necessarily mean "corrupt" but, for the price of this hardware it should be able to support more. and should support dnla. just my thoughts.

    I would even be more forgiving but each time this happens I have to reboot the tivo to reconnect to the network again.
     
  12. Jan 8, 2015 #5052 of 6046
    n2lovell

    n2lovell New Member

    21
    0
    May 17, 2014
    Should be in the Feb release.

    The release *after* that one, will start accepting users putting the programId into the description of push content. Where in the *first* piece of square bracketed information will get attempted to be interpreted as a programId (i.e. put "[EP012599310002]" in the description and it will attempt to do the metadata matching). Additionally having a matching programId in a pull will be sufficient to do the metadata matching (not just episodeTitle + title matching).

    This was done so that content from TTCB will more often get their content merged in with the newly announced OnePass feature (and actually make it likely for push).
     
  13. Jan 8, 2015 #5053 of 6046
    jcthorne

    jcthorne Well-Known Member

    3,116
    196
    Jan 28, 2002
    Houston
    Great news. Thanks for the information. Will be great when episodes start grouping together and in episode order.
     
  14. Jan 8, 2015 #5054 of 6046
    wmcbrine

    wmcbrine Well-Known Mumbler

    11,785
    850
    Aug 2, 2003
    In that case, I'd want to see a more complete log.
     
  15. SGLipman

    SGLipman New Member

    1
    0
    Jun 5, 2005
    Anyone have an idea on how to get pytivo (or something similar) for a Mac? My current release of PyTivo (which is from 2010) isn't compatible with the Roamio.

    Please let me know!

    Thanks.
     
  16. lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    pyTivo is not a Windows only program and runs fine on a Mac. You just need to have a compatible version of Python installed. Probably want to have an up to date ffmpeg also.
     
  17. markp99

    markp99 TakoKichi TCF Club

    13,460
    1,448
    Mar 21, 2002
    Nashua, NH
    I can confirm. pyTivo works fine on my Mac, serving files to my Roamio.

    If you have not already, take a look at the following Mac guide:

    http://www.tivocommunity.com/tivo-vb/showthread.php?p=8960628
     
  18. DFergATL

    DFergATL New Member

    23
    0
    May 31, 2005
    @wmcbrine

    I got most of it working now. I was using Wireless and that was a disaster. I got some network over powerline adapters and now I am having a much better time. :) Never used those things before, they are doing better then I would have thought.

    I do have a question. I can get almost all my files to work, there are a few. .wmv files that don't work.

    When I try to transfer these, I can see in the pyTivo windows what appears to be the files being recoded. They are then transferred to the tivo but they don't play.

    I am not sure if there is something I can look for to maybe get these to work. If they don't I will live with it. Just trying to see what I can do.

    I am running on Win 8.1 x64
    16 gig of ram (Yes, I'm a ram junkie)
    I did download the 32bit ffmepeg because I didn't know what other to use an it clearly states on their webiste (Use this if you don't know..) so I did.

    Anyway, if there is anything that can be suggested I would like to know.

    David
     
  19. HerronScott

    HerronScott Well-Known Member

    7,535
    1,102
    Jan 1, 2002
    Staunton, VA
    Where did these wmv files come from? If they are the digital copies that you can download with some BluRay/DVD's, then I don't believe they are going to work as they have DRM-protection.

    Scott
     
  20. wmcbrine

    wmcbrine Well-Known Mumbler

    11,785
    850
    Aug 2, 2003
    Post the log. Also, please elaborate on "they don't play".
     

Share This Page

spam firewall

Advertisements