pyTivo push issue

Discussion in 'TiVo Home Media Features & TiVoToGo' started by ilkevinli, Dec 8, 2011.

  1. Dec 8, 2011 #1 of 15
    ilkevinli

    ilkevinli Member

    109
    0
    Jan 6, 2001
    NYC
    Hi,
    I have pyTivo setup and working with a small issue. WHen I push a show to my tivo and I transfer the show, I end up with 2 copies on my Tivo. Anyone have any I dea why ? Here is a copy of the transfer:

    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: MyMovies
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo.beacon:Living Room
    INFO:pyTivo.beacon:Bedroom
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo:192.168.2.147 [08/Dec/2011 21:03:35] "GET /TiVoConnect?Command=Query
    Container&Container=%2F&DoGenres=1 HTTP/1.0" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:03:35] "GET /TiVoConnect?Command=Query
    Container&Container=%2F&DoGenres=1 HTTP/1.0" 200 -
    INFO:pyTivo.video.video:[08/Dec/2011 21:03:43] Queued "D:\Tivo\My First Place -
    Downtown House Buying (12_06_2011)_cut.mpg" for Push to Living Room
    INFO:pyTivo:127.0.0.1 [08/Dec/2011 21:03:43] "GET /TiVoConnect?Command=Push&Cont
    ainer=MyMovies&File=/My+First+Place+-+Downtown+House+Buying+%2812_06_2011%29_cut
    .mpg&tsn=Living+Room HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:04:53] "GET /TiVoConnect?Command=Query
    Formats&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:04:53] "GET /TiVoConnect?Command=Query
    Container&Container=MyMovies&SortOrder=!CaptureDate&ItemCount=8&Filter=x-tivo-co
    ntainer%2Ftivo-videos,x-tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F*&Se
    rialNum=7460001901F9B8F HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:04:59] "GET /TiVoConnect?Command=Query
    Formats&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:04:59] "GET /TiVoConnect?Command=Query
    Container&Container=MyMovies&SortOrder=!CaptureDate&ItemCount=8&Filter=x-tivo-co
    ntainer%2Ftivo-videos,x-tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F*&Se
    rialNum=7460001901F9B8F HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:05:04] "GET /TiVoConnect?Command=Query
    Formats&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:05:04] "GET /TiVoConnect?Command=Query
    Container&Container=MyMovies&SortOrder=!CaptureDate&ItemCount=1&AnchorItem=%2FMy
    Movies%2FMy%2520First%2520Place%2520-%2520Downtown%2520House%2520Buying%2520%252
    812_06_2011%2529_cut.mpg&AnchorOffset=-1&Filter=x-tivo-container%2Ftivo-videos,x
    -tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F*&SerialNum=7460001901F9B8F
    HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:05:05] "GET /TiVoConnect?Command=TVBus
    Query&Container=MyMovies&File=%2FMy%20First%20Place%20-%20Downtown%20House%20Buy
    ing%20(12_06_2011)_cut.mpg&SerialNum=7460001901F9B8F HTTP/1.1" 200 -
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:05:10] "GET /MyMovies/My%20First%20Pla
    ce%20-%20Downtown%20House%20Buying%20(12_06_2011)_cut.mpg HTTP/1.1" 206 -
    INFO:pyTivo.video.video:[08/Dec/2011 21:05:10] Start sending "D:\Tivo\My First P
    lace - Downtown House Buying (12_06_2011)_cut.mpg" to Living Room
    INFO:pyTivo:192.168.2.137 [08/Dec/2011 21:06:19] "GET /MyMovies/My%20First%20Pla
    ce%20-%20Downtown%20House%20Buying%20(12_06_2011)_cut.mpg?Format=video%2Fmpeg HT
    TP/1.1" 206 -
    INFO:pyTivo.video.video:[08/Dec/2011 21:06:19] Start sending "D:\Tivo\My First P
    lace - Downtown House Buying (12_06_2011)_cut.mpg" to Living Room
    INFO:pyTivo.video.video:[08/Dec/2011 21:16:13] Done sending "D:\Tivo\My First Pl
    ace - Downtown House Buying (12_06_2011)_cut.mpg" to Living Room, 2256160768 byt
    es, 25.96 Mb/s
    INFO:pyTivo.video.video:[08/Dec/2011 21:17:14] Done sending "D:\Tivo\My First Pl
    ace - Downtown House Buying (12_06_2011)_cut.mpg" to Living Room, 2256160768 byt
    es, 26.26 Mb/s
     
  2. ilkevinli

    ilkevinli Member

    109
    0
    Jan 6, 2001
    NYC
    Anyone ??
     
  3. lwpack

    lwpack New Member

    2
    0
    Aug 10, 2008
    Try asking over at the pyTivo forums.
     
  4. Iluvatar

    Iluvatar New Member

    377
    0
    Jul 22, 2006
    Is it still going on? It may be possible that it is an issue with the Tivo mind server that processes the file push requests.
     
  5. wmcbrine

    wmcbrine Well-Known Mumbler

    11,659
    793
    Aug 2, 2003
    I haven't seen double pushes, but the mind server has been flaky for me today. I'm getting a lot of 500 Internal Server Errors.
     
  6. ilkevinli

    ilkevinli Member

    109
    0
    Jan 6, 2001
    NYC
    Yes its still going. I tried asking on their forums but I haven't received any response. The support for pyTivo doesn't seem to be very good. KMTTG support has been awsome though.
     
  7. Iluvatar

    Iluvatar New Member

    377
    0
    Jul 22, 2006
    Well it is an odd issue that hasn't really been brought up before except by one other user who seems to have had the issue around the same time as you. Your logs show that the show is queued once to the mind server but requested twice. pyTivo can't control what Tivo servers do if they get in a weird state, which I have seen them do frequently. It may be something you just have to wait out. The only other advice I have is to make sure you are running the latest pyTivo code and to reboot your Tivo.

    pyTivo is supported mostly by the people who use it, so if no one has seen the issue before it may take awhile before someone jumps in and tries to say what the issue might be.
     
  8. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    I suspect that no one else is seeing the issue, and none of us have any idea what might be causing it. I cetainly am not and do not, so it seemed pointless to comment. One thing that might be very helpful, however, is posting the pyTivo configuration file from the offending system. We certainly can't do much without it.
     
  9. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    I am also having the the problem. I had 7 episodes of Bones. Last night there was 2 episodes of Forgotten. It was starting a third so I canceled it but a minute later it started transferring again. I had go to the computer and delete the program.
    It been doing this for the last month off and on.
    Her is my config

    [My Videos]
    type = video
    path = G:\FOR THE TIVO

    [Server]
    tivo_password = xxxxxxx
    tivo_mak = xxxxxxxxx
    ffmpeg = C:\Program Files\pyTivo\bin\ffmpeg.exe
    tivodecode = C:\Program Files\pyTivo\bin\TIVODECODE.EXE
    tdcat = C:\Program Files\pyTivo\bin\tdcat.exe
    beacon = 192.168.1.112
    togo_path = G:\FROM THE TIVO
    tivo_username =xxxxxxxxxxxxxxx
     
  10. ilkevinli

    ilkevinli Member

    109
    0
    Jan 6, 2001
    NYC
    Thanks for the responses. I appreciate it. Here is my config. (I used the * to block out some info)

    [Server]
    port = 9032
    ffmpeg = C:\pyTivo\bin\ffmpeg.exe
    tivo_password = ********
    tivo_username = *****@gmail.com
    tivo_mak = **********

    [MyMovies]
    type = video
    path = D:\Tivo

    [_tivo_SD]

    [_tivo_HD]
     
  11. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    We might look for some commonality between your two systems. What OS is on the pyTivo server? The workstation used to select the videos to push? What browser is being used? Have either of you tried a vidmgr push? If so does it do the same thing? You might try turning on debug. Some network sniffing may be required.
     
  12. ilkevinli

    ilkevinli Member

    109
    0
    Jan 6, 2001
    NYC
    Thanks.
    I have pyTivo installed on a Windows 7 Ultimate x64 computer and the same computer is used to set the push. Im using IE 9 (latest version). I have not tried vidmgr. Can you tell me where to find it ? Thanks.



     
  13. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    Mine is a windows7 pro on the same computer. I am using ie8 for the browser. No I have not tried Vidmgr but will If does a auto push.
     
  14. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
  15. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    Well, Windows 7 is a common element. It could be something in W7, although I would guess the odds are low. On e never knows...

    If you mean, "Does it automatically perform unattended pushes", then no. It's UI based.
     

Share This Page