PyTiVo files transfer ok, but have low volume

Discussion in 'TiVo Home Media Features & TiVoToGo' started by rambler, Jan 30, 2014.

  1. rambler

    rambler Member

    488
    1
    Dec 3, 2005
    The files sound fine on my PC, but after transferred to the Tivo Series 2, I have to have the TV volume cranked almost to max to hear. Files generally being movies from BT sites. Any ideas? Thanks.
     
  2. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,609
    5,889
    Apr 17, 2000
    Nevada
    Do the source files have Dolby 5.1 audio? If so that's likely the problem. IIRC all S2 units support DD audio, but only the DVD units have the optical port to pass it through to a receiver. The rest all decode it internally. I'm not sure what the pyTiVo default is when transferring to a S2. Does it pass through DD audio as-is or recode it? If it recodes it then you may try applying some compression by adding a ffmpeg_pram for -drc_scale and see if that helps. Although if it's passing the audio through that will never even get invoked so you'd have to mess with the profiles to ensure that DD audio is always recoded when sent to your S2.
     
    sdnative1 likes this.
  3. rambler

    rambler Member

    488
    1
    Dec 3, 2005
    They are not 5.1

    What I've done now is to increase the audio in the file using a program called "Format Factory". It works without affecting the video as far as I can tell.
     
    sdnative1 likes this.
  4. cherry ghost

    cherry ghost Well-Known Member

    6,325
    330
    Sep 13, 2005
    Chicago
    you could try ffmpeg

    Code:
    ffmpeg -i input -c:v copy -af volume=5.0 output
    -af volume=5.0 increases volume by 5dB
     
  5. rambler

    rambler Member

    488
    1
    Dec 3, 2005
    I put that in the pytivo.conf file?
     
  6. cherry ghost

    cherry ghost Well-Known Member

    6,325
    330
    Sep 13, 2005
    Chicago
    It would be done separately, before using pyTiVo.

    I'm not 100% sure how to incorporate it into pyTiVo. Try adding the "-af volume=x" to ffmpeg_pram in SD TiVo Settings.


    ETA: That won't work. Something needs to be added to ffmpeg_tmpl, but I can't figure it out.
     
  7. sdnative1

    sdnative1 New Member

    25
    0
    Mar 7, 2009
    I'm using PyTivo (and K-lite Codec) for the first time on my Bolt. Same issue with low volume transfers.
     
  8. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,609
    5,889
    Apr 17, 2000
    Nevada
    There is actually a filter included with the TiVo DirectShow filter called like "volume booster" or something that's inserted into the graph automatically when you play a .tivo file. So there is a known issue with low audio on TiVo transfers.
     

Share This Page