pyTivo auto pushes

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Oct 18, 2009.

  1. Sep 1, 2011 #201 of 216
    johnjay829

    johnjay829 New Member

    41
    0
    Jan 2, 2007

    Advertisements

    Do you have the pytivo conf file mapped correctly in the autopush.jar
     
  2. Sep 1, 2011 #202 of 216
    jcncamsdad

    jcncamsdad New Member

    5
    0
    May 1, 2009
    Probably not. The .jar file sees the shares, but I did not touch the pytivo.conf file.
     
  3. Sep 1, 2011 #203 of 216
    caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...

    Restart your Tvos. Usually that what I have to do
     
  4. Sep 1, 2011 #204 of 216
    jcncamsdad

    jcncamsdad New Member

    5
    0
    May 1, 2009
    Nope, that didn't work.
     
  5. dcrowell77

    dcrowell77 Member

    66
    1
    Dec 27, 2007

    Advertisements

    I noticed that I haven't gotten any new trailers in awhile so I tried adjusting the feedURL like below and things seem to be chugging along again.

    #feedURL = "http://www.hd-trailers.net/blog/feed/"
    feedURL = "http://feeds.hd-trailers.net/hd-trailers"

    Anyone know what changed?
     
  6. Chuppa

    Chuppa New Member

    1
    0
    Jan 7, 2012
    Australia
    Hi Guys,

    How can I 'easily' get auto-push to run at login on a Mac in the background?

    I keep running into issues with the command "auto_push -b &"
     
  7. Feb 1, 2012 #207 of 216
    alton987

    alton987 New Member

    7
    0
    Aug 28, 2011
    Could someone help me understand how to do this? Ialso want autopush on 2 tivos
     
  8. innocentfreak

    innocentfreak Well-Known Member

    9,231
    54
    Aug 25, 2001
    Florida
    Is there anyway with autopush to monitor a specific folder in the shares? I don't want the whole share monitored but just a few specific folders.
     
  9. ebf

    ebf New Member

    542
    0
    Mar 21, 2005
    Make a new share for sub-folder and hide it from all the TiVos to avoid on-TV confusion.
     
  10. Bobot

    Bobot New Member

    13
    0
    Jun 17, 2004
    South...
    For the last week or so, autopush via pyTivo has been pushing every podcast to my Tivo twice. The autopush log shows it checking each video, and then shows it pushing each video multiple times. It is not respecting the auto_push.txt file.

    I have rebooted the Tivo several times, rebooted the machine running the autopush service, checked the parameters, deleted the auto_push.txt file, etc all in attempts to fix this.

    What else do I need to investigate to stop this behavior? Is there a better method I should be using to monitor a folder of videos and push them automatically to the Tivo?
     
  11. Shelbrain

    Shelbrain New Member

    9
    0
    Aug 15, 2004
    Hudson, Florida
    PyTivo is working properly and I am trying to set up the auto push function. I have downloaded the autopush program and it is placed in C:\Program Files\autopush. I open the program, find my pytivo.conf file, choose my shares and when I go to save the autopush conf file, I get this:

    Problem writing to config file: C:\Program Files\autopush\config.ini
    java.io.FileNotFoundException: C:\Program Files\autopush\config.ini (Access is denied)

    Any ideas? Thanks in advance!
    Does any one think I could edit the .conf program directly and avoid the GUI?
    Could someone post their sample autopush conf file for me to examine?
     
  12. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    'Sounds like you are running Windows, in particular Windows 7.

    Yeah. Don't run Windows, especially not Windows 7. Alternately, you could put pyTivo, or at least its config file, somewhere besides Program Files.

    Yes, running as Admin, I think, may work. Certainly there is no requirement that the web utility do the work.
     
  13. Aero 1

    Aero 1 Active Member

    584
    27
    Aug 8, 2007
    installed autopush v01.d, browsed the pytivo.conf file, it saw my shares, but it wont autopush. getting the following error:

    help! any ideas? thanks.

    standalone pytivo push works fine, kmttg pytivo push works also, just not auto push.

    p.s. this is under windows 7 x64.
     
  14. RJV

    RJV New Member

    9
    4
    Sep 4, 2003
    I'm having the same symptoms, in the same environment and circumstances, as Aero 1 in the previous post. Any ideas?

    edit: I fibbed...I am not using kmttg.
     
  15. Nov 4, 2014 #215 of 216
    plpmke

    plpmke New Member

    5
    0
    Nov 27, 2010
    Milwaukee, WI
    Sorry if this sounds like a noob question, but how do I get auto_push to run as a background job on OS X at login? I can get auto_push to run perfectly fine as graphical job at boot via adding it to my Login Items, and a couple of years ago I was able to get it to run as a background job when I was doing some testing (didn’t suit my purposes at the time so I disabled it). For the life of me, I cannot get it to run as a background job for me on my new media server, no matter what I do! I’m pretty sure I used the “-b &” command from Terminal previously (as stated on the Code wiki)...Thinking about it, I may have created an Application via Automator to run the Terminal commands via a shell script. Does it seem like I am on the right track here? Any specifics or suggestions? Thanks.
     
  16. mystic1muse

    mystic1muse New Member

    23
    1
    Jun 13, 2015
    Is Pytivo Auto Push still functional? I set everything up and it appears to be working from the display I see "Watching" and the file that I just put in the directory where transfers should occur; then it says "pushing" that file; and the right address of my Tivo where it is suppose to be pushing to. BUT

    ... no transfers are made to the Tivo.

    No error messages.
     

Share This Page

spam firewall

Advertisements