pyHME icons on S4

Discussion in 'Developers Corner' started by jeepguy_1980, Feb 19, 2012.

  1. jeepguy_1980

    jeepguy_1980 Unregistered User

    250
    0
    Mar 1, 2008
    Newport...

    Advertisements

    I have a server running pyhme, an original S3, and an S4 Elite. The S4 does not show icons for any of the pyhme apps. Is this a known bug?
     
  2. wmcbrine

    wmcbrine Well-Known Mumbler

    11,734
    827
    Aug 2, 2003
    I just noticed myself that the icon for Reversi doesn't show in the HDUI with 20.2. (It does in the SDUI.) I fixed this once already, back when the HDUI was new -- in that case, it was some limitation on the type of PNGs the HDUI would accept. (No greyscale? 24-bit color only? I forget exactly, but it was something on those lines.) I don't yet know what the problem is this time.

    Edit: This was the old issue:

    Code:
    commit bddff194e5c0a25783c66a298fc9bc3cf8192ffc
    Author: William McBrine <wmcbrine@gmail.com>
    Date:   Mon Apr 5 17:14:12 2010 -0400
    
        The new HD UI on the TiVo Premiere requires icons to be RGB, not indexed
        or greyscale.
    
     
  3. wmcbrine

    wmcbrine Well-Known Mumbler

    11,734
    827
    Aug 2, 2003
    So, in fact, the HDUI in 20.2 never requests the icons at all. Also, it doesn't acknowledge the unregistering of the apps. Meanwhile, everything works as it should from the SDUI. This is quite strange to me -- you'd think that would all be common back-end code, but no. (I say "strange", and it is, but it's not entirely a surprise -- it's not the first time I've run into that kind of thing in the HDUI, where there's different behavior in what should logically be part of a common back end.)
     
  4. jeepguy_1980

    jeepguy_1980 Unregistered User

    250
    0
    Mar 1, 2008
    Newport...
    I'm not sure if the HDUI requests the icons for the pre-packaged apps or not, but they have icons.
     
  5. wmcbrine

    wmcbrine Well-Known Mumbler

    11,734
    827
    Aug 2, 2003

    Advertisements

    Yes, I'm aware.

    Those apps are specified to the TiVo in a different way, not accessible to us.
     
  6. wmcbrine

    wmcbrine Well-Known Mumbler

    11,734
    827
    Aug 2, 2003
    Icons are back in the HDUI with the latest HME for Python (in git), but only for "Add an App". Then again, the HDUI has progressed from not requesting the icons for Zeroconf-announced apps in 20.2, to not recognizing the app announcements at all in 20.2.1 and 20.2.2.
     

Share This Page

spam firewall

Advertisements