Problem after drive swap

Discussion in 'TiVo Upgrade Center' started by DougF, Jan 3, 2006.

  1. DougF

    DougF Well-Known Member

    15,223
    1,816
    Mar 18, 2003
    North Dakota

    Advertisements

    I have a Series 1 DTiVo. I replaced the original 40 GB with an 80 GB and then later added another 40 GB. The 80GB drive went bad and I used dd to copy it to a spare 160GB I had. Because I had already upgraded, it only used 80GB of the 160GB drive. At this point I had a 160GB A drive (of which only 80GB was being used) and a 40 GB B drive.

    So, last week I started over. I put the two drives in a PC and got an image (SPs, Wishlists, no recordings). I copied that to a 40GB drive and then added the 160GB drive back. Now I have a 40GB A drive and a 160GB B drive. Since then, I'm having a strange problem. Some of my recordings are mixes of two or more programs. A recording will be fine when I check it one day and will be corrupt at a later date.

    For example, last night's recording of Arrested Development was the Sci Fi Inside: Battlestar Galactica for the first 15 minutes or so. I recorded both, but they came on at different times. Also, I recorded A Goofy Movie for my daughter this weekend. She was watching it for the first 45 minutes or so while it recorded and there were no problems. When we went to play it back yesterday, it was mixed with segments from The Twilight Zone. Some Christmas programs I recorded last weekend were fine when I checked them mid-week. By the weekend, a message stating that there was no video signal or something appeared when I tried to play them.

    Any ideas?
     
  2. oilhat

    oilhat New Member

    6
    0
    Feb 12, 2002
    According to the Hinsdale guide, you can't replace your A drive with something smaller than the original. You started with an 80Gb, made an image, and then wrote it to a 40Gbit, if I understand you correctly. Maybe this is what happens. I have an image from a 30Gbit Series 1 DSR6000 DirecTivo if that would help. oilhat@operamail.com
     
  3. JamieP

    JamieP Member

    991
    0
    Aug 2, 2004
    This is typical of an lba48 problem. If you used an lba48 CD when you added the 160GB drive, but did not put an lba48 tivo kernel on your tivo, the tivo "wraps around" when it tries to address beyond 137GB on the B drive. This will cause the kind of problem you are seeing.
     
  4. kap0w

    kap0w New Member

    68
    0
    Jan 27, 2005
    Seattle, WA
    It seems to me that if you had a 160 gig drive and you didn't do anything about lba48, it would just see it as a 137 gig drive (like mine) - you shouldn't have problems there. As hard as this might be, I'd have the TiVo wipe all the recordings and see if it's still doing it. If that doesn't do it, I'd pull the drives and maybe just go with the single 160. It's more simple and it means you have a lot less complicated setup. A 40 is really pretty useless.
     
  5. DougF

    DougF Well-Known Member

    15,223
    1,816
    Mar 18, 2003
    North Dakota

    Advertisements

    I betcha this is the problem. The unit is reporting that it has around 200 hours capacity and it should only be reporting about 165 or 170. I did use the lba48 CD.

    Is there anything I can do about it without starting over and losing my recordings?
     
  6. kap0w

    kap0w New Member

    68
    0
    Jan 27, 2005
    Seattle, WA
    I think you're right - it is some sort of LBA48 problem, but I've never made that jump so I can't offer more. Since your disks aren't full, there may be some way to copy everything off onto another drive and then back onto just the large drive, but tht would both require another large drive, a ton of time, and assume that it would fix things.
     
  7. JamieP

    JamieP Member

    991
    0
    Aug 2, 2004
    You can install an S1 LBA48 kernel. I think the ptvupgrade lba48 cd may have them, or see this.

    Given that you've run for a while with the "wrap around" problem, I'd be concerned that your file system is badly damaged. It's possible this will haunt you downstream even if you correct the kernel now. It might be safest to start over. If you have some things you want to watch first, you could try installing an lba48 kernel and see how it goes. If nothing else bad happens after a week or two, you might be ok.
     
  8. BobCamp1

    BobCamp1 Well-Known Member

    2,039
    359
    May 15, 2002
    I've done this before. The Tivo OS and its recordings are most likely gone. Your Tivo will probably hang and not even boot in a couple of days.

    You will save a lot of time if you just start over. You'll have to use your backup image, and either have to use an LBA48 cd and upgrade the kernel, or just use the original non-lba48 cd which will limit you to 137GB on the 160GB hard drive.
     
  9. JamieP

    JamieP Member

    991
    0
    Aug 2, 2004
    The one saving grace here may be that it is only the B drive that has the "wrap around" problem. The A drive is ok. This may mean that the corruption will primarily be in the media files themselves, and not in the software partitions and file system metadata. If the recordings are precious, I wouldn't hesitate to attempt to recover rather than starting over, but I wouldn't be surprised if it failed either.
     

Share This Page

spam firewall

Advertisements