Premier wireless N issue

Discussion in 'TiVo Help Center' started by dsc25, Nov 13, 2011.

  1. dsc25

    dsc25 Member

    40
    0
    Nov 14, 2002
    Philadelphia...
    I've had a long saga with Premier and the Wireless N adapter. I would love any assistance.

    We got our first Premier about a year and a half ago. It was set up with the Wireless N adapter and worked perfectly . . . for four months. Then, all of a sudden, it wouldn't connect to the internet reliably - that dreaded yellow exclamation point off and on. Then, it just wouldn't connect at all. After returning the box to TiVo twice and working with the service reps for dozens of hours, I just reconfigured my router so that it was in the room with the TiVo and used a non-wireless connection to the box. Premier has worked great for a year that way.

    Mind you, every other device in the house works perfectly on the wireless network, including my old Series 2 using the TiVo Wireless G adapter, my main desktop computer, and my laptop (as well as other wireless devices).

    Last month we wanted to replace the Series 2 with a Premier. I hooked the new box up no problem using a new Wireless N adapter. The initial download of software and program data worked flawlessly. The first week or so was pretty good with the wireless connection as well.

    But now, for the past two weeks, the wireless connection is pretty much useless. I have the yellow exclamation point almost all the time. I've tried rebooting. I've tried reconnecting the adapter. I've jiggled the cord (which actually was a solution with the original Premier when connected directly to the router). Nothing has worked. Of course, all other wireless in the house is still working just fine.

    Any thoughts this time? I know if I call TiVo I'm going to spend countless hours doing everything I did a year ago with my original Premier and they're ultimately going to have no clue how to fix it. So, I thought I'd try people here.

    Thanks!
     

Share This Page