Premier 500GB Dead - Troubleshooting HD and power supply pointers?

Discussion in 'TiVo Help Center' started by chromicant, Jan 28, 2020.

  1. chromicant

    chromicant New Member

    5
    0
    Jan 28, 2020
    I have a Premier (TDD746500) that, after a power outage, has decided that it wants to be stuck on the "Welcome..." TiVo screen. From my troubleshooting (pulled all the cords/CableCARD out, swapped HDMI cables, used another power outlet - the TiVo "recommended" testing), I am down to either the HD being dead, or the power supply being shot (I am assuming and hoping the motherboard is good...I don't want to lose my lifetime TiVo subscription!).

    My question is - is there an easy way to determine which of the two components are bad. I have some basic electrical test equipment to test the PS with, and I have a small array of USB SATA adapters and Linux-based machines lying about.

    Testing the HD seems simple enough (probably start by S.M.A.R.T. testing and go from there). Drive also doesn't seem to have the telltale click-click of Death when the TiVo is trying to boot.

    The PS is a bit tricky - any known voltages or test points? A quick visual inspection doesn't show any bulging caps.

    Anyone have a good starting point for more in-depth troubleshooting? If it does need a new HD - any good ones to look for?
     
  2. shwru980r

    shwru980r Well-Known Member

    2,983
    295
    Jun 22, 2008
    Pull the hard drive, hook it up to a PC and use CrystalDiskImage software to check the health of the drive. The original hard drive is 8-10 years old and has probably failed.
     
  3. chromicant

    chromicant New Member

    5
    0
    Jan 28, 2020
    So quick update on what I've tried so far.

    Pulled the hard drive and got it into my Frankentower (my mess of a Linux desktop PC). Was able to run "mfsbackup -6so tivo-bkp.img /dev/sdc" with no visible errors, and pulled about 4 gigs off the drive. smartctl didn't show any immediate errors.

    Tried putting the drive back, and still no boot. Checked the voltages on the power supply, and did get +12 and +5.1. Lastly, took a spare PC power supply and used that to power the HD in the TiVo...and still no boot.

    Is it common for the hard drive to work in a PC and not in the TiVo? Have a bit of a headscratcher with this one.
     
  4. BizzyMarks

    BizzyMarks New Member

    19
    0
    May 21, 2006
    My 500GB also got stuck in the boot process just last week. Except mine was stuck on Clearing Guide Data which I initiated. I cloned the drive thinking it was a drive problem, but the cloned drive did the same thing which tells me it a software issue. I got a clean image and used that to replace the cloned image and it booted up just fine. Clean image means I had to set it up like a completely new device.

    But, I'm still having Guide Data issues.

    Good luck.
     
  5. chromicant

    chromicant New Member

    5
    0
    Jan 28, 2020
    A follow-up.

    It was the drive. A new WD Red 1TB and some time to reimage the new drive and everything is good again.

    Thanks for the help!
     

Share This Page