potential workaround to make the stream 4k at least usable again after the latest trash update

Discussion in 'TiVo Stream 4K' started by crackers8199, Mar 23, 2021.

  1. crackers8199

    crackers8199 New Member

    14
    2
    Dec 8, 2020

    Advertisements

    so, i can confirm (for me anyway) that it is the youtube app that has made the stream 4k basically unusable after tivo forced this latest trash update on all of us and then went radio silent. every time i reboot, i end up with the youtube app freezing the second you try to play anything and video in every other app (no joke, literally every other app does this) is so choppy that everything is unwatchable. the device is basically a brick at that point.

    here's what i've come up with so far to at least make the device usable (unfortunately though you have to do this on every reboot...or at least i have, i haven't found a way to make it stick over a reboot yet):
    • go to android settings > apps > youtube > force stop, then uninstall updates
    • go to google play store, click your profile icon at the top of the screen, and update the youtube app
    at this point, the youtube app should now work again and video in other apps will be smooth again.

    i have absolutely no idea why or how this is happening, but this has worked for me. i can't speak for it fixing the youtube tv issues, but if anyone is willing to test it out go right ahead.

    also, if anyone could figure out a way to make this stick across a reboot or figure out what the hell tivo did to bork this update so badly, that would be much appreciated...i tried just disabling the youtube app, that didn't work. even after reboot the problem persists until i re-enable and then do the uninstall updates / update dance with the youtube app.
     
  2. Foogie

    Foogie New Member

    10
    1
    Mar 23, 2021
    Seems like you are the only one with choppy video and freezing, from what I can gather some people are having issues with live streams on youtube displaying colored bars which has happened to me a couple of times but also has occurred on a different device of mine aswell, but is fixed by reloading the channel stream once or twice. All my apps and system apps are up to date, I updated to firmware 5256 manually and have a mini flash drive attached. Choppy video can be caused by lack of power supply or a bad connection. Your issue seems to be partly on your end rather than all Tivo. Like at the beginning I had Wifi issues that Tivo acknowledged but it also helped when I raised my router higher.
     
  3. crackers8199

    crackers8199 New Member

    14
    2
    Dec 8, 2020
    no, there are multiple people on reddit who have reported the same thing.

    also no, not having these issues with any other devices (including the new chromecast nor fire stick 4k or second gen).

    also no. the stream 4k worked perfectly until the last update...so unless you're telling me this update fried my power brick (also unlikely since the procedure i described above fixes the issue until a reboot), that's not it either.

    what exactly do you gain from refusing to admit that tivo might have screwed up with this update? there are TONS of people both here and on reddit reporting all sorts of issues, including this one. i'm far from the only one. in fact, another redditor has already confirmed that my procedure fixed youtube for him as well...

    but sure, i'm the only one and it's my network causing the issues. FFS.
     
  4. rczrider

    rczrider Active Member

    185
    95
    May 15, 2020
    Using stock YouTube sucks, anyway. Disable it and install Smart YouTube TV.
     
    Amiga likes this.
  5. crackers8199

    crackers8199 New Member

    14
    2
    Dec 8, 2020

    Advertisements

    like i said, disabling doesn't solve the problem. the choppy video is still there after a reboot.

    literally the only way i've found to fix it is the procedure i've described above.
     
  6. rczrider

    rczrider Active Member

    185
    95
    May 15, 2020
    I must have been confused. You're claiming the YouTube app is causing all other apps to be "choppy"?
     
  7. crackers8199

    crackers8199 New Member

    14
    2
    Dec 8, 2020
    yes, that seems to be the case. every time i see the choppy video issue in *any* app (which seems to be every time i reboot), the youtube app also hangs when trying to play any video and performing these steps fixes it. every time. and these are the only steps i've found that have definitively fixed it every single time.

    i've tried literally everything else i can think of, and this is quite literally the *only* thing that has worked to resolve this for me aside from a complete factory reset, which obviously takes far too long to accomplish given the frequency i've had to keep doing this with (once a week or so since this horrible update was forced on us).

    i get it, that seems counterintuitive, and as a long time android user and computer developer by day i have no clue how they managed to screw this up this badly and make it happen this way...but it's absolutely the case on my device.
     
  8. driverseven

    driverseven Tivo Bolt

    62
    9
    Oct 11, 2007
    Westchester, NY
    I have no idea if this is related to the update but it just happened and I've never seen it before. On Prime Video last night, I selected "One Night in Miami" and when the movie started, the screen went blank but the audio continued. Leave the movie and the Prime Video menus work and other movies work with no issue. I tried to get it to play 3x and no change. Left TivoStream and went to Tivo Bolt, the Prime Video app played the movie with no issue.
     
  9. BNY

    BNY New Member

    1
    0
    Saturday
    I've been having the youtube issue for the past 2 weeks now.
    My workaround is uninstall youtube updates, then update in google store and then restart device.
    I can get youtube to work this way but it often gets screwed up again by the next day.

    When youtube goes haywire, this affects other apps sometimes, although most seem to work better after a simple restart or manually force stopping most apps running.

    I also experience the streaking lines on youtube but that only happens if i try to watch a live stream.
    sometimes it works, but most times i get the streaking lines after 2-3 seconds of viewing. (this issue has been going on for months)

    Edit:
    I just went ahead and went on a app disabling spree after i had another youtube freeze issue. Youtube now seems to be working just fine!!!
    I disabled almost anything that could be disabled (even text to speech, dictionary, gallery, contacts and more). And changes stuck after a reboot. lets see if this sticks for the long haul.
     
    Last edited: Apr 10, 2021 at 2:38 AM

Share This Page

spam firewall

Advertisements