Owned my Premiere for almost 3 weeks

Discussion in 'TiVo Premiere DVRs' started by JTyler82, Jan 13, 2012.

  1. JTyler82

    JTyler82 New Member

    Dec 27, 2011
    and I've noticed that The audio is off. I'm hooked up to Comcast, and I have it hooked up to Comcast Broadband internet, and I noticed that the Audio is always a little off. Depending on what channel I'm on. Premium channels aren't that bad, but Normal channels are Worse.

    Is there a way to Fix this? I've tried all the audio settings. The help section on the Tivo site, and I've rebooted a dozen times (While waiting for the 20.2 update). and Nothings helped.

    I'm really Loving TiVo but I cannot deal with watching TV where the audio is always out of sync.
  2. cherry ghost

    cherry ghost Well-Known Member

    Sep 13, 2005
    you might want to check the audio settings on your TV/receiver
  3. rabinny

    rabinny New Member

    Feb 11, 2011
    Jersey Shore
    Do you have your audio going through a receiver? Some receivers have a/v delay time settings.
  4. JTyler82

    JTyler82 New Member

    Dec 27, 2011
    I have my Audio going through a 10 year old Shelf Stereo, with Red-White on the back...
  5. compnurd

    compnurd Well-Known Member

    Oct 6, 2011
    Have you tried directly connected to your tv?
  6. Dr_Diablo

    Dr_Diablo Dr_Diablo

    Nov 23, 2003
    same happens to me as well, the problems on the cable provider..

    After bitchin ti BH they were able to resolve this annoying issue
  7. myklup

    myklup New Member

    Apr 7, 2009
    I'm assuming you have the audio going right out of the tivo into the 10 year old receiver, and you're using hdmi to you tv? Try running the audio to the receiver FROM the tv instead.

    New (HDMI switching) receivers automatically take care of this issue as well
  8. scandia101

    scandia101 Just the facts ma'am

    Oct 20, 2007
    MN, greater...
    That's how I have mine set up. Makes things much simpler not having to change the input on the receiver when I change the input on the tv to use another device.

Share This Page