OTA, old UI, doesn’t play Amz Prime

Discussion in 'TiVo Roamio DVRs' started by MtnTech, May 5, 2019.

  1. May 5, 2019 #1 of 13
    MtnTech

    MtnTech New Member

    8
    1
    May 5, 2019

    Advertisements

    i haven’t updated the UI of my 4yo Roamio OTA, if that matters here. I keep finding cases where it won’t play a given Amazon Prime Free video, but the same title plays on my Apple TV.

    Unrelated but also a PITA is that 100% of the time I leave the Netflix app, the unit hangs on a black screen for a very long time. Sometimes button mashing seems to speed its recovery. No other player app does this. Doesn’t even matter if I played anything, or just loaded and exited Netflix.
     
  2. May 5, 2019 #2 of 13
    dlfl

    dlfl Cranky old novice

    9,017
    775
    Jul 6, 2006
    Dayton OH
    You already have a good solution to your complaints: The Apple TV. I stopped using the clunky Amazon and Netflix apps on my Roamio long ago and now use a Fire TV, although it is a nuisance to have to switch inputs.
     
    MtnTech likes this.
  3. May 5, 2019 #3 of 13
    MtnTech

    MtnTech New Member

    8
    1
    May 5, 2019
    I hear you, though it is because of my TV’s clunky input-switching mechanism that I would rather stay on one device as much as possible.

    And it is because of AppleTV’s poorly implemented Siri/touch remote (touch sensitivity makes scrolling absolutely suck, and its inability to stay connected to my device is infuriating) that I would rather not use the AppleTV, either.

    The peanut is the best thing going.
     
  4. May 5, 2019 #4 of 13
    moyekj

    moyekj Well-Known Member

    12,236
    896
    Jan 23, 2006
    Mission...
    I still use my Roamio Pro for both Netflix and Amazon. For Amazon I use it for both Prime video and HBO channel subscription and I have not encountered any problems playing any title for both Netflix and Amazon. The Amazon UI is pretty slow compared to Netflix, but overall very happy watching both via my Roamio Pro.
     
    HerronScott and MtnTech like this.
  5. May 5, 2019 #5 of 13
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,304
    1,068
    Apr 6, 2000
    SF Bay Area

    Advertisements

    Yes, lately Netflix is taking longer to exit. Apparently, this latest version is doing that.
     
    MtnTech likes this.
  6. May 5, 2019 #6 of 13
    Adam C.

    Adam C. Active Member

    390
    220
    Jul 24, 2017
    I have never had any problems with Netflix, Amazon, or Hulu on my Roamio OTA. With the latest Hydra update, Netflix is running better than ever and the app opens instantly. I occasionally have problems with the Amazon app when running it on a Mini though.
     
    MtnTech likes this.
  7. May 5, 2019 #7 of 13
    MtnTech

    MtnTech New Member

    8
    1
    May 5, 2019
    Well, maybe it’s time to finally update. I had not thus far because I saw so many negative comments for so long.


    Sent from my iPhone using Tapatalk
     
  8. May 5, 2019 #8 of 13
    Adam C.

    Adam C. Active Member

    390
    220
    Jul 24, 2017
    I had the same concerns. But I upgraded to Hydra about a month ago and have not had any issues. The auto commercial skip feature pretty much sealed the deal for me.
     
    MtnTech likes this.
  9. May 5, 2019 #9 of 13
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,304
    1,068
    Apr 6, 2000
    SF Bay Area
    The issue is not with TE3 or TE4, the latest Netflix app exits slow.

    Its not on opening the Netflix app, its closing it.
     
  10. Adam C.

    Adam C. Active Member

    390
    220
    Jul 24, 2017
    I have no trouble with Netflix closing on my Roamio OTA running Hydra.
     
    moyekj and MtnTech like this.
  11. OrangeCrush

    OrangeCrush Active Member

    306
    226
    Feb 18, 2016
    I did the update to the new experience a couple weeks ago and the apps are running noticeably smoother. I got so frustrated with the apps on the old UI I had given up on them, but they do seem usable now.
     
    MtnTech likes this.
  12. MtnTech

    MtnTech New Member

    8
    1
    May 5, 2019
    Well, I did it. I’ve only watched a little of anything since, but so far so good.


    Sent from my iPhone using Tapatalk
     
  13. Adam C.

    Adam C. Active Member

    390
    220
    Jul 24, 2017
    Yup. With the latest TE4 update the Netflix app opens instantly, so I assume it just stays loaded into memory rather than the system having to open and close it every time it gets used.
     
    MtnTech likes this.

Share This Page

spam firewall

Advertisements