Noob: Transferring recordings and upgrading HDD

Discussion in 'TiVo Roamio DVRs' started by peggypwr1, Apr 2, 2020.

  1. Apr 2, 2020 #1 of 74
    peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    Hello all, I have a Tivo Roamio and the HDD is getting full.

    1. I would like to transfer the HD recordings to my desktop and convert to MKV so I can playback on my standalone KDLinks media player. What is the easiest way to do this?

    2. Can TIvo recordings be changed into MKV?

    3. I want to upgrade the HDD to a 6tb or 8tb. I was reading that Western Digital makes special PVR hard drives specifically for recording video? Any recommendations you folks can link to?

    4. 5400 rpm or 7200?

    5. If I get a new HDD. Can I transfer the old shows from my old HDD to the new one so i can still access them in my Tivo?

    Thank you all.
     
  2. Apr 2, 2020 #2 of 74
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,687
    920
    Apr 6, 2000
    SF Bay Area
    You may be better to convert to MPEG4. Tivo recordings are either MPEG2 or TS.
    MPEG4 is a compressed video file and it can take a long time to process. If you have a lot of files, it can seem like forever to finish.
    WD Red (Not pro, 7200+ RPM). If you want to start anew, follow the steps in MSFR thread.(work time: about 30 minutes. Otherwise, use MFSTools 3.2 thread. There is a limit of 4TB with MFSTools, but it can be surpassed in the 10TB Roamio thread. This process can take many hours.
    As long as you stay on v20.7.x. Avoid v21.x as PC->Tivo transfers has been disabled.
    You would use PyTivo as the transfer server. KMTTG can be the download program, as well as for processing (large batches are possible).
     
  3. Apr 3, 2020 #3 of 74
    Mikeguy

    Mikeguy Well-Known Member

    27,636
    9,192
    Jul 28, 2005
    pyTivo Desktop is easy to install, and to use to transfer shows TiVo box <-> PC. It also will decrypt (convert) the shows you transfer from your TiVo box to your PC, should you want it to do so.

    pyTivo Desktop

    discussion thread here: Easier to use pyTivo
     
  4. Apr 3, 2020 #4 of 74
    peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    Thank you for the replies. I installed pyTIVO.

    Here's the problem, and I should've mentioned in my original description, I apologize for not doing so.

    I have two TIVOs:
    One is the OTA Tivo and the other is the digital cable HD Tivo Romaio.

    PyTIVO is only "seeing" the OTA TIVO. I want it to recognize the Digital TIVO. How do I get the software to do that. THe media key I entered is from my digital cable TIVO so I'm curious to why the software is not picking that DVR up?

    The digital cable TIvo is connected to wi-fi and TIVO connection is functioning.

    and what do mean by
    "As long as you stay on v20.7.x." what is that referring to?
     
  5. Apr 3, 2020 #5 of 74
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,687
    920
    Apr 6, 2000
    SF Bay Area
    All Tivo devices must be on your tivo.com account, so they will have the same Media Access Key and permissions, so, confirm in your tivo.com account that your device's Service numbers are listed correctly, and under DVR Preferences, they are enabled for sharing/transfers. The Media Access Key should be the same in your account, all your Tivo devices under Media Access Key in the Settings menu.
    All Tivos technically are digital, you may be referring to digital cable, since almost all cable service is digital and not analog anymore.
    Its the Tivo software its running, listed under System Information.
     
  6. Apr 3, 2020 #6 of 74
    peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    tivo.png

    Ok so I went in and both my DVRs are listed. And I selected share. I restarted the software and it still doesn't see my "Man Cave" DVR (Digital Cable TV), thats the one I want. It only sees the master bedroom :-(
     
  7. Apr 3, 2020 #7 of 74
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,687
    920
    Apr 6, 2000
    SF Bay Area
    You don't need to restart anything. You just need both your devices to make a Tivo Service Connection. Its how they learn of your changes. You may need to restart the box if you don't see the charges. If you restart, do another Tivo service connection, this will enable the networking again or you have to wait awhile.
     
  8. Apr 3, 2020 #8 of 74
    peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    Ok, Ill try that tomorrow.

    Another noob question, I went ahead and download a show form the OTA DVR. It downloaded successfully. Its a .tivo format. I used VLC media player, but, the image is all pixelated? Do I need special software ?
     
  9. Apr 3, 2020 #9 of 74
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,687
    920
    Apr 6, 2000
    SF Bay Area
    This is a file that is encrypted by the Tivo. To decrypt, KMTTG has that function which uses a program called TivoDecode. PyTivo Desktop may have it also.
     
  10. peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    Wow so frustrating.
    Ok, so I, re-connected to the TIVO server.

    I have no anti-virus or firewall.
    Again, the software only recognizes the master bedroom DVR, but not the Man Cave one?

    There must be a way...do I need to manually input the ip address of the ManCave DVR?

    Thank you all for your patience.
     
  11. Mikeguy

    Mikeguy Well-Known Member

    27,636
    9,192
    Jul 28, 2005
    Indeedy, it does. :)
     
  12. Mikeguy

    Mikeguy Well-Known Member

    27,636
    9,192
    Jul 28, 2005
    A frustrating thing with pyTivo Desktop is that it sometimes stubbornly refuses to see a TiVo box on the network. I sometimes find it helpful to restart pyTivo (under the icon at the top right of the pyTivo Desktop main page), sometimes a few times. There have been some other settings suggestions in the pyTivo Desktop thread here (see above), and Dan (the dev) and others often answers inquiries there.
     
  13. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,687
    920
    Apr 6, 2000
    SF Bay Area
    Did you perform the Tivo Service connection on BOTH Tivos? You did not if note that the Media Access Key on your account is the same on both Tivos.
     
  14. kpeters59

    kpeters59 Well-Known Member

    2,863
    582
    Jun 19, 2007
    Houston, Texas
    When I use to bother putting files back on my TiVo (as opposed to just playing them with an alternate device - Kodi), I found that unplugging the TiVo's Network Cable and plugging it back in would allow the System (Bonjour?) to work as desired for a while.

    YMMV.

    -KP
     
    Mikeguy likes this.
  15. peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    I did the Tivo Service COnnection only on the digital cable "Man Cave" DVR - this is the one I want.
    The OTA TIVO is always recognized .

    I then restarted the Man Cave digital cable DVR, and it still will NOT be recognized?

    It only picks up the OTA DVR Ip address?

    ANy other suggestions.

    ANd yes I logged in to my TIVO account...the media access key is the same for both DVRs
     
  16. kpeters59

    kpeters59 Well-Known Member

    2,863
    582
    Jun 19, 2007
    Houston, Texas
    Reboot your router and any ethernet switches involved.

    -KP
     
  17. peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    Ok, Ill try that later tonight when everyone is sleeping.

    Both the DVRs are connected via WiFI , no Ethernet cable.
     
  18. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,687
    920
    Apr 6, 2000
    SF Bay Area
    Restart the computer?
     
  19. peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    Yes, I restarted the computer.

    Is there anyway I can manually enter the IP address of the "MAN Cave" DVR into that software?
     
  20. peggypwr1

    peggypwr1 Member

    36
    0
    Aug 21, 2015
    UPDATE:

    Ok, I power cyled my router and restarted the desktop.

    Sill no connection! It will only connect to OTA DVR.

    I tried to add "Man Cave" DVR manually in KTTMG and it says:

    >> Getting Now Playing List via RPC from Man Cave ...

    RemoteInit - (IP=192.168.1.3, port=1413): Connection timed out: connect

    [java.net.DualStackPlainSocketImpl.connect0(Native Method), java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source), java.net.AbstractPlainSocketImpl.doConnect(Unknown Source), java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source), java.net.AbstractPlainSocketImpl.connect(Unknown Source), java.net.PlainSocketImpl.connect(Unknown Source), java.net.SocksSocketImpl.connect(Unknown Source), java.net.Socket.connect(Unknown Source), sun.security.ssl.SSLSocketImpl.connect(Unknown Source), sun.security.ssl.SSLSocketImpl.<init>(Unknown Source), sun.security.ssl.SSLSocketFactoryImpl.createSocket(Unknown Source), com.tivo.kmttg.rpc.TiVoRPC.RemoteInit(TiVoRPC.java:265), com.tivo.kmttg.rpc.TiVoRPC.<init>(TiVoRPC.java:106), com.tivo.kmttg.rpc.Remote.<init>(Remote.java:57), com.tivo.kmttg.rpc.Remote.<init>(Remote.java:69), com.tivo.kmttg.main.config.initRemote(config.java:635), com.tivo.kmttg.task.remote$1AutoThread.run(remote.java:77), java.lang.Thread.run(Unknown Source)]

    RemoteInit - (IP=192.168.1.3, port=1413): Connection timed out: connect

    [java.net.DualStackPlainSocketImpl.connect0(Native Method), java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source), java.net.AbstractPlainSocketImpl.doConnect(Unknown Source), java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source), java.net.AbstractPlainSocketImpl.connect(Unknown Source), java.net.PlainSocketImpl.connect(Unknown Source), java.net.SocksSocketImpl.connect(Unknown Source), java.net.Socket.connect(Unknown Source), sun.security.ssl.SSLSocketImpl.connect(Unknown Source), sun.security.ssl.SSLSocketImpl.<init>(Unknown Source), sun.security.ssl.SSLSocketFactoryImpl.createSocket(Unknown Source), com.tivo.kmttg.rpc.TiVoRPC.RemoteInit(TiVoRPC.java:265), com.tivo.kmttg.rpc.TiVoRPC.<init>(TiVoRPC.java:106), com.tivo.kmttg.rpc.Remote.<init>(Remote.java:57), com.tivo.kmttg.rpc.Remote.<init>(Remote.java:69), com.tivo.kmttg.main.config.initRemote(config.java:635), com.tivo.kmttg.task.NowPlaying$1AutoThread.run(NowPlaying.java:90), java.lang.Thread.run(Unknown Source)]

    WHy is it timing out?? THe service is connecting, the wifi is strong??

    ANy other suggestions??
     

Share This Page