NO TCP/IP over wired connection

Discussion in 'TiVo Help Center' started by lenzar, Sep 30, 2007.

  1. lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    I have a series 2 Tivo, that I have over an wired network. It goes to a hub, then to my computer. Both Tivo Desktop and the DVR do not recognize it is connected to a network. It may be my adapter which i just changed to match what Tivo said would work with my system. On my "network Connections" it has listed a "1394 Connection". Then it has no status. When I click on Repair it says "TCP/IP is not enabled for this connection Cannot Proceed". I tried disabling and enabling it again but still the same thing.
    Any suggestions?
     
  2. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    The 1394 connection is a Firewire card/port in your desktop.

    There should be an entry on your desktop under Network Connections for "Local Area Connection." That's the one you want.

    How are you connected to the internet? You mentioned a hub connecting the TiVo and PC, but not how you get out to the internet from there (I'm assuming you have broadband).
     
  3. lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    Exactly, I can see the connection and it says it is working properly, but no IP addresses or anything for that matter. I am connected, not through a hub, but through a router. I then connect to the internet via a broadband connection.
     
  4. Oct 2, 2007 #4 of 27
    lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    I went ahead and installed a new network adapter based on the Tivo recommendation, but no luck. I really think it is either the computer or router. It worked fine in my old house over a wireless router.
     
  5. Oct 2, 2007 #5 of 27
    windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Ok, so your PC and TiVo are connected, wired, to a router, which then goes out to the internet.

    What are the IP addresses of your PC and TiVo? Exactly which adapter are you using with the TiVo?
     
  6. Oct 6, 2007 #6 of 27
    lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    OK, so as an idiot, can you tell me where to find this information and why that would help. Shouldn't i be worried about security and putting my IP addresses on the internet?
     
  7. Oct 6, 2007 #7 of 27
    windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    The IP addresses you are using should be private (non-routable) addresses. Since you're behing a router, those addresses are "protected."

    The addresses of your PC and TiVo should be something like 192.168.x.x. I'm just trying to confirm that both of your devices are on the network and the same subnet. Once you know the address of your TiVo (Network Information screen) you can try and ping it from your PC.
     
  8. Oct 6, 2007 #8 of 27
    lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    OK, that is understandable for me.

    So, when I open my network connections screen. I see two connections. One says 1394 connection. The other says Local area connection.

    Under the LAN connection it says:
    Address Type: Assigned by DHCP
    IP Address: 67.xxx.xx.xx
    it also has a subnet mask and default gateway.

    Under the 1394 Connection it says:
    Nothing.
    When I am in the General tab it says status: connected
    but when I click on the support tab: it has not information for address type, IP address, subnet mask or default gateway.
    when I click on the repair button it says: Windows could not finish repairing the problem because the following action cannot be completed: TCP/IP is not enabled for this connection. Cannot proceed.

    Is there something I'm missing?
     
  9. Oct 6, 2007 #9 of 27
    windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Ok, first of all, edit your post and remove that IP address (or make it 67.xxx.xxx.xxx). That's your actual IP address on the internet. What that tells me is that you're NOT using a router. It sounds like your cable/DSL modem is directly connected to your PC.

    Ignore that 1394 connection. Again, that's a Firewire card in your PC and is not used for networking (don't ask me why they show it under Network Connections).

    So I need some more information on your actual setup. Again, from what you're describing, it sounds like you've got a cable or DSL modem directly connected to your PC (otherwise your IP address would be something like 192.168.1.x). What kind of box is it? Is it really a router with a wireless access point in it?
     
  10. lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    Windracer, see, thats what I was afraid of. Thats why i asked the question. I can tell you that indeed, i am going through a router. I have a new home with a centralized distribution system and connects directly to the router. The router is then connected to the modem. So, in each of my room, I have a network connection drop that funnels to a central distribution closet. In that closed the wires go into the router. My router then connects to my modem.
    Does that make sense.
    I guess I'm confused about the 1394 connection. Where can I go to read more about it?
     
  11. lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    The router is a Linksys, 10/100 8 port workgroup switch.
     
  12. RoyK

    RoyK New Member

    2,935
    1
    Oct 22, 2004
    SW VA
    Google it.

    You can think of 1394 (AKA FireWire) as a very fast USB kind of thing. Its used to connect some devices like certain Camcorders etc to a PC where fast data transfer is needed.
     
  13. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Switch doesn't necessary equal router. Most consumer routers you buy today (like the wireless ones) include a 4-port switch. What you're describing as an 8-port workgroup switch sounds like just a switch ... not a router.

    A router does NAT (network address translation). That is what allows you to have a single external, public IP address from your broadband provider shared with multiple PCs on the other side of the router (with private IP addresses like the 192.168.x.x I have been describing).

    So, it sounds like maybe you have the switch connected to your modem. If that's the case, my guess would be that the first device to be turned on would get your public IP address and work on the network. None of the other devices would work (unless your modem allows multiple public IP addresses and is doing DHCP).

    You still haven't said what the IP address is of the TiVo (assuming it's getting one at all).
     
  14. lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    OK, you'll have to excuse my ignorance. I am not a computer guy. I know just enough to be dangerous. And as ludicris as it sounds, I did not realize there was a difference between a switch and a router.
    As for the Tivo, its not getting an IP address at all. Every time i try to connect the Tivo to the service, it says no DHCP service available.

    So, how is it that the computer is supposed to work then. Is it supposed to be plugged directly into the switch and then the computer connects to the modem? I don't think I can do that with my configuration.
     
  15. ForrestB

    ForrestB New Member

    824
    0
    Apr 8, 2004
    It sounds like you have a switch - but you need a cable/dsl router. Unless you cable/dsl modem has a router (some do) then I suggest installing a router in between the cable/dsl modem and the switch. After you install the router, you'll need to setup the router by typing it's IP address (ie. 192.168.1.1). It's a one time setup that takes a few minutes and then you should be all set.
     
  16. Puppy76

    Puppy76 Well-Known Member

    1,433
    44
    Oct 6, 2004
    I'd recommend Linksys for the router-get something that says it has a firewall, as that'll help protect your whole network.

    You'll connect the router to your model (you can remove the switch, or still use it in some other location to get more network ports if you need them, but the ROUTER has to be the first thing connected to your modem).

    As mentioned, you'll need to configure your router once it's hooked up. If this is a DSL modem, you'll probably need to set your router to log into the DSL service (your router will be doing this INSTEAD of your computer). If this is cable, you don't need to do that, but you may have issues because you may have registered your computer's MAC address with your cable company, and may need to reregister the modem instead. You'll have to check the instructions you got from them.

    Also of course make sure your router's firewall is one, and change the default admin password. By default Linksys seems to ship their routers with the firewall enabled, which is a good thing.

    Once all that's done you don't need to do anything special. The router gives out an IP address to your computer and Tivo, and then they should be able to see each other with Tivo Desktop.
     
  17. lenzar

    lenzar New Member

    13
    0
    Oct 1, 2005
    I noticed tonight my Tive had an IP address of 71.xx.xx.xx.
    Does that mean anything?
     
  18. bleakman

    bleakman New Member

    4
    0
    Jul 30, 2007
    lenzar
    you need to solicit some hands on network help.
    Get someone over there that has some idea about what is what and where things are.

    I do in home support and you are the sort of person that would call me in such a state of frustration that is just unnecessary.

    This is a simple network setup but if you don't know how to ask the question (hub/switch/router???) - you won't get the answer you need.

    (not being mean; trying to be helpful)
     
  19. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Well, if your PC IP still starts with 67 and your TiVo IP starts with 71, that would explain why the two can't "see" each other (TiVo Desktop doesn't work across subnets like that).

    I'm still not clear on exactly how everything is wired together in your setup, especially with the pre-wired jacks in the house and the switch. So I agree with bleakman that you might need someone who knows a little about networking to actually come on-site and help you out.
     
  20. Puppy76

    Puppy76 Well-Known Member

    1,433
    44
    Oct 6, 2004
    Did you actually set up a router as per earlier posts?

    I'd agree-it sounds like you're getting confused by this and probably need someone to come help you in person.
     

Share This Page