No OLED Display - am I missing something?

Discussion in 'TiVo Help Center' started by briangraf, Aug 23, 2007.

  1. briangraf

    briangraf New Member

    7
    0
    Aug 23, 2007
    I just bought a "factory renewed" series 3 from tivo in their web specials section. I have completed guided setup, connected to the service successfully, and loaded program data - but no matter what I do, I cannot figure out how to get the OLED display (clock or recording in progress) to show up. The front panel has recording leds and when I press a button on the remote, an amber activity led lights up - but no orange OLED.

    Before someone says that they mistakenly sent me a TivoHD instead of a Series 3 - I am 100% sure that the hardware is correct. I even have the TiVo glo remote (although the select button is DOA, but that is another story for another thread) that I wouldn't have if it weren't a TivoHD - also when it starts up I get the THX screen.

    I've been through every screen I can find trying to see any setting that would control this display but have had no luck. Am I missing something, or did my friends at TiVo simply ship out someone else's lemon without actually "renewing" anything?
     
  2. dianebrat

    dianebrat wait.. I did what? TCF Club

    12,553
    1,752
    Jul 6, 2002
    boston'ish
    The flat cable that goes to the OLED is known to dislodge in shipping on occasion, a few valiant souls opened their units up (with the power off) and reconnected it and it was fine, but more had no luck.

    If you want to see if it's really working, on a restart it will light up with Tivoguy and say "Ready, Set, Tivo"

    If you're not seeing those in the boot process, the OLED is hinky, and you may need an exchange on the unit.

    Diane
     
  3. briangraf

    briangraf New Member

    7
    0
    Aug 23, 2007
    Thanks Diane for the response. I was afraid of that. If it were just the display, I may have taken a chance at cracking open the box. I still have the star screwdrivers I bought to add a bigger HD to my series 2 back in the day :)

    Since my remote is worthless as well - i will probably just return the entire package and have them send me a replacement.

    Thanks again,

    Brian
     
  4. briangraf

    briangraf New Member

    7
    0
    Aug 23, 2007
    Just to follow up - I called TiVo Support and sure enough - the box needs to be replaced. Overall it was a very painless experience - much better than I expected. Crossing my fingers that all goes well this time around.
     

Share This Page