No https on my hdtivo

Discussion in 'TiVo Series3 HDTV DVRs' started by km, Mar 6, 2020.

  1. Mar 6, 2020 #1 of 11
    km

    km Member

    92
    0
    Dec 1, 2001
    Atlanta....
    My series 3 HDTivo doesn't have the https port open. I need it to be able to download a recording.
    I do have telnet access in, so I may be able to diagnose the problem if someone knows how https normally starts. i haven't done downloads in a long time, but it used to work.

    My other services are working, including a few of the usual extras

    PORT STATE SERVICE
    21/tcp open ftp
    23/tcp open telnet
    80/tcp open http
    2190/tcp open tivoconnect
    2191/tcp open tvbus
    8080/tcp open http-proxy
     
  2. Mar 6, 2020 #2 of 11
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,684
    917
    Apr 6, 2000
    SF Bay Area
    How are you trying to download shows?

    There are programs available to use, the best is KMTTG, then PyTivo.
    You would need to make sure transfers and sharing is enabled under DVR Preferences on your tivo.com account.
     
  3. Mar 6, 2020 #3 of 11
    km

    km Member

    92
    0
    Dec 1, 2001
    Atlanta....
    I have run kmttg successfully before, but when I run it now it fails since it tries to make a https (port 443) connection to the tivo and there is no https service running on the tivo, just the ports I listed above. I'm trying to get to the bottom of what happened to 443.
    Oh, and I did check the DVR preferences on the account.
     
  4. Mar 6, 2020 #4 of 11
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,684
    917
    Apr 6, 2000
    SF Bay Area
    If it has rebooted recently, you would need to make a Tivo Service connection and then KMTTG would work.

    You can also use your browser

    https:// (your Tivo IP) /nowplaying/index.html
     
  5. Mar 8, 2020 #5 of 11
    km

    km Member

    92
    0
    Dec 1, 2001
    Atlanta....
    I'm running 11.0n.H1-xx not letting it update to K1 when it attempts to on nightly reboots. I'm guessing thats why https is not available. I have some mods in H1 that I've been too lazy to update for K1, which is why I'm doing this. Except for downloads which I haven't done in years my H1 state works fine.

    Also, from another posting I've read that kmttg Downloads are useless on the Series 3 for mpeg4 recordings, without another newer generation Tivo for conversion, which I don't have. My provider is all mpeg4. If thats the case, there really is no point in me updating to K1 so that downloads will work anyway. The last time I used kmttg was years ago, before mpeg4.
     
    Last edited: Mar 8, 2020
  6. Mar 8, 2020 #6 of 11
    HerronScott

    HerronScott Well-Known Member

    7,389
    1,060
    Jan 1, 2002
    Staunton, VA
    That would have been good information to provide. :) (Not running the current version and also a modified version as well).

    You are right that while they updated the HD code to support MPEG4 recordings they did not provide a means to download them in TS mode. Are you using Comcast?

    Scott
     
  7. Mar 8, 2020 #7 of 11
    km

    km Member

    92
    0
    Dec 1, 2001
    Atlanta....
    Yes, I'm on Comcast. It turns out this is not very important. My main DVR has become mythtv, and I use the Tivo as a backup. The video files are directly available on myth, I just happened to delete one that I wanted a screenshot from and thought I could get it from a Tivo download. Completely a one off.

    I go back to the Series 2 days, and keep the Tivo mostly out of sentiment. The reality is I should retire the series 3, and stop paying both Tivo and Comcast the fees to keep it going.
     
  8. Mar 8, 2020 #8 of 11
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,684
    917
    Apr 6, 2000
    SF Bay Area
    I do not know why you would not allow the update to n.K1 as, I believe, it adds the capability of recording MPEG4/h.264, but it still does not allow transfers of MPEG4.
     
  9. Mar 8, 2020 #9 of 11
    km

    km Member

    92
    0
    Dec 1, 2001
    Atlanta....
    its already doing that on 11.0n.H1. To allow K1 I have to do some patching so that I don't lose telnet/ftp/tivowebplus, and the patching is error prone. I don't see any gain for the trouble/risk.
     
  10. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,684
    917
    Apr 6, 2000
    SF Bay Area
    There is only 1 telnet and that is for network remote control.
     
  11. km

    km Member

    92
    0
    Dec 1, 2001
    Atlanta....
    Not the way I use it. Its a Linux box and I have an added set of Linux utilities on it, that I would have to reload if I let it update.
     

Share This Page