New Release: jpegwriter

Discussion in 'TiVo Underground' started by The Jake, Jan 11, 2002.

  1. kelsky

    kelsky New Member

    1
    0
    Feb 2, 2005

    Advertisements

    I can't seem to get jpegwriter working on my series 2 unit that is running 6.2.


    bash-2.02# tivosh ./jpegwriter
    extra characters after close-brace
    while compiling
    "{ ..."
    while compiling
    "[–| ..."
    (file "./jpegwriter" line 19)
    bash-2.02#

    Any suggestions are appreciated.

    Oh, I have tried ver 1.1, 1.2 & 1.3 and they all give me the same message. I have three Hughes DVR40's and they all react the same.
     
  2. john1980

    john1980 New Member

    179
    0
    Jun 17, 2004
    New Zealand
    You are going to have some pretty serious problems getting it going. Firstly it is a binary and not a TCL script, so it can not be run via tivosh (which is a TCL interpreter). Secondly the binary has been compiled for a PowerPC processor (Series 1 TiVo) and will not run on a MIPS processor (Series 2 TiVo). If you wish to get the application working on a series 2 unit you will need to install gcc and compile it from the source code... however I would not bother as it is very unlikely to work as all the ioctl's (commands) will be different - if they even exist at all.

    Short answer is that it (and many other modules/utilities) will not work on series 2 units.
     
  3. PyroMan

    PyroMan New Member

    13
    0
    Jun 5, 2002
    OK, I am now able to make my first real contribution to TiVo hackers. I have discovered that the problem with the first character being cut off is due to the use of the "string trim[left or right]" commands. The correct method is to use "file tail" and "file rootname".

    In other words change this line
    Code:
    puts $chan [html_link [string trimleft [string trimright "$pic" ".jpg"]  "/var/hack/pics/"] [string trimleft "$pic" "/var/hack/pics/"] ]
    to
    Code:
    puts $chan [html_link [file tail [file rootname "$pic"]] [file tail "$pic"] ]
    I hope this helps.
     
  4. acacia

    acacia OccasionalTivoHacker

    36
    0
    Aug 23, 2003
    London
    Great! Thank you!
     
  5. jar-head

    jar-head New Member

    18
    0
    Mar 28, 2006

    Advertisements

    I have been trying to get jpegwriter to work on my Series 2 DirecTivo until I read this. Are there any alternatives that will alow me to display an image of any kind on my tivo?
     
  6. lloydjs

    lloydjs New Member

    99
    0
    Jul 15, 2003
    Sterling, CT
    I have a series 1 w/ TivoWeb v1.9.4

    jpegwriter works fine from bash prompt by issuing the command:
    jpegwriter <jpeg_filename.jpg>

    However, it doesn't work with TivoWeb (Jpeg Viewer module) nor will it work with slideshow.tcl (http://www.cobb.uk.net/Tivo/Slideshow/)

    Both attempts flash the image very briefly and then the screen goes white.
    I tried various versions of jpegwriter - 1.1, 1.2, 1.3 - and all produce the same results - only work from bash prompt.

    I am thinking the jpeg module and the slideshow require something else that the standalone excecutable does not, maybe some libosd files.
    The readme for jpegwriter states that libosd is required but I didn't put them on the Tivo. I thought I would try it with just jpegwriter and it worked fine from the bash prompt. Do you think this could be my problem? If so, where would the libosd files go? The readme files don't provide much instruction as far as how to install and where to put the files.

    Thanks to all the helpful people in the forum community, I no longer consider myself a newbie, but far from an expert.

    Thank you!

    PS: My TivoWeb has a bunch of grey boxes at the top that look like they might be buttons but don't do anything and have no text. Is this normal? Maybe I have a bad TivoWeb install.
     

Share This Page

spam firewall

Advertisements