New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Apr 29, 2020 #12641 of 12831
    snerd

    snerd Well-Known Member

    1,458
    499
    Jun 6, 2008

    Advertisements

    I have an iPhone but I haven't updated the TiVo app because it sounds like the latest rev is broken. I've never learned how to poke around the innerds, but I've done that on a Nexus 7 tablet and I'm willing to try it on the iPhone if someone can give me some hints as to what tools I need.

    Also have an iPad that I could update to the latest TiVo app.
     
  2. Apr 29, 2020 #12642 of 12831
    moyekj

    moyekj Well-Known Member

    12,176
    827
    Jan 23, 2006
    Mission...
    Per information I was told what worked in the past was Jailbreaking the iOS device using jailbreaks like electra or unc0ver which then allow retrieving and decrypting the .ipa file. However those methods apparently only work properly for older iOS versions 11.x or earlier. My contact had to use different jailbreak method (checkra1n) for newer iOS releases, but then was not able to decrypt the .ipa file properly. So would seem it's easier for old versions of iOS.
     
  3. Apr 29, 2020 #12643 of 12831
    snerd

    snerd Well-Known Member

    1,458
    499
    Jun 6, 2008
    My iPad is quite old, it says it is iOS 9.3.5 and that it is up to date.
     
  4. Apr 29, 2020 #12644 of 12831
    moyekj

    moyekj Well-Known Member

    12,176
    827
    Jan 23, 2006
    Mission...
    Sounds perfect! I wonder if it will even run the latest TiVo iOS app though? If so then that would be very encouraging.
     
  5. Apr 29, 2020 #12645 of 12831
    snerd

    snerd Well-Known Member

    1,458
    499
    Jun 6, 2008

    Advertisements

    Sadly, I get a network error when trying to use the old TiVo app that was installed years ago (I rarely use the iPad). The new TiVo app won't install because it requires iOS 12.

    My iPhone is iOS 13, so it sounds like I'm not going to be much help.
     
  6. May 1, 2020 #12646 of 12831
    RedMan8

    RedMan8 Member

    218
    1
    Sep 30, 2005
    New problem... I think it must be my Java settings somehow but it only happens after KMTTG has been running for a while. I can't click on any menu items or right-click on any shows, otherwise I get the errors in this photo:
    <guess I can't share a google photo's photo?>
    [​IMG]
     
  7. May 1, 2020 #12647 of 12831
    RedMan8

    RedMan8 Member

    218
    1
    Sep 30, 2005
    JavaError-KMTTG.png

    Like it can't create the pop-up window when right-clicking or clicking a menu item?

    I can't figure out how to get it to happen "on purpose" - but after a few hours of running it just magically starts erroring.
    The only fix I've found is to exit the program and re-launch, but of course I need to finish reviewing commercial cuts etc before that.

    It still loops and cuts commercials, etc... so I have no way to know if it's "broken" until I try to click on something.

    WEIRD!!
     
  8. May 1, 2020 #12648 of 12831
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,094
    1,014
    Apr 6, 2000
    SF Bay Area
    I have noticed one issue with KMTTG, the Remote/info tab is not working anymore. Even if i updated to the latest (2.4o).
     
  9. May 2, 2020 #12649 of 12831
    minimeh

    minimeh Vanity Phrase Here

    346
    75
    Jun 20, 2011
    San Francisco
    Might be an isolated problem as a quick check here on two machines was okay.

    Do you see any clues in the message window? Maybe try rebooting your Tivo? Maybe try running kmttg with the debug flag to see if clues appear in the log?
     
  10. May 2, 2020 #12650 of 12831
    RedMan8

    RedMan8 Member

    218
    1
    Sep 30, 2005
    The debug log is a great idea!
    Yea - I've not only reboot the TiVo and computer - but I swapped out the TiVo hard drive with a brand new one. Still happens. I've used KMTTG for several years (love it)!
     
  11. May 2, 2020 #12651 of 12831
    RedMan8

    RedMan8 Member

    218
    1
    Sep 30, 2005
    Interesting... the only debug output I can find is "Save Messages To File". That would be fine except when I'm having the issue I can't click any menu items or right-click the window (both of those things just error and don't open the menu).

    Is there another option that just logs everything?
     
  12. May 2, 2020 #12652 of 12831
    kpeters59

    kpeters59 Well-Known Member

    2,926
    603
    Jun 19, 2007
    Houston, Texas
    Is there any chance this is related to the Hardware Acceleration issue posted a few issues back?

    That fix solved my issue that has similarities to what you're describing.

    -KP
     
  13. May 2, 2020 #12653 of 12831
    RedMan8

    RedMan8 Member

    218
    1
    Sep 30, 2005
    interesting... video driver display stuff - yea, maybe!

    OK - I made a bat file with the java switch options and it's running that way right now. I'll report back!
     
  14. May 2, 2020 #12654 of 12831
    slowbiscuit

    slowbiscuit FUBAR

    4,545
    559
    Sep 19, 2006
    In the ATL
    I wish the debug log had timestamps, the Logger class does this easily. Helps a lot to troubleshoot intermittent issues.
     
  15. May 2, 2020 #12655 of 12831
    moyekj

    moyekj Well-Known Member

    12,176
    827
    Jan 23, 2006
    Mission...
    BUMP. Still no responses.
     
  16. May 2, 2020 #12656 of 12831
    minimeh

    minimeh Vanity Phrase Here

    346
    75
    Jun 20, 2011
    San Francisco
    Apologies for the ambiguity, my response was intended for @ThAbtO's problem.
     
  17. May 2, 2020 #12657 of 12831
    scottb

    scottb Member

    75
    4
    Dec 31, 2002
  18. May 3, 2020 #12658 of 12831
    RedMan8

    RedMan8 Member

    218
    1
    Sep 30, 2005
    YES!
    And for the record - it's still happening, even with the undocumented java switch I've tried.
    I'm glad I'm not the only one but it's so hard to debug. Google searches have found nothing!

    ETA: I'm downgrading my Java to version 8u202 (removing version 8-251).
     
    Last edited: May 3, 2020
  19. May 3, 2020 #12659 of 12831
    scottb

    scottb Member

    75
    4
    Dec 31, 2002
    I will be very interested in hearing the outcome of your downgrading Java, and the result it has in resolving this issue.
     
  20. May 3, 2020 #12660 of 12831
    RedMan8

    RedMan8 Member

    218
    1
    Sep 30, 2005
    Confirmed - I have NOT had any issues since I downgraded Java to 8u202. This is the longest KMTTG has been running without erroring on menu clicks.
     

Share This Page

spam firewall

Advertisements