New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Dec 8, 2019 #12501 of 12585
    BH9244

    BH9244 Member

    158
    1
    Feb 10, 2009
    Starting this morning when I attempt to use the "Search" function to review upcoming episodes it errors out with the following message, any guidance appreciated.

    >> RUNNING 'REMOTE Keyword Search' JOB FOR TiVo: DVR B5E6
    RPC error response:
    {
    "code": "internalError",
    "debug": "com.tivo.trio.dbaccess.DbAccessError: Default SqlException handling. + errorCode = 1146 SQL: /* offerSearch,partnerId=tivo:p
     
  2. Dec 9, 2019 #12502 of 12585
    miceland

    miceland New Member

    4
    0
    Apr 27, 2011
    Unable to decode anything now that I am using VideoRedo v6.

    ...
    ---DONE--- job=javadownload output=SHOW.TiVo
    VideoRedo video dimensions filter is enabled
    container=mpeg, video=mpeg2video, x=1280, y=720
    >> Running qsfix on SHOW.TiVo ...
    C:\WINDOWS\system32\cscript.exe //nologo C:\kmttg\VRDscripts\qsfix.vbs "SHOW" "SHOW.mpg.qsfix" /l:AppData\Local\Temp\VRDLock757193480919712896.tmp /m /c:mpeg /v:mpeg2video /x:1280 /y:720
    qsfix failed (exit code: 0 ) - check command: C:\WINDOWS\system32\cscript.exe //nologo C:\kmttg\VRDscripts\qsfix.vbs "SHOW.TiVo" "SHOW.mpg.qsfix" /l:...AppData\Local\Temp\VRDLock757193480919712896.tmp /m /c:mpeg /v:mpeg2video /x:1280 /y:720
    C:\kmttg\VRDscripts\qsfix.vbs(152, 5) (null): The server threw an exception.
    ...
    Killing 'qsfix' job: C:\WINDOWS\system32\cscript.exe //nologo C:\kmttg\VRDscripts\qsfix.vbs "SHOW.TiVo" "SHOW.mpg.qsfix" /l:...\AppData\Local\Temp\VRDLock757193480919712896.tmp /m /c:mpeg /v:mpeg2video /x:1280 /y:720
    You are running up to date version: v2.4o

    Also just installed and paid for VideoRedo v6

    Any progress here or help downgrading to 5 since I never purchased 5, only 6
    VideoReDo TV Suite 6.60.4.086 to be precise.


    Thanks,
    -mice
     
  3. Dec 10, 2019 #12503 of 12585
    moyekj

    moyekj Well-Known Member

    11,911
    663
    Jan 23, 2006
    Mission...
    Looks like you don't have TiVo Desktop installed. You need to have it properly installed (at minimum partially installed) and have VRD be able to play .TiVo files for qsfix to work.
     
    mlippert likes this.
  4. Dec 10, 2019 #12504 of 12585
    SamuriHL

    SamuriHL Member

    40
    10
    Jan 23, 2012
    Actually I think we have a bigger issue. I just ran some tests, as well. My laptop is on the slow ring builds for 20h1 Windows 10. And it gives the same COM errors. However, my HTPC is on the 1909 (or whatever the build number is) 19h2 fall build, and it works perfectly fine with the same version of VRD. Now I'm only one user here, but, so far that's my experience. I think we can thank MS for this but I don't know if the VRD guys are going to be willing to look into this until spring when it officially releases (SIGH). We'll see what they say as I've reported my findings on the VRD forum, as well. Hopefully others who are on the 20h1 builds can confirm this finding.
     
  5. Dec 11, 2019 #12505 of 12585
    moyekj

    moyekj Well-Known Member

    11,911
    663
    Jan 23, 2006
    Mission...
    Note that with every major Windows 10 update you need to re-install TIVo Desktop, so it may simply be that.
     
    Mikeguy and kpeters59 like this.
  6. Dec 11, 2019 #12506 of 12585
    SamuriHL

    SamuriHL Member

    40
    10
    Jan 23, 2012
    Not in my case as I have a script that I use to register the dshow dll and set the mak in the registry. I can open the files just fine in vrd. I ran a qfix manually and it was fine. The vbs script throws an error as does my powershell script. However the other user with this issue is saying they're on 1903 so if that's the case I've no idea what changed. I installed the latest build of windows on 12/6 which is when the scripts stopped working for me. They work on my other machine.
     
  7. Dec 11, 2019 #12507 of 12585
    SamuriHL

    SamuriHL Member

    40
    10
    Jan 23, 2012
    Ok, I don't know what happened with my laptop but it's working again. The weird thing is I could edit the TiVo files with VRD6 so tivo support (mak and dshow dll) were at least partially registered. But for whatever reason qsfix didn't like it. So I re-ran my script to set the MAK (tivomak.exe) and register the TiVoDirectShowFilter.dll, rebooted the damn thing, and now it works. That was ODD! Chalk it up to windows being windows I guess. Sorry for the false alarm on this one.

    @miceland I replied to you on the VRD forum, as well, but, I would give these steps a try and see if you can open a TiVo file in VRD6. If so, then you should be good with the qsfix script. You'll need to grab Dan's pyTivo program which contains the tivomak.exe and the TiVoDirectShowFilter.dll file. You can just use his installer to register everything, or you can manually run the tivomak file with your MAK and then do regsvr32 TiVoDirectShowFilter.dll as admin and that should take care of your issue, too.
     
    mlippert likes this.
  8. Dec 12, 2019 #12508 of 12585
    elprice7345

    elprice7345 Member TCF Club

    346
    17
    Sep 28, 2009
    Denver, CO
    @moyekj and @davidblackledge: There was a lot of discussion after I made this request, but I'm not sure what the resolution was?

    @Dan203 Has a great app in pyTivo Desktop, but It would be great to be able to process all of my downloads in kmttg and not have to switch back and forth.
     
  9. Dec 12, 2019 #12509 of 12585
    moyekj

    moyekj Well-Known Member

    11,911
    663
    Jan 23, 2006
    Mission...
    I have no plans on making updates to kmttg related to the ts issue, or any major updates to kmttg at this point. Don't know if David has been looking into or not, but I doubt it.
     
  10. Dec 13, 2019 #12510 of 12585
    Lurker1

    Lurker1 Well-Known Member

    718
    322
    Jun 4, 2004
    @moyekj, thank you again for kmttg. It is an essential tool that I use every single day. I would likely get rid of TiVo if I could no longer use kmttg with it.
     
    leiff, reneg, snerd and 5 others like this.
  11. Dec 14, 2019 #12511 of 12585
    howards

    howards Member

    84
    5
    Oct 31, 2007
    Just started having a problem after running fine for years.

    When I try to start kmttg using: java -jar kmttg.jar

    I get the following messages:

    Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "main"
    Shutdown hook executing.
    Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "Thread-0"

    Anybody have a solution for me? TIA.
     
  12. Dec 14, 2019 #12512 of 12585
    mlippert

    mlippert Active Member

    284
    58
    Apr 2, 2010
    Massachusetts
    I don't have a solution, but something must have changed recently on your system.
    More information might help someone else to be able to help you. What OS are you running on? What version of java is running. Did a java update get installed recently? What version of kmttg?
     
  13. Dec 14, 2019 #12513 of 12585
    SamuriHL

    SamuriHL Member

    40
    10
    Jan 23, 2012
    My guess would be a java update. Just a guess.
     
    mlippert likes this.
  14. Dec 14, 2019 #12514 of 12585
    howards

    howards Member

    84
    5
    Oct 31, 2007
    kmttg v2.4o
    Windows 7
    Java 13.0.1

    The problem is related to a Java issue. If I go back to an old version of Java then kmttg runs okay. Would like it if I could run kmttg on the latest version of Java.
     
  15. Dec 14, 2019 #12515 of 12585
    ej42137

    ej42137 Well-Known Member

    3,622
    510
    Feb 15, 2014
    Los Angeles
    That's your problem, AFAIK kmttg won't run on anything but Oracle Java 1.8.
     
  16. Dec 14, 2019 #12516 of 12585
    minimeh

    minimeh Vanity Phrase Here

    329
    71
    Jun 20, 2011
    San Francisco
    There has been discussion on how later versions of Java than 1.8 are not supported.
     
    davidblackledge likes this.
  17. Dec 15, 2019 #12517 of 12585
    SamuriHL

    SamuriHL Member

    40
    10
    Jan 23, 2012
    You could install a private copy of java 8 and create a bat file to open kmttg with it. That way your system can use whatever version you want. I use the openjdk version of java 8 and haven't had any issues.

    Sent from my SM-G975U using Tapatalk
     
  18. Dec 27, 2019 #12518 of 12585
    FredT

    FredT Member

    47
    2
    Sep 26, 2013
    I have a problem downloading files from a TiVo Roamio to my Mac. The error returned is:

    http IO exception for: http://192.168.1.18:80/download/Whe...Playing&id=220393&Format=video/x-tivo-mpeg-ts
    Server returned HTTP response code: 403 for URL: http://192.168.1.18:80/download/Whe...Playing&id=220393&Format=video/x-tivo-mpeg-ts
    Download failed to file: /Video/_TiVi Files/Wheel of Fortune - Home for the Holidays - Day 4 (12_26_2019).TiVo

    I tried many different files, restarted the TiVo, restarted the router and Mac, etc. The only change I've made is a new router, but I successfully downloaded files since. I searched and found other instances of this problem in the forum, but I didn't find a solution that will fix my problem. I'm running version 2.4o and Java is up to date. Any suggestions would be greatly appreciated.
     
  19. Dec 28, 2019 #12519 of 12585
    minimeh

    minimeh Vanity Phrase Here

    329
    71
    Jun 20, 2011
    San Francisco
    That's a bit ambiguous. Kmttg is compatible with Java 1.8. The most up to date Java version is 13.0.1, which is incompatible.
     
  20. Dec 28, 2019 #12520 of 12585
    vanclute

    vanclute Member

    221
    8
    Aug 3, 2003
    Apologies in advance for asking something that might already be somewhere in the 626 pages of this thread., I just have no practical way to dig through it to find what I need.

    I'd like to try kmttg again on mac (having last tried it many years ago). It gets the content find from my TiVo, but the comskip portion fails. It just hangs on comskip_review.

    Does anyone know how to get the comskip portion to work on Mac? Running it on full auto resulted in very poor commercial detection, but running it on a manual review fails to produce the promised GUI so that I can check the detection and adjust as needed.
     

Share This Page