New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Aug 3, 2019 #12241 of 12890
    SteveG

    SteveG New Member

    12
    0
    Dec 28, 2001
    New Jersey

    Advertisements

    Channels question. I've used it before, but not working as I remember. I read through the thread and found the instructions in New program for 1 step TTG downloads, decryption, encoding - kmttg. (Post #12179 in this thread).

    Those instructions were:
    To copy a channel list to your new Bolt:
    • Load or Refresh a channel list.
    • Check or uncheck channels.
    • Click on Copy.
    • Select your Bolt.

    However, when I follow those steps, nothing happens. Clicking copy, it prompts for which tivo, but then just refreshes that tivo and doesn't actually update the channels list with checkmarks removed.

    Using 2.4m (and also tried 2.4l which is still available on my mac) and get the same result with both versions. The tivo's are Roamios (1 basic and 1 plus). Any ideas?
     
  2. Aug 3, 2019 #12242 of 12890
    worachj

    worachj Well-Known Member

    1,480
    120
    Oct 13, 2006
    Eagan, MN
    Does KMTTG see the new Bolt? When you click on Copy there should be a drop down list of TiVo's and you should see the new bolt listed.
     
  3. Aug 3, 2019 #12243 of 12890
    reneg

    reneg Well-Known Member

    1,145
    231
    Jun 19, 2002
    I think if you are checking or unchecking channels, you want to save them before you copy. Click Modify to save your changes before you click Copy
     
  4. Aug 3, 2019 #12244 of 12890
    SteveG

    SteveG New Member

    12
    0
    Dec 28, 2001
    New Jersey
    Thanks for the replies. KMTTG does see the new Roamio (the instructions I copied and pasted from the prior post mentioned a Bolt, but I'm working with a few roamios) and when I click copy, I do see a "Choose which Tivo to copy to" and can select the new Roamio. But then nothing happens. No messages in the bottom-half status section.

    I've tried 2 approaches.
    1. Refresh the current Tivo with the properly checked list of channels - the list populates with the correct channels checked
    2. Save... and save the file with the name Roamio.chan
    3. Load... and select the Roamio.chan file
    4. Click Copy..."Choose which Tivo to copy to" and selecting the new tivo, but then nothing happens.

    Test with current tivo:
    1. Refresh the current Tivo channel list- the list populates with the correct channels checked.
    2. Click a new channel just for testing
    3. Click Modify - Nothing seems to happen, but it does refresh and pull up the new channel list with the test channel properly checked.

    Repeat almost the same test with the new Tivo:
    1. Refresh the new Tivo channel list- the list populates with all the channels checked.
    2. UnClick a channel just for testing
    3. Click Modify - Nothing seems to happen, but it does refresh and pull up the channel list, but still with all channels checked.

    Tried next: Rebooted new Roamio
    Repeated above. No change after reboot.
    Tried with another pre-existing tivo and worked as expected.
    Tried modifying the channel list through the Tivo interface and then refreshing, and I need to try/check again, but think that also failed. So this seems more like a specific new Tivo problem. I've got to leave but want to post this before I forget. Will provide more details later after additional testing.

    Any suggestions appreciated. Might it just need time after the MAK was added when the Tivo was added to my account?
     
  5. Aug 3, 2019 #12245 of 12890
    SteveG

    SteveG New Member

    12
    0
    Dec 28, 2001
    New Jersey

    Advertisements

    Update: I've now confirmed, this doesn't seem to be a KMTTG issue. I've got 2 new Roamio's (a plus and a pro) and both of them even through the on-screen Channel List interface refuse to remove channels. Clicking select button on remote to remove the check mark and then going back or hitting Tivo button and then going back in shows no change, with the unchecked channels remaining checked. So I may need to call Tivo.

    An older Roamio basic and the Premiers these new Roamios are intended to replace work as expected (both through the on-screen UI and KMTTG).
     
  6. Aug 4, 2019 #12246 of 12890
    The TiVo Dude

    The TiVo Dude Member

    101
    0
    Jun 9, 2004
    KMTTG 101

    New to KMTTG. Awesome program/collection. Finding my way around and reading what I can find.

    Is there a post that suggests best file settings for storing the files on a NAS and using something like Plex or Infuse to play them on another device, i.e. AppleTV?

    Right now, I have the following boxes checked - decrypt, ad detect, ad cut, encode and have selected hb_television as the encoding profile - as much of the content I've created from blu-rays is currently stored as mkv (and the mpg files were "in a box" (not full screen) when played on the TV.)

    Also, it seems like I'm only getting an mkv if there is an ad cut?

    Am I missing anything?
     
    Last edited: Aug 4, 2019
  7. Aug 4, 2019 #12247 of 12890
    mlippert

    mlippert Active Member

    316
    76
    Apr 2, 2010
    Massachusetts
    @The TiVo Dude Welcome. KMTTG is an awesome tool.
    However, some things will require manual intervention. For example if you want to cut ads out of saved shows. Ad detect is great but cannot be relied on. Even if you're only doing it from the Tivo cut points you will still occasionally get some ads, but worse occasionally you will end up cutting portions of the show.

    I don't try to get the downloaded shows into the "correct" directory on my NAS, although I know there aere some people here who do. I put the downloaded shows in a single directory and move them once the final version (decrypted, ad cut, captions) is there. I do get kmttg to name them appropriately for Plex though. I use the following file naming configuration setting in kmttg which handles both series and movies:
    Code:
    [mainTitle] ["- s" season]["e" episode " - "][episodeTitle " "]["(" movieYear ") "]([month]_[mday]_[year], [channel])
     
    The TiVo Dude likes this.
  8. Aug 4, 2019 #12248 of 12890
    ej42137

    ej42137 Well-Known Member

    3,765
    586
    Feb 15, 2014
    Los Angeles
    kmttg doesn't directly process your videos; instead it directs other software programs to accomplish that task, either ffmpeg, HandBrake, or VideoReDo. Those programs have active forums where people discuss recipes for encoding video ad nauseum. I would start with the encoding profiles built into kmttg, and if I were unsatisfied with that result I'd go to the forums mentioned for further suggestions.

    If you are willing to spend a little money, VideoReDo is the easiest and most powerful video render program. HandBrake is free but it is more work and will require more research.
     
    The TiVo Dude likes this.
  9. Aug 4, 2019 #12249 of 12890
    The TiVo Dude

    The TiVo Dude Member

    101
    0
    Jun 9, 2004
    Thanks guys!
    Looks like VideoReDo is pc only (mac guy) so I'll have to stick with kmttg.
    I'll also stick with the ff_h264_high_rate - and will not delete the originals until I have confirmed the ad cut hasn't also performed program cut!
    Really appreciate the quick responses as I've only got a few weeks to clear the machine before it's decommissioned/lifetime transferred. ...and i've been wanting to get these performances off the TiVo anyway.
     
  10. Aug 7, 2019 #12250 of 12890
    Hcour

    Hcour Well-Known Member

    1,864
    529
    Dec 24, 2007
    I recently upgraded kmttg and java and somehow kmttg stopped working. I uninstalled and re-installed both per the instructions, including associating kmttg.jar with javaw.exe but it still doesn't work. The Properties for the kmttg folder has "Attributes: Read Only" box checked. Should that be unchecked? Thanks.
     
  11. Aug 7, 2019 #12251 of 12890
    jtdon99

    jtdon99 Member

    44
    6
    Oct 25, 2014
    lenior,nc
    You stated you upgraded the Java also, if that was v11 I don't think its works w/kmttg
     
  12. Aug 7, 2019 #12252 of 12890
    Hcour

    Hcour Well-Known Member

    1,864
    529
    Dec 24, 2007
    Yeah, when I re-installed it's ver 8. Thanks.
     
  13. Aug 14, 2019 #12253 of 12890
    justen_m

    justen_m Cheesehead TCF Club

    10,386
    822
    Jan 14, 2004
    Boise, ID
    Should have read this thread before I upgrade to Oracle Java 12. I can verify it doesn't work with kmttg. It was working fine on this box (Ubuntu 18.04.3LTS) with Oracle Java 8. Fudge. Now I have to figure out how to uninstall the new version of Java. Luckily, it still works on my four other Linux boxes and two Win10 boxes that have Java 8.

    sudo apt remove oracle-java12-installer
    sudo apt remove oracle-java11-installer local

    Ok, back to 8. kmttg works again.
     
  14. Aug 15, 2019 #12254 of 12890
    davidblackledge

    davidblackledge Registered l√úser

    563
    36
    Sep 9, 2008
    NM
    Yeah java 11 moved the javafx library into a separate download, so it could be fixed to work with newer Java by including the library download and changing the java startup command line to load it.
    I haven't tried this nor do I know if the library is something that could be redistributed with kmttg.
     
  15. Aug 16, 2019 #12255 of 12890
    Ian Westcott

    Ian Westcott New Member

    1
    2
    Aug 16, 2019
    I don't think people try this because details are extremely difficult to find. I scoured Oracle and Java's websites, and the same refrain is used: JavaFX is distributed with the JRE from version 8ish and up. Nowhere is it mentioned that JavaFX was removed from 11 or 12. If I go to the JavaFX FAQ, it says to download the JRE. If I go to the older FAQ and find a download link for a Linux .sh script that should set it up, that link takes me to a page saying that method was obsolete and that I should download the JRE, because that's where JavaFX is. The kmttg websites and wikis are the only place I can find that says recent Javas split off JavaFX again. I ended up downloading Java 8 and everything worked, but I was never able to find a download link for JavaFX in the Java website. If they do offer a more recent standalone JavaFX, they make it pretty hard to find.
     
    davidblackledge and mlippert like this.
  16. Aug 17, 2019 #12256 of 12890
    ej42137

    ej42137 Well-Known Member

    3,765
    586
    Feb 15, 2014
    Los Angeles
    I couldn't get kmttg to work with Java 11 or 12 even with JavaFX. If anyone ever did I'd like to hear about it.
     
    mlippert likes this.
  17. Aug 20, 2019 #12257 of 12890
    foxmulder241

    foxmulder241 New Member

    3
    0
    Jan 11, 2016
    I can not get my files to transfer from mytivo to pc using kmttg it worked before then I started trying monday and it wouldn't anymore

    This the message I get at the bottom

    AMHQ Weekend - 08-17-2019

    Recorded Sat 08/17/2019 02:58 AM on 776=TWCHD, Duration=182 mins, EpisodeNumber=201959, PAUSE POINT: 3 mins 56 secs, originalAirDate=2019-08-17
    The science and stories of weather, plus in-depth forecasts with a focus on weekend weather.

    >> DOWNLOADING FROM 'Hal 9000' C:\Users\Michael\Desktop\New folder (5)\AMHQ Weekend - 08-17-2019 (08_17_2019).TiVo ...

    http://10.0.0.248:80/download/AMHQ+Weekend.TiVo?Container=/NowPlaying&id=112988&Format=video/x-tivo-mpeg-ts

    http IO exception for: http://10.0.0.248:80/download/AMHQ+Weekend.TiVo?Container=/NowPlaying&id=112988&Format=video/x-tivo-mpeg-ts

    Server returned HTTP response code: 503 for URL: http://10.0.0.248:80/download/AMHQ+Weekend.TiVo?Container=/NowPlaying&id=112988&Format=video/x-tivo-mpeg-ts

    Download failed to file: C:\Users\Michael\Desktop\New folder (5)\AMHQ Weekend - 08-17-2019 (08_17_2019).TiVo

    A
     
  18. Aug 21, 2019 #12258 of 12890
    kpeters59

    kpeters59 Well-Known Member

    3,125
    645
    Jun 19, 2007
    Houston, Texas
    Try a different show.

    Try a different Disk/Drive.

    -KP
     
    foxmulder241 likes this.
  19. Aug 21, 2019 #12259 of 12890
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,476
    1,099
    Apr 6, 2000
    SF Bay Area
    This tells me that the Tivo server in the Tivo crashed.... Restart the Tivo.

    If this happens often, increase time it waits between downloads to about 30 seconds. (Options / Program Options [tab] / "Start Delay in seconds for download tasks")
     
    murgatroyd likes this.
  20. Aug 21, 2019 #12260 of 12890
    foxmulder241

    foxmulder241 New Member

    3
    0
    Jan 11, 2016
    Yes i tried a few different shows and I got one out of six of shows to transfer, i did to a restart of the tivobox I unplugged it and then pligged it back in after a couple minutes

    Thank you kpeters59 and thabto
     

Share This Page

spam firewall

Advertisements