New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Sep 13, 2018 #11981 of 12095
    aaronwt

    aaronwt UHD Addict

    22,037
    676
    Jan 31, 2002
    Northern...
    I thought the total capacity of the TiVo had to be manually input in kmttg? I remember having to do that with all my TiVos to have it show the correct storage available. But once entered it should remember it.

    Which reminds. me. I guess I need to check if there is a new kmttg available. I run mine as a service so it's rare that I actually open up the kmttg interface. SInce I have a headless PC dedicated to TiVo/kmttg.
     
  2. Sep 13, 2018 #11982 of 12095
    ThAbtO

    ThAbtO TiVoholic by the bay

    9,725
    531
    Apr 6, 2000
    SF Bay Area
    The exact space can be set automatically, through the Remote/Info tabs (RPC enabled)
     
  3. Sep 13, 2018 #11983 of 12095
    bradleys

    bradleys It'll be fine....

    4,057
    205
    Oct 31, 2007
    Space isn’t really the issue. The NPL list isn’t populating
     
  4. Sep 14, 2018 #11984 of 12095
    Soapm

    Soapm Active Member

    1,655
    6
    May 9, 2007
    Aurora, CO
    This is what I have in the file naming field on the file settings tab;

    [mainTitle][/][SeriesEpNumber] - [episodeTitle]

    Two movies I just transferred from my TivoHD came named like this;

    - .mpg

    What can I do to get the movie title and year while still getting the season, episode numbers and episode titles from TV shows?
     
  5. Sep 14, 2018 #11985 of 12095
    elprice7345

    elprice7345 Member TCF Club

    275
    9
    Sep 28, 2009
    Denver, CO
    Your use of [/] should have created a folder named [mainTitle] with a file named [SeriesEpNumber] - [episodeTitle].mpg

    Since the show is a movie, [SeriesEpNumber] and [episodeTitle] don’t exist and therefore are empty.

    Maybe you want something like @moyekj’s wiki example: [mainTitle] [" (" movieYear ")] [" (" SeriesEpNumber ") "][" - " episodeTitle]

    See: kmttg / Wiki / File_Naming
     
    Last edited: Sep 15, 2018
  6. Sep 14, 2018 #11986 of 12095
    Soapm

    Soapm Active Member

    1,655
    6
    May 9, 2007
    Aurora, CO
    Thanks, for shows I've always liked that it grouped them in a folder with the name of the show but I agree it's a bit of overkill for movies.

    I probably got my current naming scheme from the Wiki but it would have been many moons ago...
     
  7. Sep 14, 2018 #11987 of 12095
    bradleys

    bradleys It'll be fine....

    4,057
    205
    Oct 31, 2007
    I think I confused in my post when I mentioned dusk space:

    I am having issues with KMTTG this morning. I haven’t used it in a few months, so I am not sure when it started.

    It sees both of my TiVo’s and counts down the NPL list as normal. However, when it is done the display simply reads “No content in table”. The log doesn’t indicate any problems.

    It simply doesn’t draw the NPL

    I upgraded the most recent build “j” and updated the tools.
     
  8. Sep 15, 2018 #11988 of 12095
    kpeters59

    kpeters59 Well-Known Member

    1,653
    310
    Jun 19, 2007
    Houston, Texas
  9. Sep 18, 2018 #11989 of 12095
    bradleys

    bradleys It'll be fine....

    4,057
    205
    Oct 31, 2007
  10. Sep 18, 2018 #11990 of 12095
    ThAbtO

    ThAbtO TiVoholic by the bay

    9,725
    531
    Apr 6, 2000
    SF Bay Area
    How about a KMTTG screen shot?
     
  11. Sep 18, 2018 #11991 of 12095
    Soapm

    Soapm Active Member

    1,655
    6
    May 9, 2007
    Aurora, CO
    also, what kind of Tivo and are you using RPC?
     
  12. Sep 28, 2018 #11992 of 12095
    spammsmcghee

    spammsmcghee New Member

    27
    0
    Feb 19, 2010
    Seems I might be having the same issue. Can't get the NPL to populate on one of my XL4s. This just started happening yesterday. I've updated KMTTG to 2.4j (it was 2.4h), updated java, power-cycled the Tivo, verified it is connected to the internet through the wireless-G adapter, and restarted the computer for good measure.

    upload_2018-9-28_2-49-36.png
     
  13. Sep 28, 2018 #11993 of 12095
    ThAbtO

    ThAbtO TiVoholic by the bay

    9,725
    531
    Apr 6, 2000
    SF Bay Area
    "RemoteInit" = Network Remote control

    It must be off, or you could toggle it off then back on, then reboot (for good measure.)
     
  14. Sep 28, 2018 #11994 of 12095
    spammsmcghee

    spammsmcghee New Member

    27
    0
    Feb 19, 2010
    And where would I find that? I've been using these Tivos and KMTTG for several years, and I don't recall ever having to mess with it.
     
  15. Sep 28, 2018 #11995 of 12095
    ThAbtO

    ThAbtO TiVoholic by the bay

    9,725
    531
    Apr 6, 2000
    SF Bay Area
    It should be under Settings / remote (abouts) on the Tivo itself.
     
  16. Sep 28, 2018 #11996 of 12095
    moyekj

    moyekj Well-Known Member

    11,843
    545
    Jan 23, 2006
    Mission...
    Most likely that issue is that the IP kmttg is using doesn't match the IP of the XL4 unit. You can fix the IP manually for that TiVo under configuration--TiVo tab.
     
    kpeters59 likes this.
  17. Oct 1, 2018 #11997 of 12095
    worachj

    worachj Well-Known Member

    1,377
    76
    Oct 13, 2006
    Eagan, MN
    So thankful having the Season Premiere search at this time of the year for setting up new season passes and verifying that last year’s season passes still work and are compatible with the guide data! ‘Check OnePasses[z]’ on season passes also a great checking tool. Thanks!
     
    kpeters59, reneg and moyekj like this.
  18. Oct 5, 2018 #11998 of 12095
    Photo_Joe

    Photo_Joe New Member

    23
    1
    Feb 18, 2014
    Davis,...
    Roamio Plus on Comcast in California
    kmttg was working last night. Today I restarted my Mac and launched kmttg; now all of the Show listing from the TiVo on kmttg are shadded brown and copy protected. When I try to start a transfer job I get this message, "This show is copy protected - cannot process"

    I did not change any of the configurations in kmttg. I closed the program; restarted my computer and relaunched kmttg.... Any thoughts

    After posting the above I downloaded and reinstalled kmttg 2.4j and kmttg_MacOSX_tools_v2.1e

    I have two TiVos on a MoCA network. On kmttg the 6 tuner Roamio is showing all of the programs as being copy protected. On kmttg the 4 tuner Roamio the programs are not showing as being copy protected.

    After reinstalling kmttg, I rebooted my TiVo with the copy protection problem for the 3rd time and the problem has gone away (for now) ??
     
    Last edited: Oct 5, 2018
    mlippert likes this.
  19. Oct 13, 2018 #11999 of 12095
    Sbmocp

    Sbmocp Member

    132
    1
    Apr 19, 2001
    Hello!

    I've downloaded this program and am trying to install it on Windows 10. I've created a directory under C:\Program Files (and also tried it in C:\Program Files(x86) ) and get the same results each time I attempt to run it.

    I get an error about insufficient permissions for the directory. The .ini files can't be created, and the tools cannot be installed.

    I've checked and the user account has Admin privileges. What's the best way around this?

    Thanks in advance.
     
  20. Oct 13, 2018 #12000 of 12095
    mlippert

    mlippert Active Member

    220
    37
    Apr 2, 2010
    Massachusetts
    The best way is to give up on putting it in Program Files and just create the directory in the root, e.g. c:\kmttg, or actually anywhere other than Program Files such as \Users\uname\Documents\kmttg

    I fought this battle ages ago, it isn't worth it.
     

Share This Page