1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Mar 9, 2018 #11681 of 11948
    moyekj

    moyekj Well-Known Member

    11,804
    510
    Jan 23, 2006
    Mission...
    Quite the contrary unfortunately. TiVo has gone out of their way to kill off any/all 3rd party RPC access. With proper/official RPC access we could do so much more...
     
  2. Mar 9, 2018 #11682 of 11948
    moyekj

    moyekj Well-Known Member

    11,804
    510
    Jan 23, 2006
    Mission...
    v2.4g version is now released. Has "Find Remote" item for virtual remote and fixes for a couple of issues reported here recently in addition to the new RPC certificate to replace the one expiring soon.
    kmttg / Wiki / release_notes
     
    murgatroyd, humbb, Lurker1 and 3 others like this.
  3. Mar 9, 2018 #11683 of 11948
    DBrunetti

    DBrunetti Member

    87
    21
    Dec 6, 2016
    Connecticut
    Just installed the new version and tried the "Find Remote". Works great.
     
  4. Mar 9, 2018 #11684 of 11948
    murgatroyd

    murgatroyd Don't stop believin'

    26,070
    242
    Jan 5, 2002
    Berkeley CA
    What version of Java should we be at to make kmttg happy? I think I blew off the latest Java update notice because I didn't want to mess up kmttg -- is it okay to update now?
     
  5. Mar 9, 2018 #11685 of 11948
    murgatroyd

    murgatroyd Don't stop believin'

    26,070
    242
    Jan 5, 2002
    Berkeley CA
    Just installed the new version and tried the "find remote".

    Bonus feature -- if the cat is glued to my lap, and I can't get him to move, now I have a way to get him to leave. :D
     
    HerronScott likes this.
  6. Mar 9, 2018 #11686 of 11948
    wmcbrine

    wmcbrine Ziphead

    10,800
    217
    Aug 2, 2003
    AFAICT, it still governs the so-called telnet interface -- which I hope it always will, because there's zero security on that interface otherwise.
     
  7. Mar 12, 2018 #11687 of 11948
    badams888

    badams888 Member

    31
    5
    Jun 6, 2016
    I've got a roamio OTA 4 tuner tivo. I'm guessing that that unit does not support a find remote. When I click the find remote, I get:

    telnet - Failed to connect to host: 192.168.1.79
    telnet - connect timed out

    Does this only work with a remote that has some kind of sound or vibration? Mine is the stock remote that came with my tivo.
     
  8. Mar 12, 2018 #11688 of 11948
    moyekj

    moyekj Well-Known Member

    11,804
    510
    Jan 23, 2006
    Mission...
    You have to turn on "allow network remote" under settings on your Roamio to open up the telnet interface. Don't have the exact menu path for that, but somewhere under settings on your Roamio.
     
  9. Mar 12, 2018 #11689 of 11948
    JoeKustra

    JoeKustra in the other Alabama TCF Club

    13,226
    1,816
    Dec 7, 2012
    Ashland, PA...
    In Remote, CableCard & Devices. I'm not sure it still works.
     
  10. Mar 12, 2018 #11690 of 11948
    ThAbtO

    ThAbtO TiVoholic by the bay

    9,033
    370
    Apr 6, 2000
    SF Bay Area
    It still works
     
  11. Mar 13, 2018 #11691 of 11948
    snerd

    snerd Active Member

    833
    85
    Jun 6, 2008
    Thanks for the update and new feature.
    Nitpick: ToolTip for "Find Remote" is blank.
     
    moyekj likes this.
  12. Mar 13, 2018 #11692 of 11948
    badams888

    badams888 Member

    31
    5
    Jun 6, 2016
    Wow, thanks, didn't know that feature existed. I have 2 remotes, and they now both play a tune.

    Also, with the new column that shows the checkmarks, is there a way to determine which season pass an item in the todo list is from. Is this something that can be added to the info when one clicks on a show in todo? Some of mine (e.g. "basketball") might result from a few different season passes.
     
    Last edited: Mar 13, 2018
  13. Mar 24, 2018 #11693 of 11948
    HeatherA

    HeatherA Old AVS Forum Member

    962
    6
    Jan 9, 2002
    Any idea why a perfectly functioning KMTTG would suddenly start transferring only the audio of shows instead of the video? This started happening around 2/22 and I can not get it to transfer the full contents of a show/movie any longer. I had a ton of stuff I transferred and didn't look at and only realized today when the files were all extremely small sizes. I'm on the current version and updated Java and reinstalled fresh today. Same issue. I did update to Hydra, but only in the past few days so this predated that.
     
  14. Mar 24, 2018 #11694 of 11948
    ThAbtO

    ThAbtO TiVoholic by the bay

    9,033
    370
    Apr 6, 2000
    SF Bay Area
    The smaller size files mean its from a channel that is broadcasting in MPEG4 format and to transfer them, you need to enable"Transfer in Transport stream." then, try downloading it again.
     
    murgatroyd and HeatherA like this.
  15. Mar 24, 2018 #11695 of 11948
    HeatherA

    HeatherA Old AVS Forum Member

    962
    6
    Jan 9, 2002
    Thank you. I'll try that.
     
  16. Mar 24, 2018 #11696 of 11948
    HeatherA

    HeatherA Old AVS Forum Member

    962
    6
    Jan 9, 2002
    NVM I found it.
     
    Last edited: Mar 24, 2018
  17. Mar 24, 2018 #11697 of 11948
    reneg

    reneg Active Member

    943
    109
    Jun 19, 2002
    File->Configure->Program Options, 2nd checkbox down on the left side. Download Tivo files in Transport Stream format.
     
    HeatherA likes this.
  18. Mar 24, 2018 #11698 of 11948
    HeatherA

    HeatherA Old AVS Forum Member

    962
    6
    Jan 9, 2002
    Thank you!
     
  19. Mar 25, 2018 #11699 of 11948
    HerronScott

    HerronScott Well-Known Member

    5,841
    623
    Jan 1, 2002
    Staunton, VA
    I'm guessing you are on Comcast as they are moving to MPEG4 at least for non-broadcast channels (although someone I think in the Chicago area reported that they had moved a local broadcast channel there to MPEG4 as well).

    Scott
     
  20. Mar 25, 2018 #11700 of 11948
    HeatherA

    HeatherA Old AVS Forum Member

    962
    6
    Jan 9, 2002
    I am Comcast. We just moved to their area in January but I've just resumed transferring files in February so hadn't noticed... I think it's going to be tricky because not all seem to be in that format so I'm getting a lot of transfer errors. I'll need to spend more time fiddling. Or just stop archiving as much as I do.
     

Share This Page