1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Feb 7, 2018 #11641 of 11661
    moyekj

    moyekj Well-Known Member

    11,703
    390
    Jan 23, 2006
    Mission...
    It only works for telnet protocol as I didn't find an RPC equivalent that worked. So I've added to next release as a telnet button only. I found it to not be 100% reliable in triggering the remote to sing - sometimes pressing the button did nothing.
     
    ClearToLand and kpeters59 like this.
  2. Feb 8, 2018 #11642 of 11661
    allroader

    allroader New Member

    4
    0
    Jun 20, 2003
    It was a decryption error. Files now decrypting properly and transcoding. thanks
     
  3. Feb 10, 2018 #11643 of 11661
    murgatroyd

    murgatroyd Don't stop believin'

    25,718
    101
    Jan 5, 2002
    Berkeley CA
    Just tried to refresh the Now Playing list on my Roamio using v2.4f and got this:

    Code:
    RPC error response:
    
    {
    
       "code": "internalError",
    
       "debug": "0x30001",
    
       "text": "Error occurred while finding recordings.",
    
       "type": "error"
    
    }
    
    Trying to clear off recordings as much as I can to make space for the Olympics. I can just leave kmttg open and keep transferring recordings, but that will only go so far.
     
  4. Feb 11, 2018 #11644 of 11661
    Lurker1

    Lurker1 Active Member

    452
    129
    Jun 4, 2004
    moyekj, while watching the Olympics I noticed a strange problem with autoskip. I am not entirely sure what is happening, but I will describe the symptom which is consistent and repeatable.

    If I press the green button myself during a program, it will skip to the next start point and then immediately skip again to the next start point after that. I'm guessing there is some undesirable interaction between manual skip and autoskip, perhaps involving start/stop point padding? Please see if you can reproduce this behavior and figure out what is going on. I was skipping over boring parts of the opening ceremony, and then realized I was missing a lot more than I intended.

    EDIT: I changed my start point padding from 500 to 0 and the problem went away. Perhaps you shouldn't autoskip if the play position is in the pad after the actual start point.
     
    Last edited: Feb 11, 2018
  5. Feb 11, 2018 #11645 of 11661
    murgatroyd

    murgatroyd Don't stop believin'

    25,718
    101
    Jan 5, 2002
    Berkeley CA
    Still seeing the "0x30001" error but the NPL seems to be refreshing anyway. I haven't rebooted the Roamio because I haven't caught a moment where I wasn't watching or recording something.
     
  6. Feb 16, 2018 #11646 of 11661
    HollyJane

    HollyJane New Member

    16
    1
    Oct 18, 2017
    I got rid of our Tivo Premier and now we have a Tivo Bolt, which I've set up with kmttg. On the old box, I could right-click on a show and delete it from kmttg. On the Bolt, when I right-click on any show at all, the menu that appears has plenty of options but now "delete" is not one of them. I tried instead to select the show and hit delete, clear, cmd-delete, but no luck. No "delete" on any of the other menus that I can find, anyway. Anyone know how to delete now?
     
  7. Feb 16, 2018 #11647 of 11661
    mlippert

    mlippert Member

    157
    17
    Apr 2, 2010
    Massachusetts
    That's odd. Highlighting and hitting the delete key still works for me (on Win 7 java 1.8.0_161 kmttg v2.4f). And I just ran kmttg to look and delete is the 3rd item in my right click menu.

    I know that doesn't help, other than to say there's probably just some odd configuration thing going on w/ your setup. Hopefully someone else has already figured that out.
     
  8. Feb 16, 2018 #11648 of 11661
    ThAbtO

    ThAbtO TiVoholic by the bay

    8,263
    180
    Apr 6, 2000
    SF Bay Area
    Make sure RPC is enabled on the Bolt, under Config, Tivos Tab.
     
    HollyJane likes this.
  9. Feb 16, 2018 #11649 of 11661
    moyekj

    moyekj Well-Known Member

    11,703
    390
    Jan 23, 2006
    Mission...
    Yup, what he said.
     
    HollyJane and kpeters59 like this.
  10. Feb 16, 2018 #11650 of 11661
    mike386

    mike386 New Member

    27
    3
    Jan 17, 2009
    When I download a program a second time, kmttg should append a "(2)" to the end of the filename before the extension. However, I noticed that the "(2)" is appended to the folder name and it makes a new folder. Probably because that is the first space in the file path. The actual filename is not changed (just the folder in the file path).

    My download folder:
    C:\Users\xxx\Documents\My TiVo Recordings\DL

    Folder created by kmttg to store the second download of the same program:
    C:\Users\xxx\Documents\My(2).TiVo Recordings\DL
     
  11. Feb 16, 2018 #11651 of 11661
    moyekj

    moyekj Well-Known Member

    11,703
    390
    Jan 23, 2006
    Mission...
    No actually the logic is it looks for the first "." in the name assuming that is the file extension separator. I would suggest not using .TiVo as part of your file naming scheme to avoid the bad assumption for that case. i.e. Suggest you use "My TiVo Recordings" instead of "My .TiVo Recordings".
     
    kpeters59 likes this.
  12. HollyJane

    HollyJane New Member

    16
    1
    Oct 18, 2017
    Thanks SO much, that did the trick! Glad I came back to my post to check for replies. Whereas before this forum has always sent me an email when I received a reply to a post, it didn't do that this time for these replies, so I almost assumed there were none.
     
  13. JoeKustra

    JoeKustra in the other Alabama TCF Club

    10,391
    995
    Dec 7, 2012
    Ashland, PA...
    Tell the admin -> No longer receiving emails.
    Thanks
     
  14. mlippert

    mlippert Member

    157
    17
    Apr 2, 2010
    Massachusetts
    @moyekj I was just about to install Oracle Java on a new machine (OS is linux) and I was wondering whether to install Java 8 or Java 9.

    I know from past messages that there were some kmttg issues w/ Java 9, that I think were fixed, but are you regularly using 9 now or still 8?
     
  15. moyekj

    moyekj Well-Known Member

    11,703
    390
    Jan 23, 2006
    Mission...
    I'm on 8 to make sure when I compile it's compatible with 8, but I don't think there's any reason not to use 9.
     
  16. mlippert

    mlippert Member

    157
    17
    Apr 2, 2010
    Massachusetts
    Thanks
     
  17. stonewallers

    stonewallers Member

    38
    1
    Apr 8, 2010
    Thank you for this question. I'm about to (this weekend) build a new streaming/plex/tivo media server using ubuntu and was wondering about this. Could you possibly check in here in case there are any issues?

    I remember when I did my first linux install not too long ago I ran into issues with the getting/sourcing a wrong FFmpeg. Just trying to anticipate any issues with my upcoming build. (I was going to built with one of the new AMD ryzen 5 2400g APU but due to the issues with non-upated bios, reports of problems with linux, and questioning if I might run into compatibility issues having to use a recent version of ubuntu, I decided to stick with an intel i5 8400).
     
  18. mlippert

    mlippert Member

    157
    17
    Apr 2, 2010
    Massachusetts
    Sure no problem, although it's a slow process on my part. I also started a conversation w/ you directly in case the issues are too far off topic for this thread. (If they're related to kmttg I will definitely be mentioning them here.)
     
    Last edited: Feb 19, 2018 at 9:32 PM
  19. Taco Corp

    Taco Corp Member

    35
    4
    Jun 5, 2017
    Here's a bit of weirdness.

    *Don't know if this has been reported in this thread or elsewhere in the forum. Apologies if so.*

    This weekend I discovered that the kmttg RPC functions and the Tivo app on iOS will work with the "Network Remote" setting on the Tivo set to "Disabled". It had been turned off for months, went to pull some shows via kmttg and realized I never enabled the "Network Remote". Ooops. Anyone willing to try this out on their Tivo and confirm the same (either via kmttg RPC or the Tivo app)? I wonder if they've botched some of the settings in all of this UI screwyness they've introduced over the past several months.
     
  20. JoeKustra

    JoeKustra in the other Alabama TCF Club

    10,391
    995
    Dec 7, 2012
    Ashland, PA...
    I guess. I've had that option disabled for years. I would be surprised if it still does anything.
     

Share This Page