1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jan 5, 2018 #11541 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    severe, looks like you are running kmttg.jar from within the zip file which won't work. You need to completely extract the zip file to a folder on your computer and then run kmttg.jar from there, not within the zip file which looks like what you are doing.
     
    mlippert and severe like this.
  2. Jan 5, 2018 #11542 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    There was a change in RPC on TiVo server side which made the code to retrieve available seasons go into infinite loop and thus not return anything for many/most linear series. I've implemented a workaround for next release.
     
  3. Jan 5, 2018 #11543 of 11566
    severe

    severe Member

    74
    0
    Dec 11, 2009
    Yes! That was the issue.

    Thanks a ton.
     
  4. Jan 7, 2018 #11544 of 11566
    J_Palmer_Cass

    J_Palmer_Cass New Member

    6
    1
    Jan 1, 2018
    How much of TiVo Desktop is required to use KMTTG?

    Specifically, do we keep Bonjour installed if we only keep the minimum TiVo Desktop file installation?
     
  5. Jan 7, 2018 #11545 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    Don't need Bonjour (kmttg doesn't use it).
     
  6. Jan 7, 2018 #11546 of 11566
    ej42137

    ej42137 Well-Known Member

    2,612
    110
    Feb 15, 2014
    Los Angeles
    My Bolt+ only sees TiVo Desktop when it's set to Bonjour; my Roamio sees TiVo Desktop no matter what the network setting. Of course, if you're not actually running TiVo Desktop or don't have a Bolt this won't matter.
     
  7. Jan 11, 2018 #11547 of 11566
    sinanju

    sinanju Active Member

    824
    55
    Jan 3, 2005
    I've just moved to a new laptop. My employer, much to my chagrin, has replaced my Ubuntu system with a RHEL 7.4 system. I've moved kmttg over and gotten the following when trying to run:

    Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "main"
    Shutdown hook executing

    Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "Thread-0"​

    I've seen elsewhere in the thread that this is likely to be JavaFX related, but Oracle insists that this JDK contains JavaFX and there is no individual download for it anymore.

    java version "1.8.0_151"
    Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
    Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)​

    I tried Java 9 with the same bad results others upthread have experienced. Any would be advice appreciated.
     
  8. Jan 11, 2018 #11548 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    I run kmttg on CentOS 7.2 which is same as RHEL 7.2 and it runs fine, so RHEL 7.4 should work fine too. You need to check the java installation for javafx components. Go to top dir of JDK installation you are using and search for javafx. For installation I'm using currently (jdk1.8.0_144) I see this:
    Code:
    > find . -name "*javafx*"
    ./lib/javafx-mx.jar
    ./lib/ant-javafx.jar
    ./javafx-src.zip
    ./bin/javafxpackager
    ./jre/lib/javafx.properties
    ./jre/lib/amd64/libjavafx_font.so
    ./jre/lib/amd64/libjavafx_font_t2k.so
    ./jre/lib/amd64/libjavafx_iio.so
    ./jre/lib/amd64/libjavafx_font_freetype.so
    ./jre/lib/amd64/libjavafx_font_pango.so
    ./man/man1/javafxpackager.1
    ./man/ja_JP.UTF-8/man1/javafxpackager.1
    
     
  9. Jan 11, 2018 #11549 of 11566
    mlippert

    mlippert Member

    141
    14
    Apr 2, 2010
    Massachusetts
    Perhaps reinstalling Oracle Java8 would help.
    I just looked at my Linux Mint system (Ubuntu based so it doesn't match your setup, but) and I only had the openjdk java installed. I installed the PPA for Oracle Java and then installed Oracle Java 8. It paused the installation TWICE, once to agree to the license for Java (I didn't read it that closely) and then AGAIN to agree to the license for JavaFX and components.
    So perhaps although there is no separate javaFX install, on your system that part of the Oracle Java install was rejected? Hence no JavaFX.

    After the oracle java 8 install I did the find moyekj suggested in /usr and found this (on my Ubuntu based system):
    Code:
    $ find /usr -name "*javafx*"
    /usr/bin/javafxpackager
    /usr/share/mime/video/x-javafx.xml
    /usr/share/icons/breeze/mimetypes/64/video-x-javafx.svg
    /usr/share/icons/breeze/mimetypes/16/video-x-javafx.svg
    /usr/share/icons/breeze/mimetypes/32/video-x-javafx.svg
    /usr/share/icons/breeze/mimetypes/22/video-x-javafx.svg
    /usr/share/icons/oxygen/base/32x32/mimetypes/video-x-javafx.png
    /usr/share/icons/oxygen/base/128x128/mimetypes/video-x-javafx.png
    /usr/share/icons/oxygen/base/64x64/mimetypes/video-x-javafx.png
    /usr/share/icons/oxygen/base/16x16/mimetypes/video-x-javafx.png
    /usr/share/icons/oxygen/base/22x22/mimetypes/video-x-javafx.png
    /usr/share/icons/oxygen/base/256x256/mimetypes/video-x-javafx.png
    /usr/share/icons/oxygen/base/48x48/mimetypes/video-x-javafx.png
    /usr/share/icons/breeze-dark/mimetypes/64/video-x-javafx.svg
    /usr/share/icons/breeze-dark/mimetypes/16/video-x-javafx.svg
    /usr/share/icons/breeze-dark/mimetypes/32/video-x-javafx.svg
    /usr/share/icons/breeze-dark/mimetypes/22/video-x-javafx.svg
    /usr/share/man/man1/javafxpackager.1.gz
    /usr/lib/jvm/java-8-oracle/bin/javafxpackager
    /usr/lib/jvm/java-8-oracle/javafx-src.zip
    /usr/lib/jvm/java-8-oracle/man/ja_JP.UTF-8/man1/javafxpackager.1
    /usr/lib/jvm/java-8-oracle/man/man1/javafxpackager.1.gz
    /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libjavafx_font_t2k.so
    /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libjavafx_font_freetype.so
    /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libjavafx_iio.so
    /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libjavafx_font_pango.so
    /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libjavafx_font.so
    /usr/lib/jvm/java-8-oracle/jre/lib/javafx.properties
    /usr/lib/jvm/java-8-oracle/lib/ant-javafx.jar
    /usr/lib/jvm/java-8-oracle/lib/javafx-mx.jar
     
  10. Jan 11, 2018 #11550 of 11566
    slowbiscuit

    slowbiscuit FUBAR

    3,947
    202
    Sep 19, 2006
    In the ATL
    I've run into this too - Kevin was it ever fixed as a bug? Probably should be since there are times when no shows in NP will have skip but you still want the service to run for new shows (I have a daily task to collect new skip data). What's also aggravating is that you have to re-enable it on all Tivos and Minis if you start kmttg in foreground with no skip data in table and then get data. I have prune on refresh enabled so skip data is usually not more than a few shows.
     
    Last edited: Jan 11, 2018
  11. Jan 11, 2018 #11551 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    Was not aware of that issue. I've made a change for next release such that AutoSkip service will launch even with empty AutoSkip table. (There was a check in code to not launch if AutoSkip table empty).
     
    slowbiscuit, Lurker1 and foghorn2 like this.
  12. Jan 12, 2018 #11552 of 11566
    MLAKE1

    MLAKE1 Member

    189
    0
    Apr 8, 2002
    Norwalk, CT
    Hi all,

    I'm attempting to run the latest version of kmttg recently installed, and I'm getting an error message that reads "Could not find the main class: C:\kmttg\kmttg.jar. Program will exit." Anyone else had this, or know what I might be doing wrong?

    I'm running Windows 10 and Java 8, Update 151. I downloaded kmttg and unzipped all of the contents to C:\kmttg\ per the recommendation on the site.
     
  13. Jan 12, 2018 #11553 of 11566
    mlippert

    mlippert Member

    141
    14
    Apr 2, 2010
    Massachusetts
    I did a little research and found this stackoverflow question and then looked at the kmttg wiki page, which leads me to think you are attempting to run kmttg by "java c:\kmttg\kmttg.jar". You have to start it using "java -jar c:\kmttg\kmttg.jar", or it is likely you can just doubleclick on the jar file or create a desktop shortcut (see the wiki) although you may have to configure Windows to know how to deal appropriately with .jar files.
     
  14. Jan 12, 2018 #11554 of 11566
    MLAKE1

    MLAKE1 Member

    189
    0
    Apr 8, 2002
    Norwalk, CT
    Thanks mlippert for the reply. Unfortunately no dice - I get the same error when launching from the cmd line, as I do when double-clicking on the .jar file icon in the directory. I checked the file associations from the cmd line, and it's properly set for how the wiki shows to handle the jar files. And within the Windows directory, the icon association is correct as far as it showing the Java icon against the .jar file.
     
  15. Jan 12, 2018 #11555 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    MLAKE1, as mlippert mentioned that message does imply your system is attempting to launch the kmttg.jar file using following which is not correct:
    java c:\kmttg\kmttg.jar

    A properly configured Windows java installation should actually use this to launch when double-clicking the kmttg.jar file:
    javaw -jar c:\kmttg\kmttg.jar

    I'm pretty sure if you start a "cmd" (DOS) window and execute the following command it will work:
    java -jar c:\kmttg\kmttg.jar

    And if that's the case you can simply make a desktop shortcut that executes "javaw -jar c:\kmttg\kmttg.jar" as a workaround. A proper Java installation shouldn't have the problem.
     
    kpeters59 likes this.
  16. Jan 12, 2018 #11556 of 11566
    MLAKE1

    MLAKE1 Member

    189
    0
    Apr 8, 2002
    Norwalk, CT
    The "javaw" did it ... now I have it open. Thanks all.

    Is this the best route for me to take already-downloaded .TiVo files and convert them to .mp4?
     
  17. Jan 12, 2018 #11557 of 11566
    mlippert

    mlippert Member

    141
    14
    Apr 2, 2010
    Massachusetts
    Glad you got it working.

    As for is kmttg the best route to take your already downloaded .TiVo files and convert them to .mp4, My personal opinion is yes, but you may need other parts installed (you need to decode the .tivo files and there are various ways to do that, qsfix them, and then convert the decoded file to mp4 (h264), and I think kmttg can control various ways of doing that (VideoReDo, handbrake, ffmpeg). In addition it will depend somewhat on what codec your source .tivo files use (mpeg 2 or h264) depending on how the channel is delivered by your cable company to your tivo.
     
  18. Jan 13, 2018 #11558 of 11566
    wireman121

    wireman121 Member

    128
    0
    Nov 8, 2008
    Hey- Couple of questions:
    Can there be a way to loop autoskip from skipmode within the UI? I currently keep kmttg running on a PC at all times, and have Loop in GUI selected for auto transfers. I'd like to have the same option for autoskip, so anytime there is a new recording with skipdata, kmttg will automatically run autoskip from skipmode so by the time I watch it, it already has the autoskip table. Even if it is an extra checkbox for auto transfers on a global or per-show basis.

    In conjunction with that - I'd like to have the ability to specify which TiVo autoskip for skipmode runs on. Since Minis arent shown in kmttg, I'd like to specify a rarely used Mini for this operation so it can almost always run on that tivo without causing problems for me...

    I may be alone in looking for these things, but they would be a great help. I'd prefer not to create schedules and such for a second instance of kmttg when I already keep one running and looping in the GUI.
     
  19. Jan 14, 2018 #11559 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    The Windows scheduler is best suited for running AutoSkip from SkipMode and won't interfere with your kmttg GUI version:
    kmttg / Wiki / windows_task_scheduler
    You can specify which TiVo to use for it by name.
    You can actually specify a Mini using the batch/scheduler version, but it doesn't work properly to recognize skip points so don't bother trying. You can schedule the AutoSkip from SkipMode at a time when you and family are all sleeping.
     
    kpeters59 likes this.
  20. Jan 14, 2018 #11560 of 11566
    moyekj

    moyekj Well-Known Member

    11,669
    365
    Jan 23, 2006
    Mission...
    v2.4e version released with a couple of fixes:
    • Due to RPC changes on TiVo servers the "Start From" field of "Season Pass Options" form was not finding and populating available seasons. This release implements a workaround for that issue. There may be cases when not all available seasons are listed, but it should be better than before the workaround implementation.
    • AutoSkip service is now allowed to start with empty AutoSkip table.
     

Share This Page