New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jun 18, 2016 #9821 of 12918
    SameerUCLA

    SameerUCLA New Member

    16
    0
    Jul 15, 2009

    Advertisements

    Hi all,

    I'm having an issue with KMTTG (and cTivo) and could use your expert help.

    I've transferred video just fine with KMTTG in the past. However, when trying to transfer a news program from my TiVo to my Mac, the encoded MP4 file is only 77 MB (while the TiVo file is 2.98 GB), and the MP4 is audio only.

    I can't figure out what the configuration switch changed to make it audio only.

    Interestingly, the .ts file from the Tivolibre decrypt is also small -- only 89.7 MB.

    I'm having the same issue when I use cTivo.

    Any thoughts?


    THANKS!!

    - Sameer

    (p.s. it's a news broadcast featuring my 3- and 4-year old, so I really want so save it. Thanks in advance for any help!) :)
     
  2. Jun 18, 2016 #9822 of 12918
    Jester60

    Jester60 New Member

    23
    1
    Jun 15, 2016
    Rebooted the TIVO, router and laptop before posting (learned a long time ago ... first step when having computer issuses ... reboot).
     
  3. Jun 22, 2016 #9823 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    Hi-
    Can anyone help me with the settings required for getting good closed captions? I'm using a Roamio Plus and the captions are awful if i let kmttg decode the recording.

    I have a workaround, but it is a bit tedious. I download the recording as a .Tivo file, use the current version (0.81) of ccextractor on the Tivo file to crate a SRT file, then use VideoReDo to decode the file, and use MKVmerge to combine the SRT file and decoded Tivo file, and finally use VideoRedo to trim off the portions of the video I don't want.

    However, there is one major problem with this approach. ccextractor has a bit of a problem reading the Tivo file and drops quite a few of the captions. However, the timing of the subtitles is perfect Here's an example. First, if I let kmttg decode and extract:
    And next if I do everything manually:
    So, the file with the correct timing has 108 less captions, and the one with tall the captions is 7 seconds off.

    BTW, the timing problem is not in the extraction of the captions. VLC will let you see the captions in a MPG file, and the timing of captions is bad in the decoded file.

    So would anyone who is successfully extracting closed captions please help me out.

    Thanks in advance,

    Tim
     
  4. Jun 22, 2016 #9824 of 12918
    mattack

    mattack Well-Known Member

    25,442
    649
    Apr 9, 2001
    sunnyvale
    I think I'm essentially asking what you just answered, but I'm doing it on purpose to make it absolutely clear.

    So you're saying that the captions look fine *ON THE TIVO ORIGINALLY*, but having kmttg ***JUST DOWNLOAD AND DECRYPT** (no other steps), then watching that decrypted file, the captions are messed up?

    If so, that _seems_ impossible, since AFAIK, the ONLY difference between the file on the Tivo itself and the decrypted file is the encryption itself.

    Perhaps you're watching a different caption stream in the cases? AFAIK, even though everything is still digital nowadays, you still get so-called "analog captions" encoded in the video _too_. You could try seeing if a different caption 'channel' (forget the right term) has better captions. Sometimes it's for a different language, sometimes it's still English... (and no, I don't mean extra hard of hearing info)

    Now, going through a whole bunch of extra steps, especially reencoding, etc., can certainly mess them up.
     
  5. Jun 22, 2016 #9825 of 12918
    moyekj

    moyekj Well-Known Member

    12,295
    948
    Jan 23, 2006
    Mission...

    Advertisements

    Hyrax, you should try editing the .TiVo file directly with VRD, trim out commercials and save as decrypted .mpg or .ts, then extract captions from that.
     
  6. Jun 22, 2016 #9826 of 12918
    lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    The only way I have found to get good captions is to download in TS format.
     
  7. Jun 22, 2016 #9827 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    Yes, that is exactly what I am seeing... the caption timings are definitely different in the decoded mpg file than in the .Tivo file. It has been like that for many years. But now now that my hearing is fading along with my youth, it has become a big problem.
     
  8. Jun 22, 2016 #9828 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    Good idea! I'll try that.

    Thanks
     
  9. Jun 22, 2016 #9829 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    I tried that when it first became an option, but I thought it caused other problems. I'm trying it again now. Thanks for the suggestion.
     
  10. Jun 22, 2016 #9830 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    Worked perfectly! Thanks so much.
     
  11. Jun 22, 2016 #9831 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    That also seems to have fixed my problem, but VLC will not play back the .ts file. MPC-HC does play it, however.
     
  12. Jun 22, 2016 #9832 of 12918
    Soapm

    Soapm Active Member

    1,668
    9
    May 9, 2007
    Aurora, CO
    I am having this same problem, any ETR on the fix?

    Code:
    qsfix failed (exit code: 0 ) - check command: C:\WINDOWS\system32\cscript.exe //nologo C:\kmttg\VRDscripts\qsfix.vbs "E:\From Tivo\S02E201__Roots__.TiVo" "E:\From Tivo\S02E201__Roots__.mpg.qsfix" /l:D:\Chuck\LOCALS~1\Temp\VRDLock163819396642291927.tmp /m /c:mpeg /v:mpeg2video /x:528 /y:480 
    
    C:\kmttg\VRDscripts\qsfix.vbs(131, 4) (null): The server threw an exception. 
     
  13. Jun 22, 2016 #9833 of 12918
    howards

    howards Member

    84
    5
    Oct 31, 2007
    VLC plays back TS files for me. Perhaps you don't have Tivo Desktop installed (needed for its decoder)?
     
  14. Jun 22, 2016 #9834 of 12918
    lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    A .ts file should already be decrypted.
     
  15. Jun 22, 2016 #9835 of 12918
    moyekj

    moyekj Well-Known Member

    12,295
    948
    Jan 23, 2006
    Mission...
    Doesn't look like the same problem. Line 131 is attempting to write output file which is failing. If you continue to have the problem you could try and use current non-beta release of VRD to see if that fixes the issue, but like I said appears to be a different problem.
     
  16. Jun 23, 2016 #9836 of 12918
    Soapm

    Soapm Active Member

    1,668
    9
    May 9, 2007
    Aurora, CO
    What could cause that error?

    I used the changes listed above to pull the file as ts but can't get it to encode. It seems to be having trouble writing to E:/Ready/. This was using both HB and ffmpeg so I know it's something weird.
     
  17. Jun 23, 2016 #9837 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    I do have Tivo Desktop installed ... VRD also requires it, I think. VLC plays most .TS files for me, just not the ones created by KMTTG.
     
  18. Jun 23, 2016 #9838 of 12918
    lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    What are you using to decrypt?
     
  19. Jun 23, 2016 #9839 of 12918
    Hyrax

    Hyrax Member

    119
    3
    Sep 1, 2007
    I've tried all of the available options. I think I'm currently using tivolibre in Directshow comparability mode. However, I found the advice to download the Tivo file, edit it with VRD, write out a .TS file (no recoding), then use ccextractor to be the easiest workflow.
     
  20. Jun 23, 2016 #9840 of 12918
    Bane7

    Bane7 New Member

    15
    1
    Jun 23, 2016
    The windows tools are failing to download in kmttg with the below error:


    Connection error: Connection timed out: connect"

    I can download the package manually without issue from sourceforge. Are there manual install instructions for the tools? Is it as simple as putting a path to the tools in the configuration page?

    Thanks,
     

Share This Page

spam firewall

Advertisements